Bug 23032 - Incorrect page width in Trojita webview after regression of qtwebkit5
Summary: Incorrect page width in Trojita webview after regression of qtwebkit5
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: mga6-64-ok
Keywords: advisory, validated_update
Depends on:
Blocks: 23034
  Show dependency treegraph
 
Reported: 2018-05-14 07:13 CEST by Dimitrios Glentadakis
Modified: 2018-06-03 13:03 CEST (History)
8 users (show)

See Also:
Source RPM: qtwebkit5-5.212.0-1.alpha2.7.mga6.src.rpm
CVE:
Status comment:


Attachments
trojita_screenshot_before_update.png (99.22 KB, image/png)
2018-06-01 17:08 CEST, PC LX
Details
trojita_screenshot_after_update.png (131.34 KB, image/png)
2018-06-01 17:09 CEST, PC LX
Details

Description Dimitrios Glentadakis 2018-05-14 07:13:45 CEST
Here the report :

https://github.com/annulen/webkit/issues/511

I tested the given patch and it solves the problem
Comment 1 David GEIGER 2018-05-14 12:02:19 CEST
Assigning to QA,


Advisory:
=============================

A regression was found in current qtwebkit5 package that cause incorrect page width for plain text messages especially in Trojita.
This update fixes this issue.

For reference:
https://github.com/annulen/webkit/issues/511



Packages in 6/core/updates_testing:
========================
qtwebkit5-5.212.0-1.alpha2.7.1.mga6.i586.rpm
libqt5webkitwidgets5-5.212.0-1.alpha2.7.1.mga6.i586.rpm
libqt5webkitwidgets-devel-5.212.0-1.alpha2.7.1.mga6.i586.rpm
libqt5webkit5-5.212.0-1.alpha2.7.1.mga6.i586.rpm
libqt5webkit-devel-5.212.0-1.alpha2.7.1.mga6.i586.rpm

qtwebkit5-5.212.0-1.alpha2.7.1.mga6.x86_64.rpm
lib64qt5webkitwidgets5-5.212.0-1.alpha2.7.1.mga6.x86_64.rpm
lib64qt5webkitwidgets-devel-5.212.0-1.alpha2.7.1.mga6.x86_64.rpm
lib64qt5webkit5-5.212.0-1.alpha2.7.1.mga6.x86_64.rpm
lib64qt5webkit-devel-5.212.0-1.alpha2.7.1.mga6.x86_64.rpm

Source RPM: 
========================
qtwebkit5-5.212.0-1.alpha2.7.1.mga6.src.rpm

Source RPM: qtwebkit5 => qtwebkit5-5.212.0-1.alpha2.7.mga6.src.rpm
Assignee: geiger.david68210 => qa-bugs

David GEIGER 2018-05-15 05:43:19 CEST

Depends on: (none) => 23034
CC: (none) => geiger.david68210

David GEIGER 2018-05-15 15:59:02 CEST

Depends on: 23034 => (none)
Blocks: (none) => 23034

Comment 2 Len Lawrence 2018-06-01 15:43:49 CEST
Yes, I looked at it when it was first posted and tried to open an imail account with trojita and failed at the password.  Another password forgotten and there are more than a hundred.  I don't know how many times I have gone through this loop to reset my password.  I don't want to jeopardize my existing imail connection via Thunderbird so I backed out.

CC: (none) => tarazed25

Comment 3 Bill Wilkinson 2018-06-01 16:16:11 CEST
Tested mga6-64. Was able to log into gmail account, download and delete messages.  Due to the name of the sent messages folder in gmail, "sent messages" was unable to send a message.  Plain text and html email display properly.

Whiteboard: (none) => mga6-64-ok
CC: (none) => wrw105

Comment 4 PC LX 2018-06-01 17:08:01 CEST
Installed and minimally tested without issue.

I only did some testing for this particular issue and, since I don't normally use Trojita, there may exist regressions I didn't notice. It would be better if a regular Trojita user tested this update.

See screen shots from before and after update.

System: MAgeia 6, x86_64, Plasma DE, intel CPU, nVidia GPU using nvidia340 proprietary driver.

$ uname -a
Linux marte 4.14.44-desktop-2.mga6 #1 SMP Mon May 28 22:35:45 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
$ # BEFORE UPDATE
$ rpm -qa | grep lib64qt5webkit
lib64qt5webkitwidgets5-5.212.0-1.alpha2.7.mga6
lib64qt5webkit5-5.212.0-1.alpha2.7.mga6
$ # AFTER UPDATE
$ rpm -qa | grep lib64qt5webkit
lib64qt5webkit5-5.212.0-1.alpha2.7.1.mga6
lib64qt5webkitwidgets5-5.212.0-1.alpha2.7.1.mga6

CC: (none) => mageia

Comment 5 PC LX 2018-06-01 17:08:33 CEST
Created attachment 10211 [details]
trojita_screenshot_before_update.png
Comment 6 PC LX 2018-06-01 17:09:21 CEST
Created attachment 10212 [details]
trojita_screenshot_after_update.png
Comment 7 Thomas Andrews 2018-06-01 21:17:00 CEST
Looks good enough to me. Validating, advisory in Comment 1.

Keywords: (none) => validated_update
CC: (none) => andrewsfarm, sysadmin-bugs

Comment 8 peter winterflood 2018-06-01 23:10:25 CEST
also tested it , no problems displays fine.
nice alternative to thunderbird
never tried it before

CC: (none) => peter.winterflood

Thomas Backlund 2018-06-03 12:40:49 CEST

Keywords: (none) => advisory
CC: (none) => tmb

Comment 9 Mageia Robot 2018-06-03 13:03:19 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0106.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.