Bug 23025 - kdenlive missing dependency
Summary: kdenlive missing dependency
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal critical
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-05-13 04:27 CEST by nikos papadopoulos
Modified: 2018-05-28 01:26 CEST (History)
4 users (show)

See Also:
Source RPM: kdenlive-17.12.2-1.mga6.src.rpm
CVE:
Status comment:


Attachments

Description nikos papadopoulos 2018-05-13 04:27:45 CEST
Description of problem:
Kdenlive won't start.

How reproducible:
Everytime.



The console gives the following...

   [bash 4.3]$ kdenlive
   ++++++++
   Switching audio backend to:  "sdl_audio" 
   ++++++++++
   qrc:/qml/kdenliveclipmonitor.qml:3:1: module "QtQuick" is not installed
   Σφάλμα κατάτμησης (segmentation fault) (core dumped)


According to this...
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822279
...kdenlive needs...
   qml-module-qtquick-controls

I tried various unsuccessful ways to find out which "quick" package is missing.

Then I downloaded the above mentioned .deb file.
Basically it contains the file...
   libqtquick2plugin.so

In Mageia, that is in rpm...
   qtdeclarative5

Who would have though?

After installing...
   qtdeclarative5-5.9.4-1.mga6.x86_64
...and its dependencies, 
kdenlive started!
Comment 1 nikos papadopoulos 2018-05-13 04:30:19 CEST
The packages that got installed were...
- lib64qt5quickparticles5-5.9.4-1.mga6.x86_64
- lib64qt5quicktest5-5.9.4-1.mga6.x86_64
- lib64qt5test5-5.9.4-1.1.mga6.x86_64
- lib64qt5xmlpatterns5-5.9.4-1.mga6.x86_64
- qtdeclarative5-5.9.4-1.mga6.x86_64
- qtxmlpatterns5-xmlpatterns-5.9.4-1.mga6.x86_64
Comment 2 David GEIGER 2018-05-13 07:58:09 CEST
Hi,

Thanks for your report!

Should be fixed with kdenlive-17.12.2-1.1.mga6 in Core/Updates_testing repo.

Please test it, thanks in advance.

Also fixed for Cauldron.

CC: (none) => geiger.david68210

Marja Van Waes 2018-05-13 13:32:08 CEST

CC: (none) => marja11
Assignee: bugsquad => kde

Comment 3 nikos papadopoulos 2018-05-14 23:00:55 CEST
Ok, I uninstalled ...
- kdenlive-17.12.2-1.mga6.x86_64
- mlt-kdenlive-6.4.1-3.mga6.x86_64
- qtdeclarative5-5.9.4-1.mga6.x86_64

Then, from Core/Updates_testing, I installed...
   kdenlive-17.12.2-1.1.mga6.x86_64
and the machine also asked me to install
   qtdeclarative5

Started kdenlive.
Opened a project, etc...
Seems to work allright.
Comment 4 José Jorge 2018-05-27 07:39:51 CEST
Looks like this bug was never pushed to QA, doing it. Tagging 64 bits Ok according to comment 3.

Assignee: kde => qa-bugs
Status: NEW => ASSIGNED
Whiteboard: (none) => MGA6-64-OK
CC: (none) => lists.jjorge

Comment 5 Lewis Smith 2018-05-27 19:00:33 CEST
Thank you Nikos for your thorough research of the cause, and test of the update.

Confirming theoretically M6/64:

BEFORE update: kdenlive-17.12.2-1.mga6
 $ urpmq --requires kdenlive | grep qtdeclarative5
 $

AFTER update: kdenlive-17.12.2-1.1.mga6
 $ urpmq  --search-media 'updates testing' --requires kdenlive | grep qtdeclarative5
 qtdeclarative5
 $
shows that 'qtdeclarative5' is now added as a requirement of kdenlive.

Advisory made from comments 0 and 2. Validating.

Keywords: (none) => advisory, validated_update
CC: (none) => sysadmin-bugs

Comment 6 Mageia Robot 2018-05-28 01:26:14 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0100.html

Resolution: (none) => FIXED
Status: ASSIGNED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.