Bug 23014 - Backport Candidate: PyCharm-Community 2018.1.2
Summary: Backport Candidate: PyCharm-Community 2018.1.2
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: validated_backport
Depends on:
Blocks:
 
Reported: 2018-05-11 11:38 CEST by Stig-Ørjan Smelror
Modified: 2018-06-03 13:12 CEST (History)
2 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Stig-Ørjan Smelror 2018-05-11 11:38:20 CEST
Advisory
========

PyCharm-Community has been backported from Cauldron.


Files
=====

Uploaded to core/backports_testing

pycharm-community-2018.1.2-1.mga6
pycharm-community-doc-2018.1.2-1.mga6
pycharm-community-plugins-2018.1.2-1.mga6

from pycharm-community-2018.1.2-1.mga6.src.rpm
Comment 1 Len Lawrence 2018-05-29 00:59:08 CEST
Mageia 6, x86_64

Installed the packages and launched the Pycharm IDE to get an idea of how it worked.

Back on this tomorrow with a simple python project, hopefully.

CC: (none) => tarazed25

Comment 2 Len Lawrence 2018-05-29 18:36:08 CEST
Continued investigating the Pycharm interface and tried the virtual environment option.  Set it up and then abandoned it because I did not really know what I was doing
Managed to find a reasonably complex program to code, an ASCII art converter for images, found in a Python ebook.  Used emacs outside the IDE to edit the code, to speed things up, and then imported it into Pycharm for testing.  Edited it in the interface to get rid of a couple of errors and ran it in the built in terminal emulator to generate an ASCII art text file which could be viewed in a normal terminal using 'cat'.  That is as far as I go with this.  There is obviously a lot more to using it than this sketchy outline but it certainly works OK for a newbie.

Whiteboard: (none) => MGA6-64-OK

Len Lawrence 2018-06-02 08:43:32 CEST

Keywords: (none) => validated_backport

Comment 3 Thomas Backlund 2018-06-03 13:12:03 CEST
package moved

CC: (none) => tmb
Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.