Bug 22979 - QGIS is missing lib64qt4-database-plugin-sqlite
Summary: QGIS is missing lib64qt4-database-plugin-sqlite
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-05-01 15:16 CEST by Patric Schramm
Modified: 2018-05-22 01:54 CEST (History)
5 users (show)

See Also:
Source RPM: qgis-2.14.7-1.mga6.src.rpm
CVE:
Status comment:


Attachments

Description Patric Schramm 2018-05-01 15:16:23 CEST
Description of problem: After a fresh install of MGA 6 64bit with the Mate Desktop i installed qgis. When launching the application qgis was nagging that the bookmark database (and other databases) where not running because the driver wasnt loaded. After a bit of research i found that lib64qt4-database-plugin-sqlite was not installed. This should be added as a depency to fix the problem.


Version-Release number of selected component (if applicable):
2.14-7


How reproducible: 
Every startup of qgis .


Steps to Reproduce:
1.urpmi qgis 
2.start qgis from the terminal
3.you see in the log that the database is not up and running
Comment 1 Marja Van Waes 2018-05-01 21:45:42 CEST
Assigning to the registered maintainer.

CC: (none) => marja11
Assignee: bugsquad => dglent

Stig-Ørjan Smelror 2018-05-02 20:51:29 CEST

CC: (none) => smelror
Assignee: dglent => smelror

Comment 2 Stig-Ørjan Smelror 2018-05-02 23:31:06 CEST
Advisory
========

Qgis has been updated to add an extra requires for a missing package needed to run the application.

References
==========
https://bugs.mageia.org/show_bug.cgi?id=22979

Files
=====

Uploaded to core/updates_testing:

python-qgis-2.14.7-1.1.mga6
qgis-2.14.7-1.1.mga6
qgis-grass-2.14.7-1.1.mga6
qgis-devel-2.14.7-1.1.mga6
qgis-debuginfo-2.14.7-1.1.mga6

from qgis-2.14.7-1.1.mga6.src.rpm
Stig-Ørjan Smelror 2018-05-02 23:31:20 CEST

Assignee: smelror => qa-bugs

Comment 3 Stig-Ørjan Smelror 2018-05-08 10:21:30 CEST
Package has also been updated in Cauldron.
Comment 4 Lewis Smith 2018-05-20 21:54:36 CEST
Testing M6/64

Installing issued qgis/qgis-grass/python-qgis wanted to pull in in 109 pkgs (lots of Qt4 stuff) demanding >700Mb of disc space and 170Mb downloads. Not worth doing, because I already had (required by Clementine):
 lib64qt4-database-plugin-sqlite-4.8.7-15.mga6
which according to the reporter is that required by qgis.
But I did *not* have the requirement added by this update:
 qt4-database-plugin-sqlite

So did a paper exercise:
BEFORE update:
 $ urpmq --requires qgis | grep sqlite
 libsqlite3.so.0()(64bit)
and NOT the library cite in c0, nor that addded by this update.

AFTER update (i.e. referencing Updates Testing):
 $ urpmq --requires qgis | grep sqlite
qgis: libsqlite3.so.0()(64bit)
qgis: qt4-database-plugin-sqlite          [added by this update]
 but NOT lib64qt4-database-plugin-sqlite.

Fine, qgis now requires qt4-database-plugin-sqlite which it did not do before; but the package names are inconsistent, not that in c0, so asking for feedback for clarification.

Keywords: (none) => feedback
CC: (none) => lewyssmith

Comment 5 Stig-Ørjan Smelror 2018-05-20 21:59:06 CEST
Lewys.

AFAIK, this is the correct package.

$ urpmq -yfi qt4-database-plugin-sqlite
Name        : libqt4-database-plugin-sqlite
Version     : 4.8.7
Release     : 15.mga6
Group       : Databases
Size        : 49340                        Architecture: i586
Source RPM  : qt4-4.8.7-15.mga6.src.rpm      Build Host: rabbit.mageia.org
Packager    : mrambo3501 <mrambo3501>
URL         : http://qt-project.org/
Summary     : Qt4 SQLITE Database Plugin
Description :
The Qt SQLite plugin makes it possible to access SQLite databases.
Name        : lib64qt4-database-plugin-sqlite
Version     : 4.8.7
Release     : 15.mga6
Group       : Databases
Size        : 54768                        Architecture: x86_64
Source RPM  : qt4-4.8.7-15.mga6.src.rpm      Build Host: ecosse.mageia.org
Packager    : mrambo3501 <mrambo3501>
URL         : http://qt-project.org/
Summary     : Qt4 SQLITE Database Plugin
Description :
The Qt SQLite plugin makes it possible to access SQLite databases.
Comment 6 José Jorge 2018-05-21 10:49:19 CEST
(In reply to Lewis Smith from comment #4)
>  I already had (required by Clementine):
>  lib64qt4-database-plugin-sqlite-4.8.7-15.mga6
> which according to the reporter is that required by qgis.
> But I did *not* have the requirement added by this update:
>  qt4-database-plugin-sqlite

In fact package lib64qt4-database-plugin-sqlite provides qt4-database-plugin-sqlite, as does libqt4-database-plugin-sqlite for 32 bit. This is the mageia simple way to have one requires for both arches.

CC: (none) => lists.jjorge

Comment 7 Lewis Smith 2018-05-21 19:43:45 CEST
Thanks for comments 5 & 6. In which case comment 4 makes a valid test.

Whiteboard: (none) => MGA6-64-OK
Keywords: feedback => advisory, validated_update
CC: (none) => sysadmin-bugs

Comment 8 Mageia Robot 2018-05-22 01:54:31 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0092.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.