Bug 22770 - skrooge terminates with message: ##FATAL: Cannot mix incompatible Qt library (version 0x50903) with this library (version 0x50904)
Summary: skrooge terminates with message: ##FATAL: Cannot mix incompatible Qt library ...
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal critical
Target Milestone: ---
Assignee: Nicolas Lécureuil
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 22660
  Show dependency treegraph
 
Reported: 2018-03-14 11:57 CET by PC LX
Modified: 2018-04-06 10:42 CEST (History)
4 users (show)

See Also:
Source RPM: skrooge-2.10.5-1.1.mga6.src.rpm
CVE:
Status comment:


Attachments

Description PC LX 2018-03-14 11:57:19 CET
Description of problem:

skrooge terminates with the message:
> ##FATAL: Cannot mix incompatible Qt library (version 0x50903) with this library (version 0x50904)



Version-Release number of selected component (if applicable):

These are the packages that were installed along with skrooge:
  lib64ofx6                      0.9.10       1.mga6        x86_64  
  lib64osp5                      1.5.2        16.mga6       x86_64  
  lib64sqlcipher0                3.3.1        3.mga6        x86_64  
  libofx                         0.9.10       1.mga6        x86_64  
  lib64skgbankgui2               2.10.5       1.1.mga6      x86_64  
  lib64skgbankmodeler2           2.10.5       1.1.mga6      x86_64  
  lib64skgbasegui2               2.10.5       1.1.mga6      x86_64  
  lib64skgbasemodeler2           2.10.5       1.1.mga6      x86_64  
  skrooge                        2.10.5       1.1.mga6      x86_64  

Have installed Qt 5.9.4 and KDE/KF5/Plasma packages from testing.



How reproducible:

Always.



Steps to Reproduce:
1. Install skrooge (urpmi skrooge).
2. Run skrooge in a terminal.
3. See "FATAL" error message.
Comment 1 PC LX 2018-03-14 11:58:11 CET
Forgot to mention that I don't have any Qt 5.9.3 packages installed. All Qt packages are 5.9.4.
Morgan Leijström 2018-03-14 12:32:38 CET

Blocks: (none) => 22660

Comment 2 Morgan Leijström 2018-03-14 12:35:28 CET
I am seeing this too.
Tested it now just because i saw this report, thanks.
I updated everything to testing versions a couple days ago.
Everything else i use are working so far.

CC: (none) => fri

Comment 3 Marja Van Waes 2018-03-14 13:25:41 CET
Assigning to the registered maintainer.

CC: (none) => geiger.david68210, marja11
Assignee: bugsquad => mageia

Comment 4 Marja Van Waes 2018-03-14 13:27:57 CET
Oh, just noticed skrooge was rebuilt.

Please try with skrooge-2.10.5-1.2.mga6 from 6 core/updates_testing
Comment 5 Thomas Andrews 2018-03-14 14:24:52 CET
I don't use skrooge, but I tried it when I saw this bug. Confirming that with the older version, it did not launch.

With the updated version, it starts without apparent incident when launched from the Plasma menu. When launched from Konsole using the command "skrooge" it launches successfully, but these messages appear in Konsole:

##WARNING: libpng warning: iCCP: known incorrect sRGB profile
##WARNING: libpng warning: iCCP: known incorrect sRGB profile
##WARNING: Icon [preview] not found
##WARNING: Icon [exchange-positions] not found
##WARNING: Icon [exchange-positions] not found
##WARNING: Icon [exchange-positions] not found
##WARNING: Icon [exchange-positions] not found
##WARNING: Icon [exchange-positions] not found
##WARNING: Icon [exchange-positions] not found

Checking on an install still running Plasma 5.8.x, there are no messages at all when it is launched from Konsole.

CC: (none) => andrewsfarm

Comment 6 Morgan Leijström 2018-03-14 15:03:23 CET
skrooge-2.10.5-1.2.mga6 launches OK here too, 64 bit, Plasma 5.12 et al

Output in terminal from where i launch skrooge contain same warnings TA sees except i dont see the "Icon [preview]" line.

Closing it, i see

##WARNING: QXcbConnection: XCB error: 3 (BadWindow), sequence: 6712, resource id: 41989131, major code: 40 (TranslateCoords), minor code: 0

I see similar warnings often in journal
Comment 7 PC LX 2018-03-14 18:28:26 CET
I'm seeing something strange when trying to install skrooge. 
In the list of packages to install two packages (lib64skgbankgui2 and lib64skgbasemodeler2) are shown twice.
I'm not certain if this is a bug in urpmi or some issue with the skrooge package.

$ LANGUAGE=C urpmi skrooge --test
To satisfy dependencies, the following packages are going to be installed:
(test only, installation will not be actually done)
  Package                        Version      Release       Arch    
(medium "Core Release")
  lib64ofx6                      0.9.10       1.mga6        x86_64  
  lib64osp5                      1.5.2        16.mga6       x86_64  
  lib64sqlcipher0                3.3.1        3.mga6        x86_64  
  libofx                         0.9.10       1.mga6        x86_64  
(medium "Core Updates Testing")
  lib64skgbankgui2               2.10.5       1.2.mga6      x86_64  
  lib64skgbankmodeler2           2.10.5       1.2.mga6      x86_64  
  lib64skgbasegui2               2.10.5       1.2.mga6      x86_64  
  lib64skgbasemodeler2           2.10.5       1.2.mga6      x86_64  
  skrooge                        2.10.5       1.2.mga6      x86_64  
28MB of additional disk space will be used.
12MB of packages will be retrieved.
Proceed with the installation of the 9 packages? (Y/n) n
Comment 8 Morgan Leijström 2018-03-14 21:52:04 CET
Yes the two duplets is odd (seen here too)
Comment 9 PC LX 2018-04-06 10:42:17 CEST
This issue is resolved, at least here.

Skrooge starts OK, loads existing document, can add new entries, saves documents, all without issues.

If someone else could confirm it works for them, this issue could be closed as resolved.

Note You need to log in before you can comment on or make changes to this bug.