Bug 22747 - google-earth won't install due to missing mesa-libGLU -- exists as libGLU
Summary: google-earth won't install due to missing mesa-libGLU -- exists as libGLU
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-03-11 17:34 CET by Pierre Fortin
Modified: 2018-03-22 23:40 CET (History)
5 users (show)

See Also:
Source RPM: glu-9.0.0-6.mga6, glu-9.0.0-6.mga7
CVE:
Status comment:


Attachments

Description Pierre Fortin 2018-03-11 17:34:40 CET
Description of problem:
# urpmi.addmedia --update google-earth http://dl.google.com/linux/earth/rpm/stable/$(uname -m)
# urpmi google-earth-pro-stable
A requested package cannot be installed:
google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)
Continue installation anyway? (Y/n) 
While some packages may have been installed, there were failures.
A requested package cannot be installed:
google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)
Continue installation anyway?

Yet....

# ll {,/usr}/*/*GLU*
lrwxrwxrwx 1 root root     15 Feb  7  2016 /lib64/libGLU.so -> libGLU.so.1.3.1*
lrwxrwxrwx 1 root root     15 Feb  7  2016 /lib64/libGLU.so.1 -> libGLU.so.1.3.1*
-rwxr-xr-x 1 root root 519760 Feb  7  2016 /lib64/libGLU.so.1.3.1*
lrwxrwxrwx 1 root root     15 Feb  7  2016 /lib/libGLU.so.1 -> libGLU.so.1.3.1*
-rwxr-xr-x 1 root root 576040 Feb  7  2016 /lib/libGLU.so.1.3.1*
lrwxrwxrwx 1 root root     15 Feb  7  2016 /usr/lib64/libGLU.so -> libGLU.so.1.3.1*
lrwxrwxrwx 1 root root     15 Feb  7  2016 /usr/lib64/libGLU.so.1 -> libGLU.so.1.3.1*
-rwxr-xr-x 1 root root 519760 Feb  7  2016 /usr/lib64/libGLU.so.1.3.1*
lrwxrwxrwx 1 root root     15 Feb  7  2016 /usr/lib/libGLU.so.1 -> libGLU.so.1.3.1*
-rwxr-xr-x 1 root root 576040 Feb  7  2016 /usr/lib/libGLU.so.1.3.1*



Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1.  urpmi.addmedia --update google-earth http://dl.google.com/linux/earth/rpm/stable/$(uname -m)
2.  urpmi google-earth-pro-stable
3.  [or use mcc]
Stig-Ørjan Smelror 2018-03-12 00:01:51 CET

Summary: google-earth won't install due to missing mesa-ligGLU -- exists as libGLU => google-earth won't install due to missing mesa-libGLU -- exists as libGLU
CC: (none) => smelror

Comment 1 Marja Van Waes 2018-03-12 06:41:48 CET
Assigning to the registered maintainer, but CC'ing all packagers collectively, because the official maintainer last pushed glu in 2012

@ kekePower

I think you should feel free to fix it (for cauldron, too)

Whiteboard: (none) => MGA6TOO
CC: (none) => marja11, pkg-bugs
Assignee: bugsquad => mageia
Source RPM: (none) => glu-9.0.0-6.mga6, glu-9.0.0-6.mga7
Version: 6 => Cauldron

Stig-Ørjan Smelror 2018-03-12 09:30:29 CET

Assignee: mageia => smelror

Comment 2 Stig-Ørjan Smelror 2018-03-12 09:36:22 CET
Package updated in Cauldron

Version: Cauldron => 6
Whiteboard: MGA6TOO => (none)

Comment 3 Stig-Ørjan Smelror 2018-03-12 09:40:14 CET
Advisory
========

Google Earth would not install due to missing mesa-libGLU. This update adds a new Provides for mesa-libGLU.

References
==========
https://bugs.mageia.org/show_bug.cgi?id=22747

Files
=====

Uploaded to core/updates_testing:

lib64mesaglu1-9.0.0-6.1.mga6
lib64mesaglu1-devel-9.0.0-6.1.mga6

from glu-9.0.0-6.1.mga6.src.rpm

Assignee: smelror => qa-bugs

Comment 4 David Walser 2018-03-15 17:22:30 CET
Is there a way to report the bug upstream to Google?  They shouldn't be hard-coding Fedora/RHEL-specific package name dependencies when the auto-generated library dependencies should be sufficient and work across distros.
Comment 5 Dave Hodgins 2018-03-15 19:37:01 CET
Reported to google with link to this bug report using google-earth-pro/help/send feedback.

CC: (none) => davidwhodgins

Comment 6 Lewis Smith 2018-03-20 21:58:35 CET
Testing Mageia 6 x64

 # urpmi.addmedia --update google-earth http://dl.google.com/linux/earth/rpm/stable/$(uname -m)
ychwanegu cyfrwng "google-earth"
    http://dl.google.com/linux/earth/rpm/stable/x86_64/media_info/synthesis.hdlist.cz
 to add the Google-earth repository.
[Thanks to Pierre for the info]

BEFORE update: lib64mesaglu1-9.0.0-6.mga6
 # urpmi google-earth-pro-stable
Nid oes modd gosod pecyn gofynnwyd amdani:
 [cannot install the following pkg]
google-earth-pro-stable-7.3.1.4507-0.x86_64 (mesa-libGLU heb ei foddloni)
 [mesa-libGLU not available]
Parhau i osod beth bynnag? (Y/n) n      [Continue?]

Just as described.

AFTER update: lib64mesaglu1-9.0.0-6.1.mga6
 # urpmi google-earth-pro-stable
    http://dl.google.com/linux/earth/rpm/stable/x86_64/google-earth-pro-stable-7.3.1.4507-0.x86_64.rpm
warning: /var/cache/urpmi/rpms/google-earth-pro-stable-7.3.1.4507-0.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY
Mae gan y pecyn canlynol lofnod gwallus:
/var/cache/urpmi/rpms/google-earth-pro-stable-7.3.1.4507-0.x86_64.rpm: Llofnod annilys (NOT OK (no key): /var/cache/urpmi/rpms/google-earth-pro-stable-7.3.1.4507-0.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY)
 [complaints about a bad signature]
Ydych chi am barhau â'r gosod? (y/N) y      [Continue?]
wrthi'n gosod google-earth-pro-stable-7.3.1.4507-0.x86_64.rpm o /var/cache/urpmi/rpms
Wrthi'n paratoi...               #############################################
      1/1: google-earth-pro-stable
                                 #############################################
error: can't create transaction lock on /var/lib/rpm/__db.000 (Resource temporarily unavailable)
error: /tmp/google.sig.WjWlvt: key 1 import failed.
error: can't create transaction lock on /var/lib/rpm/__db.000 (Resource temporarily unavailable)
error: /tmp/google.sig.WjWlvt: key 2 import failed.
Redirecting to /bin/systemctl start atd.service
warning: commands will be executed using (in order) a) $SHELL b) login shell c) /bin/sh
job 1 at Tue Mar 20 21:32:00 2018

Despite which GoogleEarth was apparently installed. Found it in the Internet menu, and it worked. There were problems related to keys which my system did not allow for, but pushing past those dialogues, it worked.
Update clearly OK. Will do the advisory now. Good work Stig.

Whiteboard: (none) => MGA6-64-OK
Keywords: (none) => advisory, validated_update
CC: (none) => sysadmin-bugs

Comment 7 Mageia Robot 2018-03-22 23:40:08 CET
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0054.html

Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.