Bug 22732 - Digikam Update for Plasma 5.12
Summary: Digikam Update for Plasma 5.12
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK MGA6-32-OK
Keywords: advisory, validated_update
Depends on: 22656 22657 22759
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-10 16:52 CET by José Jorge
Modified: 2018-05-11 22:14 CEST (History)
9 users (show)

See Also:
Source RPM: digikam
CVE:
Status comment:


Attachments

Description José Jorge 2018-03-10 16:52:54 CET
Digikam needs to be updated to fix bugs with Plasma 5.12 update.

RPMS:
digikam-5.8.0-1.mga6.i586.rpm
showfoto-5.8.0-1.mga6.i586.rpm
libdigikamdatabase5-5.8.0-1.mga6.i586.rpm
libkf5kipiplugins5-5.8.0-1.mga6.i586.rpm 
kipi-plugins-5.8.0-1.mga6.noarch.rpm
kipi-plugins-smug-5.8.0-1.mga6.i586.rpm
kipi-plugins-imgurexport-5.8.0-1.mga6.i586.rpm
kipi-plugins-piwigo-5.8.0-1.mga6.i586.rpm
kipi-plugins-googleservices-5.8.0-1.mga6.i586.rpm
kipi-plugins-remotestorage-5.8.0-1.mga6.i586.rpm
kipi-plugins-flickr-5.8.0-1.mga6.i586.rpm
kipi-plugins-rajceexport-5.8.0-1.mga6.i586.rpm
kipi-plugins-printimages-5.8.0-1.mga6.i586.rpm
kipi-plugins-jalbum-5.8.0-1.mga6.i586.rpm
kipi-plugins-flashexport-5.8.0-1.mga6.i586.rpm
kipi-plugins-facebook-5.8.0-1.mga6.i586.rpm
kipi-plugins-sendimages-5.8.0-1.mga6.i586.rpm
kipi-plugins-imageshackexport-5.8.0-1.mga6.i586.rpm
kipi-plugins-kmlexport-5.8.0-1.mga6.i586.rpm
kipi-plugins-yandexfotki-5.8.0-1.mga6.i586.rpm
kipi-plugins-wikimedia-5.8.0-1.mga6.i586.rpm
kipi-plugins-vkontakte-5.8.0-1.mga6.i586.rpm
kipi-plugins-dropbox-5.8.0-1.mga6.i586.rpm
libdigikamcore5-5.8.0-1.mga6.i586.rpm
libdigikamgui5-5.8.0-1.mga6.i586.rpm
libdigikam-devel-5.8.0-1.mga6.i586.rpm
                                       
SRPM
digikam-5.8.0-1.mga6.srpm
José Jorge 2018-03-10 16:53:55 CET

CC: (none) => lists.jjorge
Blocks: (none) => 22656

Comment 1 José Jorge 2018-03-11 19:20:04 CET
I second build was needed to enable geolocalisation. So all 5.8.0-1 are now 5.8.0-2 .

I could test on my MGA6 x86_64 all ok

Status: NEW => ASSIGNED

PC LX 2018-03-12 17:00:27 CET

CC: (none) => mageia

Ulrich Beckmann 2018-03-13 12:52:32 CET

Depends on: (none) => 22759

Comment 2 Herman Viaene 2018-03-14 18:59:51 CET
MGA6-64 on Lenovo B50 Plasma 5.12
No installation issues.
Version in repos is in the mean time 5.8.0-3
Not so familiar with digikam, but I've been able to import pictures from Nikon Coolpix.
Looks OK, I could browse properties, metadata. I could edit a picture, add a border and save a new version of the picture. Change color levels also OK.

CC: (none) => herman.viaene
Whiteboard: (none) => MGA6-64-OK

Comment 3 Mauricio Andrés Bustamante Viveros 2018-03-15 19:01:30 CET
The same testing as HViaene using MGA6-32 VBOX

All tests results in OK
Tests made with a google image

CC: (none) => neoser10

Comment 4 Mauricio Andrés Bustamante Viveros 2018-03-15 21:44:59 CET
https://drive.google.com/open?id=15Ku-OQZnFzc3OqSkPufXohW7wHiud0P2

I have this message trying to update to the new digikam 5.0.8-3

As I see, this is a new compilation.... Can the packager help with this little issue (Which package to select)
Comment 5 José Jorge 2018-03-16 16:28:11 CET
(In reply to Mauricio Andrés Bustamante Viveros from comment #4)
> I have this message trying to update to the new digikam 5.0.8-3

This is a false choice, you can choose any one you want, both will be installed.
Comment 6 Lewis Smith 2018-03-17 21:45:20 CET
I was going to do the advisory for this, but am unsure about the two versions:
 5.8.0-2  (from c1)
 5.0.8-3  (from c2, c5, c6).
(In reply to José Jorge from comment #5)
> This is a false choice, you can choose any one you want, both will be
> installed.
@José Please clarify.
Also, it looks from c4 as if Mauricio tested 5.8.0-2 , & from c2 Herman tested 5.0.8-3 . I was going to 32-bit OK (& validate) the update from c3, but these two versions need explaining please.

CC: (none) => lewyssmith
Whiteboard: MGA6-64-OK => MGA6-64-OK MGA6-32-OK

Comment 7 José Jorge 2018-03-18 08:50:35 CET
It is version 3 the good one. I enabled two options in version 2 that upstream said we should not.

This options enable akonadi support, that anyway was probably not tested by any tester as it means using already akonady contacts...
Comment 8 Lewis Smith 2018-03-18 14:15:01 CET
Thanks José. The bug RPMs link shows 5.8.0-3, which is what Herman tested.  I remain unsure just what Mauricio tested, but am letting this go and doing the advisory from comment 0 but for 5.8.0-3.

Keywords: (none) => advisory, validated_update
CC: lewyssmith => sysadmin-bugs

Comment 9 Mauricio Andrés Bustamante Viveros 2018-03-18 14:41:11 CET
I tested the digikam -1 and -2 and worked for me
This pkg is oknfor mee too
Comment 10 Nicolas Lécureuil 2018-03-18 20:58:30 CET
i would prefer to update to digikam 5.9.0 if possible for mageia 6

CC: (none) => mageia

Comment 11 Thomas Backlund 2018-03-19 16:06:46 CET
This one is built against QT 5.9

Depends on: (none) => 22657
CC: (none) => tmb

Comment 12 Morgan Leijström 2018-04-14 01:24:45 CEST
Digikam 5.9.0 is a bugfix release, so seem logical to do.
https://www.digikam.org/ : "we has focused all developements to close bugs."

CC: (none) => fri

Comment 13 José Jorge 2018-04-14 10:13:23 CEST
(In reply to Morgan Leijström from comment #12)
> Digikam 5.9.0 is a bugfix release, so seem logical to do.
> https://www.digikam.org/ : "we has focused all developements to close bugs."

Yes, but I prefer to wait for this big plasma update to be released, as I have been testing 5.8.0 version for two months with no bugs, so I am sure it will not delay it again.

Then I will push 5.9 version to testing, and let it be tested for some time.
Comment 14 David GEIGER 2018-04-14 10:26:04 CEST
I pushed digikam 5.9.0 today this morning!

CC: (none) => geiger.david68210

Comment 15 José Jorge 2018-04-14 10:33:12 CEST
(In reply to David GEIGER from comment #14)
> I pushed digikam 5.9.0 today this morning!

Without any announcement or list of rpms in this bug report? I wonder if this crazy update will ever end...
Comment 16 David GEIGER 2018-04-14 10:44:36 CEST
Updated list:

i586 RPMS:
##############################################
digikam-5.9.0-1.mga6.i586.rpm
showfoto-5.9.0-1.mga6.i586.rpm
libdigikamdatabase5-5.9.0-1.mga6.i586.rpm
libkf5kipiplugins5-5.9.0-1.mga6.i586.rpm
kipi-plugins-5.9.0-1.mga6.noarch.rpm
kipi-plugins-smug-5.9.0-1.mga6.i586.rpm
kipi-plugins-imgurexport-5.9.0-1.mga6.i586.rpm
kipi-plugins-piwigo-5.9.0-1.mga6.i586.rpm
kipi-plugins-googleservices-5.9.0-1.mga6.i586.rpm
kipi-plugins-remotestorage-5.9.0-1.mga6.i586.rpm
kipi-plugins-flickr-5.9.0-1.mga6.i586.rpm
kipi-plugins-rajceexport-5.9.0-1.mga6.i586.rpm
kipi-plugins-printimages-5.9.0-1.mga6.i586.rpm
kipi-plugins-jalbum-5.9.0-1.mga6.i586.rpm
kipi-plugins-flashexport-5.9.0-1.mga6.i586.rpm
kipi-plugins-facebook-5.9.0-1.mga6.i586.rpm
kipi-plugins-sendimages-5.9.0-1.mga6.i586.rpm
kipi-plugins-imageshackexport-5.9.0-1.mga6.i586.rpm
kipi-plugins-kmlexport-5.9.0-1.mga6.i586.rpm
kipi-plugins-yandexfotki-5.9.0-1.mga6.i586.rpm
kipi-plugins-wikimedia-5.9.0-1.mga6.i586.rpm
kipi-plugins-vkontakte-5.9.0-1.mga6.i586.rpm
kipi-plugins-dropbox-5.9.0-1.mga6.i586.rpm
libdigikamcore5-5.9.0-1.mga6.i586.rpm
libdigikamgui5-5.9.0-1.mga6.i586.rpm
libdigikam-devel-5.9.0-1.mga6.i586.rpm


x86_64 RPMS:
##############################################
digikam-5.9.0-1.mga6.x86_64.rpm
showfoto-5.9.0-1.mga6.x86_64.rpm
lib64digikamdatabase5-5.9.0-1.mga6.x86_64.rpm
lib64kf5kipiplugins5-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-smug-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-imgurexport-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-piwigo-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-googleservices-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-remotestorage-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-flickr-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-rajceexport-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-printimages-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-jalbum-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-flashexport-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-facebook-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-sendimages-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-imageshackexport-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-kmlexport-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-yandexfotki-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-wikimedia-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-vkontakte-5.9.0-1.mga6.x86_64.rpm
kipi-plugins-dropbox-5.9.0-1.mga6.x86_64.rpm
lib64digikamcore5-5.9.0-1.mga6.x86_64.rpm
lib64digikamgui5-5.9.0-1.mga6.x86_64.rpm
lib64digikam-devel-5.9.0-1.mga6.x86_64.rpm


SRPM:
##############################################
digikam-5.9.0-1.mga6.srpm
Comment 17 Morgan Leijström 2018-04-14 11:54:17 CEST
Updating here wants to remove showfoto-5.8.0-3.mga6.x86_64
because libdigikamcore.so.5.8.0 (64bit) is missing.

 -So we need to update showfoto too to 5.9.0 ?
Comment 18 David GEIGER 2018-04-14 12:00:53 CEST
showfoto is also on 5.9.0 because it comes from the same source as digikam.
Comment 19 Morgan Leijström 2018-04-15 11:36:30 CEST
You are correct. I had to add showfoto the the list for qarepo.pl to generate full list of packages to update.

For test i just see it works, but I normally do not use Digikam.
Comment 20 Mauricio Andrés Bustamante Viveros 2018-04-17 06:30:59 CEST
Tested the app
Using the common test for a photo editor:
1. Change color (B&W, gamma, contrast)
2. Change brightness and saturation
3. Open and saving files
4. Testing if is compatible with the digikam database already existent

For me, this new version is OK 

PD: tested with the new plasma-KF-qt stack
Thomas Backlund 2018-05-04 18:48:55 CEST

Depends on: (none) => 22656
Blocks: 22656 => (none)

Comment 21 Mageia Robot 2018-05-11 22:14:35 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0073.html

Status: ASSIGNED => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.