Bug 22722 - Black screen SDDM logging into Xfce - easy workaround
Summary: Black screen SDDM logging into Xfce - easy workaround
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 22656
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-08 19:00 CET by Morgan Leijström
Modified: 2018-03-09 21:53 CET (History)
1 user (show)

See Also:
Source RPM: sddm-0.14.0-13.mga6.src.rpm
CVE:
Status comment:


Attachments
journal booting to SDDM, into black xfce Ctrl-Alt-F2 & F3 = OK (20.65 KB, application/x-xz)
2018-03-08 19:45 CET, Morgan Leijström
Details

Description Morgan Leijström 2018-03-08 19:00:47 CET
Description of problem:
When logging into xfce, screen is plain black.
Switching to another vt and back makes xfce show and work OK.
(i.e Ctrl-Alt-F2, Ctrl-Alt-F3)

This *may* be a rest of bug 22488, or not.

Workaround: use another DM
Using LightDM, xfce shows up as it should.


Version-Release number of selected component (if applicable):
sddm-0.14.0-13.mga6.src.rpm


How reproducible: Always, on this setup
-which is: 32 bit machine with ati x300 GPU, mga6 fully updated as of now

Steps to Reproduce: Boot to SDDM, log into xfce
Morgan Leijström 2018-03-08 19:01:55 CET

Summary: Black screen when logging into Xfce - easy workaround => Black screen SDDM logging into Xfce - easy workaround

Comment 1 Morgan Leijström 2018-03-08 19:45:22 CET
Created attachment 10033 [details]
journal booting to SDDM, into black xfce Ctrl-Alt-F2 & F3 = OK

Log (journalctl -b) booting -> SDDM -> logging into Xfce which is shown black -> hitting Ctrl-Alt-F2, Ctrl-Alt-F3 -> Xfce is then shown and working OK.
Comment 2 Morgan Leijström 2018-03-08 21:23:25 CET
Did a full update to Plasma5.12 etc in testing, by issuing

 urpmi --auto-select --searchmedia testing 

Now xfce dispays OK when logging in using SDDM 

So this will probably be OK once released to normal updates :)
Comment 3 Marja Van Waes 2018-03-09 21:53:55 CET
(In reply to Morgan Leijström from comment #2)
> Did a full update to Plasma5.12 etc in testing, by issuing
> 
>  urpmi --auto-select --searchmedia testing 
> 
> Now xfce dispays OK when logging in using SDDM 
> 
> So this will probably be OK once released to normal updates :)

setting this report to depend on bug 22656 (the plasma update tracker)

Assignee: bugsquad => kde
Depends on: (none) => 22656
CC: (none) => marja11


Note You need to log in before you can comment on or make changes to this bug.