Bug 22655 - KMail/Akonadi: Cannot reconfigure Googlemail IMAP account
Summary: KMail/Akonadi: Cannot reconfigure Googlemail IMAP account
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
Whiteboard: MGA6-64-TOO
Depends on:
Reported: 2018-02-25 17:35 CET by Ulrich Beckmann
Modified: 2018-05-15 21:29 CEST (History)
2 users (show)

See Also:
Source RPM:
Status comment:

Excerpt of journal and list of installed packages (8.61 KB, text/plain)
2018-02-25 17:37 CET, Ulrich Beckmann

Description Ulrich Beckmann 2018-02-25 17:35:33 CET
I had a working KMail instance with a Googlemail IMAP account on Cauldron. Some time ago, there was a workflow that required access to Google Services for Akonadi. The workflow failed, and now I am trying to reconfigure my KMail accout.

The workflow passes now, but no mail is retrieved. The Akonadi resource is marked as ready. The connection settings under Accounts => Receiving => Modify => Advanced can no longer be configured manually. They are greyed out. Although another IMAP account (non-Google) is working fine.


N.B. I installed libkgapi, see also https://bugzilla.redhat.com/show_bug.cgi?id=1543140
Here libkgapi was used to fix an workflow error, so I guess that it is necessary, though not installed through dependencies in Mageia.
Comment 1 Ulrich Beckmann 2018-02-25 17:37:29 CET
Created attachment 10004 [details]
Excerpt of journal and list of installed packages
Comment 2 Marja Van Waes 2018-02-26 08:51:50 CET
did you try whether installing libkgapi fixed it, Ulrich?

See Also: (none) => https://bugzilla.redhat.com/show_bug.cgi?id=1543140
Assignee: bugsquad => kde
CC: (none) => marja11

Comment 3 Marja Van Waes 2018-02-26 08:52:42 CET
(In reply to Marja van Waes from comment #2)
> did you try whether installing libkgapi fixed it, Ulrich?

forget that, it is in your list of installed packages:

Comment 4 Ulrich Beckmann 2018-03-02 21:11:05 CET
After a full upgrade against updates_testing I find the issue in Mageia 6, too.

Whiteboard: (none) => Mg

Ulrich Beckmann 2018-03-02 21:12:13 CET

Whiteboard: Mg => MGA6-64-TOO

Comment 5 Nicolas Lécureuil 2018-03-02 21:23:57 CET
Please open an upstream bugreport about this.

CC: (none) => mageia

Comment 6 Ulrich Beckmann 2018-03-04 11:49:37 CET
The Fedora bug report linked in comment #1 is now marked as CLOSED ERRATA. Unfortunately there is no explanation, why and what is the real solution. I tested now KMail in Fedora 27 and it works fine. The configuration items are greyed out, too. libkgapi is installed through dependencies.

Version numbers are
Comment 7 Ulrich Beckmann 2018-03-04 11:51:15 CET
I found additional info:


Quote Carlos E. R.
"Yes, gmail by default uses an auth method called oauth2. Normal mail
clients like daemons can not use this method, they need user
interaction with a web page. Thunderbird currently does support it
8since about a year or so). I don't know if kmail does or not.

If it doesn't, you have to log into the gmail control web page and
"allow login by less secure applications" or similar wording.

That's the trick we have to do to use, for instance, fetchmail."


Quote Luca Beltame
"Note that KMail 5.5, from Applications 17.04 (which should have landed
in TW, or will soon) supports OAuth2 for GMail natively now."

I checked now the Google configuration under
=> My Account => Sign in and Security => Allow less secure Apps is ON

That is why it worked before.

Comment 8 Ulrich Beckmann 2018-03-05 15:03:07 CET
There is a workaround: When you use the server imap.googlemail.com instead of imap.gmail.com, Google oauth is not needed.
You can configure manually e.g. SSL/TLS and Plain.

I had to invoke $ akonadictl vacuum.

Comment 9 Ulrich Beckmann 2018-04-04 20:42:55 CEST
As Google identification method works in Fedora, I won't write an upstream bug report as sugested. It is most probably fixed there, and the fix will appear in Mageia.

Closing the bug report as "works for me".


Resolution: (none) => WORKSFORME

Ulrich Beckmann 2018-05-15 21:29:24 CEST

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=23035

Note You need to log in before you can comment on or make changes to this bug.