Bug 22576 - Twinkle was compiled without ZRTP support
Summary: Twinkle was compiled without ZRTP support
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-02-11 15:22 CET by Markus Robert Keßler
Modified: 2018-05-18 17:28 CEST (History)
4 users (show)

See Also:
Source RPM: twinkle-1.9.0-5.mga6.src.rpm
CVE:
Status comment:


Attachments

Description Markus Robert Keßler 2018-02-11 15:22:26 CET
Description of problem:

Twinkle was compiled without ZRTP support, hence, there is no encrypted call possible


Version-Release number of selected component (if applicable):

twinkle-1.9.0-5


How reproducible:

Always


Steps to Reproduce:
1. Install
2. Invoke
3. Go to EDIT ==> USER PROFILE ==> SECURITY
Comment 1 David GEIGER 2018-02-11 16:15:12 CET
I pushed an update in 6/Core/Updates_testing repo with a new 1.10.1 release and also with zrtp and gsm support enabled.

Please test it, thanks in advance!

CC: (none) => geiger.david68210

Marja Van Waes 2018-02-11 17:43:42 CET

CC: (none) => marja11
Assignee: bugsquad => geiger.david68210

Comment 2 Marja Van Waes 2018-02-11 17:44:52 CET
Thanks, David. I assigned to you because you already pushed the package to testing.
Comment 3 Markus Robert Keßler 2018-02-12 11:23:03 CET
I uninstalled the official version and installed this one, but after invoking twinkle it says:

<quote>
This application failed to start because it could not find or load the Qt platform plugin "xcb" in "".

Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
</quote>


Unfortunately, the last line is not true. I uninstalled 1.10.1 and reinstalled 1.9.0 but it does not run any more and above error stays.
Comment 4 Markus Robert Keßler 2018-02-12 12:22:58 CET
As I have to see now, Avidemux-qt also refuses to work even after reinstallation, and maybe other QT-lib-based applications are also affected.

Damn, this was a real box and not a testing-VM...
Comment 5 David GEIGER 2018-02-12 16:52:30 CET
As there are a lot of Qt5/Kf5 update in 6/Core/Updates_testing repo maybe this issue come from.
Comment 6 David GEIGER 2018-05-12 06:43:22 CEST
So time to assigning to QA now,


Advisory:
=============================

Our current version 1.9.0 is now quite old (released on 2015.07.13) and unmaintained upstream.
This updates twinkle to a version which is supported upstream and also it enables zrtp and gsm support.


Packages in 6/core/updates_testing:
========================
twinkle-1.10.1-1.mga6.i586.rpm
twinkle-1.10.1-1.mga6.x86_64.rpm

Source RPM: 
========================
twinkle-1.10.1-1.mga6.src.rpm

Assignee: geiger.david68210 => qa-bugs

Comment 7 Len Lawrence 2018-05-15 22:00:32 CEST
Had a look at this and installed and updated the package.  This is not something I know anything about - Voice over IP phone - and I do not have a microphone.

Invoked the interface and created a profile, naming sipgate.co.uk as my SIP provider, a barefaced lie.  A dialogue popped up the next time twinkle was invoked with a login screen for sipgate.co.uk.

This at least demonstrates that the application is now functioning.  It would not launch before the update.

Giving this the OK.

CC: (none) => tarazed25
Whiteboard: (none) => MGA6-64-OK

Comment 8 Lewis Smith 2018-05-17 20:44:18 CEST
Thanks Len.

Keywords: (none) => advisory, validated_update
CC: (none) => sysadmin-bugs

Comment 9 Mageia Robot 2018-05-18 17:28:07 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0086.html

Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.