Bug 22499 - drakboot exits when I click on X in the Advanced window
Summary: drakboot exits when I click on X in the Advanced window
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal major
Target Milestone: Mageia 8
Assignee: Thierry Vignaud
QA Contact:
Depends on:
Reported: 2018-01-31 21:48 CET by Stig-Ørjan Smelror
Modified: 2020-08-16 22:07 CEST (History)
1 user (show)

See Also:
Source RPM: drakxtools-18.32-1.mga8.src.rpm
Status comment:

drakboot.log (53.76 KB, text/plain)
2018-12-24 22:48 CET, Stig-Ørjan Smelror

Description Stig-Ørjan Smelror 2018-01-31 21:48:57 CET
Description of problem:

Found this strange bug when running drakboot.
drakboot opens up fine, with the regular perl messages, I click Next and then click Advanced.
When I click X to close that window, drakbook exits without any message, either at the console or in the journal.

How reproducible:
I've tried opening drakboot directly and through MCC with the same result, every time.
MCC stays open, it's just drakboot that exits.

Steps to Reproduce:
1. Start drakboot
2. Click Next
3. Click Advanced
4. Click the X to close the sub-window
5. drakboot exits
Comment 1 Stig-Ørjan Smelror 2018-11-27 00:19:23 CET
This is still happening.

Ignore the following Glib::Object::Introspection & Gtk3 warnings
Subroutine Gtk3::main redefined at /usr/share/perl5/vendor_perl/Gtk3.pm line 525.
GLib-LOG **: posix_spawn avoided (fd close requested)  at /usr/lib64/perl5/vendor_perl/Glib/Object/Introspection.pm line 67.
Comment 2 Stig-Ørjan Smelror 2018-12-24 22:48:12 CET
Created attachment 10602 [details]

I ran

sudo perl -w /usr/libexec/drakboot > drakboot.log 2>&1
Comment 3 Aurelien Oudelet 2020-08-16 22:07:41 CEST
Still present in Cauldron - 2020-08-16

Source RPM: drakxtools-17.88.1-1.mga6.src.rpm => drakxtools-18.32-1.mga8.src.rpm
CC: (none) => ouaurelien
Target Milestone: --- => Mageia 8
Version: 6 => Cauldron
Severity: normal => major

Note You need to log in before you can comment on or make changes to this bug.