Bug 22488 - Recent x11 ati on some systems make SDDM flicker @1Hz and fail to show desktop, cinnamon flicker when moving mouse
Summary: Recent x11 ati on some systems make SDDM flicker @1Hz and fail to show deskto...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK, MGA6-32-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-01-29 14:59 CET by Morgan Leijström
Modified: 2018-03-08 19:01 CET (History)
7 users (show)

See Also:
Source RPM: x11-driver-video-ati-7.10.0-1.1.mga6.src.rpm
CVE:
Status comment:


Attachments
Per comment #2, compressed journal boot to login fail (37.04 KB, application/x-xz)
2018-02-11 17:00 CET, Morgan Leijström
Details
Per comment #2, Xorg log to login fail (36.80 KB, text/plain)
2018-02-11 17:01 CET, Morgan Leijström
Details
Per comment #2, Xorg conf (10.83 KB, text/plain)
2018-02-11 17:02 CET, Morgan Leijström
Details
journalctl from plasma logout to xfce login and switching vt manually (11.20 KB, text/plain)
2018-03-08 18:09 CET, Morgan Leijström
Details

Description Morgan Leijström 2018-01-29 14:59:38 CET
Description of problem:
At login; after boot, logout, or resume, both happens:

a) the login screen flickers once a second with a horizontal band approx 2cm high band of higher luminosity shown about one frame, slowly moving down over the screen for each flicker.

b) after password is entered disk lamp flickers as usual, but it never shows desktop.  WORKAROUND: hit ctrl-alt-F2 (text console screen) and then ctrl-alt-F1 and desktop is immediately there.


__Version-Release number of selected component (if applicable):

DE = current mga6 Plasma

DM = SDDM 0.14.0-13

Problem got visible after updates a couple days ago, amongst them i remember systemd 230.12-3, radeon-firmware 2018-01-18 and something else radeon

It did NOT appear after update to latest kernel (4.14.13)


__ How reproducible:

§ Only experienced using SDDM DM; I changed to LXDM, and it do not show that problem at login (except at resume, when SDDM seem to be used anyways)  Did not test other DM 

§ I only see it on that specific laptop: Thinkpad T60 with *Radeon* graphics


As SDDM have not been changed for over a year i start blaming systemd, but it may also be radeon.   Or maybe SDDM need an update?

This cause no problem for me, and I plan reinstalling when new Qt, Plasma etc hits mga6, and maybe the problem do not show there, so unless other have problems with this it is OK by me to rest with it as is for now.
Marja Van Waes 2018-01-30 10:02:37 CET

CC: (none) => basesystem, kde, kernel, marja11

Comment 1 Morgan Leijström 2018-02-01 02:24:18 CET
Now i updated my old Thinkpad T42p which runs mga6 32 bit plasma, and have AMD/ATI GPU (RV350/M10 GL [Mobility FireGL T2] 
* same issue with flickering *- actually more visible; the bright band is wider.  (Wider because this is a slower machine? which seem to indicate it is because some software get triggered every second and disturbs display then...?)

In the few tests so far it do not fail to show desktop, like my T61 in comment 0.

So both my laptops which have AMD GPU shows this problem

Severity: normal => major

Comment 2 Marja Van Waes 2018-02-01 15:33:47 CET
(In reply to Morgan Leijström from comment #1)
> Now i updated my old Thinkpad T42p which runs mga6 32 bit plasma, and have
> AMD/ATI GPU (RV350/M10 GL [Mobility FireGL T2] 
> * same issue with flickering *- actually more visible; the bright band is
> wider.  (Wider because this is a slower machine? which seem to indicate it
> is because some software get triggered every second and disturbs display
> then...?)
> 
> In the few tests so far it do not fail to show desktop, like my T61 in
> comment 0.
> 
> So both my laptops which have AMD GPU shows this problem

When using the workaround on the first system, right after hitting Ctrl+Alt+F2, please fetch 

    /var/log/Xorg.0.log

so you can attach it to this report (it might be overwritten when you switch back with Ctrl+Alt+F1)


Can you please also attach log.txt that is the result of running, as root:

   journalctl -b > log.txt

right after rebooting and reproducing the issue on that system?

And please attach its

   /etc/X11/xorg.conf



Thanks :-)
Marja Van Waes 2018-02-01 15:34:01 CET

Keywords: (none) => NEEDINFO

Comment 3 Iñigo Salvador Azurmendi 2018-02-05 21:07:17 CET
I am also experiencing the screen flickering described by  "Morgan Leijström 2018-01-29 14:59:38 CET":

"a) the login screen flickers once a second with a horizontal band approx 2cm high band of higher luminosity shown about one frame, slowly moving down over the screen for each flicker.

b) after password is entered disk lamp flickers as usual, but it never shows desktop.  WORKAROUND: hit ctrl-alt-F2 (text console screen) and then ctrl-alt-F1 and desktop is immediately there."


After login, splash screen does not work properly. I have Mageia's default cauldron image, and it shows only the first image, no bubbles appearing. Then it shows again login screen image, only image. To be able to use the desktop environment I must change to a text console (Ctrl+Alt+F2..n) and back to Desktop environment (Alt+F1).


Problem started after updating 

2018-01-25, MGAA-2018-0022: radeon-firmware, ldetect-lst, libdrm, mesa, wayland-protocols, x11-driver-video-amdgpu, x11-driver-video-ati, x11-driver-video-intel

Thank you very much!

CC: (none) => xalba

Comment 4 Iñigo Salvador Azurmendi 2018-02-05 21:23:16 CET
Additional information about the graphic card:

00:1a.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 02) (prog-if 00 [UHCI])
        Subsystem: Hewlett-Packard Company Device [103c:2a73]
        Flags: bus master, medium devsel, latency 0, IRQ 21
        I/O ports at b480 [size=32]
        Capabilities: <access denied>
        Kernel driver in use: uhci_hcd
        Kernel modules: uhci_hcd
Comment 5 Morgan Leijström 2018-02-11 17:00:44 CET
Created attachment 9980 [details]
Per comment #2, compressed journal boot to login fail
Comment 6 Morgan Leijström 2018-02-11 17:01:41 CET
Created attachment 9981 [details]
Per comment #2, Xorg log to login fail
Comment 7 Morgan Leijström 2018-02-11 17:02:24 CET
Created attachment 9982 [details]
Per comment #2, Xorg conf
Comment 8 Morgan Leijström 2018-02-11 17:51:22 CET
Some tests:

I also tried XDM: after boot no flicker at login, but the problem is like before that after resume SDDM is used to login and it have the problem described like before.

I have tried with and without Composition, and with and without EXA enabled in graphics settings: Also tried 4.9 / 4.16 kernel - no difference any time.

Now i also tried Plasma-Wayland (after todays updates): SDDM flickers at login of course (wayland plasma not launched yet). When logged in Plasma is unusably slow!  There is no flicker at SDDM login after resume, but after login i have a completely black screen. Ctrl-backspace-backspace got me back to a blinking SDDM...

Now i tried also changing to graphics driver xorg ati: same result.
IIRC xorg ati and radeon is the same on mageia nowadays?
amdgpu is too new for my GPU (tried anyway and failed badly)

Now i tried cinnamon (@ LXDM, latest kernel, xorg ati), and find cinnamon  flicker when i move the mouse !!

I could try downgrading i.e radeon, of course... later...

Workaround for now: LXDM + MATE.  (This is a production machine)

Keywords: NEEDINFO => (none)
Summary: systemd/radeon/SDDM: screen flickers @1Hz, and fail to show desktop => systemd/radeon/SDDM: screen flickers @1Hz, and fail to show desktop, cinnamon flicker when moving mouse

Comment 9 Marja Van Waes 2018-02-12 11:48:24 CET
Thanks for the attachments, Morgan!

(In reply to Iñigo Salvador Azurmendi from comment #3)

> Problem started after updating 
> 
> 2018-01-25, MGAA-2018-0022: radeon-firmware, ldetect-lst, libdrm, mesa,
> wayland-protocols, x11-driver-video-amdgpu, x11-driver-video-ati,
> x11-driver-video-intel
> 

Morgan didn't mention mesa, as you do, but mesa must have been updated on his system too. It might be the culprit, it caused serious problems with sddm and plasma in cauldron (which got fixed with mesa-18.0.0-0.rc4.1.mga7 )

Assigning to the kernel and drivers maintainers, one of them is also the mesa maintainer.

Assignee: bugsquad => kernel

Comment 10 Morgan Leijström 2018-02-12 11:53:11 CET
Probably, i did not check updates carefully yet.

Tell me what package and version you want me to downgrade to and test.

I guess something like the following + reboot would work?

 urpmi --downgrade packagename-version

Or could new mesa be ported to mga6 testing?
Comment 11 Marja Van Waes 2018-02-12 12:44:29 CET
(In reply to Morgan Leijström from comment #10)
> Probably, i did not check updates carefully yet.
> 
> Tell me what package and version you want me to downgrade to and test.
> 
> I guess something like the following + reboot would work?
> 
>  urpmi --downgrade packagename-version
> 
> Or could new mesa be ported to mga6 testing?

Current mesa-17.3.2-1.1.mga6 was pushed to updates on 25 January, but mesa-17.3.3 is already in testing. However, it's not here, yet: http://madb.mageia.org/tools/updates
So I guess tmb isn't pleased with it as it is... you can test it at your own risk ;-)

The previous version was 17.1.5
For the packages list, see bug #21270, comment #0
Comment 12 Thomas Backlund 2018-02-12 12:49:50 CET
(In reply to Marja van Waes from comment #11)

 Current mesa-17.3.2-1.1.mga6 was pushed to updates on 25 January, but
> mesa-17.3.3 is already in testing. However, it's not here, yet:
> http://madb.mageia.org/tools/updates
> So I guess tmb isn't pleased with it as it is... you can test it at your own
> risk ;-)

Yeah, it missed some stuff, so I decided to wait for 17.3.4 that should be out ~today...

CC: (none) => tmb

Comment 13 Morgan Leijström 2018-02-12 16:43:41 CET
Thanks for the list Marja
I believe i downgraded all mesa packages it had from 17.3.2 to 17.5.1;
 still SDDM flickers, and same workaround, and yes i rebooted...

soon will be trying downgrading radeon-firmware, x11-driver-video-ati, ...
Comment 14 Morgan Leijström 2018-02-12 17:42:09 CET
Found the culprit :)

# urpmi --downgrade x11-driver-video-ati-7.9.0

Did it. (this version - in release media - is OK)

First tried - and it did not matter - to remove radeon-firmware.  (BTW could not be downgraded as it is incompatible with the recent kernels i have)  And i do not think my GPU benefits from it anyway...?

GPU in this Thinkpad T60: RV515/M54 [Mobility Radeon X1400]

BTW, all tests done with todays kernel 4.14.18-1
and current mesa-17.3.2-1.1.mga6 is OK.

Source RPM: (none) => x11-driver-video-ati-7.10.0-1.mga6.src.rpm
URL: systemd-230-12.3.mga6.src.rpm => (none)
Summary: systemd/radeon/SDDM: screen flickers @1Hz, and fail to show desktop, cinnamon flicker when moving mouse => Recent x11 ati on some systems make SDDM flicker @1Hz and fail to show desktop, cinnamon flicker when moving mouse

Comment 15 Morgan Leijström 2018-02-12 18:22:07 CET
Fix OK also verified on my Thinkpad T42p (32 bit), (the T60 is 64 bit dual) 
GPU= RV350/M10 GL [Mobility FireGL T2]; 
Module: ‎Card:ATI r300/r400/r500 based FireGL
Comment 16 Morgan Leijström 2018-02-21 08:01:41 CET
@Iñigo: do the same action work for you?

First make sure all other packages are updated, and then

# urpmi --downgrade x11-driver-video-ati-7.9.0

For me that works OK.

As users, until fixed, we could add that that package to /etc/urpmi/skip.list or simply deselect it when we do upgrades using the upgrading GUI.
Comment 17 Iñigo Salvador Azurmendi 2018-03-03 12:34:32 CET
@Morgan:

I confirm your conclusions. Last week I followed your instructions and it worked. Thank you.

With newer version 7.10.0-1.mga6 apart from the issues mentioned before I experience another problem. Refresh rate was not correctly detected for one of the two monitors attached to the computer and it caused it to be unusable. Once I realized about it I set the refresh rate manually for that monitor every time after login-in.

After the regression to x11-driver-video-ati-7.9.0 everything is back to normal. No flicker, session starting splash screen works properly and monitors refresh rate auto-detects correctly. 

I couldn't reply earlier because of the "Mageia Identity Security Breach" issue. I couldn't reset my password. Thanks to sysadmins by the way.



(In reply to Morgan Leijström from comment #16)
> @Iñigo: do the same action work for you?
> 
> First make sure all other packages are updated, and then
> 
> # urpmi --downgrade x11-driver-video-ati-7.9.0
> 
> For me that works OK.
> 
> As users, until fixed, we could add that that package to
> /etc/urpmi/skip.list or simply deselect it when we do upgrades using the
> upgrading GUI.
Comment 18 Thomas Backlund 2018-03-06 10:40:30 CET
I've just submitted a:

x11-driver-video-ati-7.10.0-1.1.mga6	

to testing, please test if that driver works
Comment 19 Morgan Leijström 2018-03-06 18:41:56 CET
Thank you Thomas!
Works perfectly what i can see.

First tested x11-driver-video-ati-7.10.0-1.1.mga6 without any other updates since i last wrote above. Then also with all normal updates released until now.

Reboot, login, working in Plasma, suspend, resume into SSDM - all OK.
No noticeable slowdown or side effect, no errors in journal.

Tested on thinkpad T60 only.  - The drive in my T42p did not want to be recognized by BIOS today - i knew it was going down, very old, had physical sector errors and pending reinstall on new drive... later... maybe mga6.1 :)
Comment 20 Thomas Backlund 2018-03-07 12:36:54 CET
(In reply to Morgan Leijström from comment #19)
> Thank you Thomas!
> Works perfectly what i can see.
>

Great,

@Iñigo: can you test if it works for you too ?
Nicolas Lécureuil 2018-03-07 13:56:23 CET

CC: kde => mageia

Comment 21 Iñigo Salvador Azurmendi 2018-03-07 19:44:26 CET
Yes Thomas, x11-driver-video-ati-7.10.0-1.1.mga6 does work for me too. No flicker, both monitors refresh rate are properly detected.

There is only one thing, not sure it is related with this update. In Plasma I have activated an effect triggered by mouse on top-left corner of the screen to "Present windows - All desktops", after installation it doesn't work. Tried setting another effect "Run command" and this one works. 

Should I downgrade again and see if it works?

Thanks!


(In reply to Thomas Backlund from comment #20)
> (In reply to Morgan Leijström from comment #19)
> > Thank you Thomas!
> > Works perfectly what i can see.
> >
> 
> Great,
> 
> @Iñigo: can you test if it works for you too ?
Comment 22 Iñigo Salvador Azurmendi 2018-03-07 19:52:08 CET
I have downgraded and the effect does not work anyway so it is not x11-driver-video-ati-7.10.0-1.1.mga6 related. Perhaps another update broke it.

Thank you very much!!
Comment 23 Morgan Leijström 2018-03-07 20:29:33 CET
(In reply to Iñigo Salvador Azurmendi from comment #21)
> In Plasma
> I have activated an effect triggered by mouse on top-left corner of the
> screen to "Present windows - All desktops", after installation it doesn't
> work. Tried setting another effect "Run command" and this one works. 

How weird.  This is my wifeś machine and i do not know if it worked before, but neither "desktop grid", nor "all windows from all desktops works" work here.  Probably more.  This system do not have anything else from testing repo.
Comment 24 Thomas Backlund 2018-03-07 20:34:59 CET
@Morgan and @Iñigo, can you also say if you tested 32 or 64bit
Comment 25 Thomas Backlund 2018-03-07 20:58:26 CET
Advisory (added to svn):

type: bugfix
subject: Updated x11-driver-video-ati packages fixes screen flickering
src:
  6:
   core:
     - x11-driver-video-ati-7.10.0-1.1.mga6
description: |
  The update of x11-driver-video-ati in MGAA-2018-0022 caused screen
  flickering on some hardware, and in some cases problems with
  VT switching with ShadowFB. This update resolves that.
references:
 - https://bugs.mageia.org/show_bug.cgi?id=22488

Assignee: kernel => qa-bugs
Keywords: (none) => advisory

Comment 26 Iñigo Salvador Azurmendi 2018-03-07 23:29:36 CET
(In reply to Thomas Backlund from comment #24)
> @Morgan and @Iñigo, can you also say if you tested 32 or 64bit

64bit in my case.
Comment 27 Morgan Leijström 2018-03-08 07:52:19 CET
32 bit here.
Comment 28 Morgan Leijström 2018-03-08 08:05:25 CET
I was wrong. My test OK was on 64 bit mageia.

I will do a 32 bit reinstall on my 32 bit ati Thinkpad T42p now and report back here again.
Comment 29 Morgan Leijström 2018-03-08 12:04:06 CET
Test OK on 32 bit

__Details:
Fresh network install (pulling all normal updates while installing) 32 bit on my Thinkpad T42p (32 bit intel CPU, GPU ati X300), shows the reported problem.

SDDM login screen show flickering as described, but here show another bug: refuse to log in a user with no password set at install, will report that separately, or add to similar reports i see exist.

I changed to GDM and logged in that user OK.  Plasma did work, but with lots of diagonal, triangular graphical flickering and artifacts.

Simply enabling testing repo and updating to x11-driver-video-ati-7.10.0-1.1.mga6 and rebooting solved the flickering and it runs quicker too (was probably wasting cycles on drawing all the graphic debris...)
Comment 30 Morgan Leijström 2018-03-08 12:12:26 CET
Should QA test this update on modern ati GPU:s for regressions before releasing?
(I personally only have Intel and Nvidia on newer machines currently)
Comment 31 Thomas Backlund 2018-03-08 12:14:45 CET
No need

validating as tested and confirmed fixed on both arches

Keywords: (none) => validated_update
Whiteboard: (none) => MGA6-64-OK, MGA6-32-OK
CC: (none) => sysadmin-bugs

Comment 32 Mageia Robot 2018-03-08 12:30:14 CET
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0048.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 33 Morgan Leijström 2018-03-08 14:09:20 CET
Thanks Thomas

For the problem about Plasma multiple window overview functionalities problems - first described in comment 21 - i opened Bug 22720.

Sidenote: in my c#29 for SDDM i "misspelled" the user name in SDDM, i entered the user name with first letter capitalised, but that dialog need it all without caps...  "Beginners mistake" - or a stuipd login dialog.
Comment 34 Morgan Leijström 2018-03-08 18:00:21 CET
Much much better - but maybe not completely fixed?

SDDM and Plasma was working perfectly AFAICT, but now i logged out of Plasma and logged into Xfce and only see a black screen.

However, just doing Ctrl-alt-F2, Ctrl-Alt-F1 -> Xfce is OK
 -That look similar to comment 0 point b)

This is on that fresh install 32 bit Thinkpad T42p.

Resolution: FIXED => (none)
Source RPM: x11-driver-video-ati-7.10.0-1.mga6.src.rpm => x11-driver-video-ati-7.10.0-1.1.mga6.src.rpm
Status: RESOLVED => REOPENED

Comment 35 Morgan Leijström 2018-03-08 18:09:36 CET
Created attachment 10032 [details]
journalctl from plasma logout to xfce login and switching vt manually

This is part of journal from end of exiting plasma,
at 16:34:04 i select to login to Xfce,
screen was just black, until i pressed Ctrl-Alt-F2, Ctrl-Alt-F1 about a minute later and xfce got visible.
After end of this journal listing i see my USB stick being put in for capturing of this journal. 

Probably not related, but to me this seem strange:
' "requirement "user ingroup nopasswdlogin" not met by user "ettan" '
This user was created at system install, and have no password.
Comment 36 Thomas Backlund 2018-03-08 18:59:24 CET
This update is published, and as such the bug is closed.

And it fixed the real critical stuff (flickering making it useless)



If there still an issue with switchng DEs, open up a new report regarding that, and check if downgrading the x11-driver-video-ati still fixes it...

Also please try another DM, as sddm is known to be flaky... it pretty much gets hiccups even if you only sneeze :)

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED

Comment 37 Morgan Leijström 2018-03-08 19:01:28 CET
Was just going to :)

I do not see this using LightDM to log into Xfce, 
so i created a separate bug 22722

Note You need to log in before you can comment on or make changes to this bug.