Bug 22342 - All GNOME sessions (standard, classic or over Xorg) fail on Dell Optiplex 320
Summary: All GNOME sessions (standard, classic or over Xorg) fail on Dell Optiplex 320
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: x86_64 Linux
Priority: Normal critical
Target Milestone: ---
Assignee: GNOME maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 22362
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-07 14:00 CET by Luis Menina
Modified: 2018-01-09 16:53 CET (History)
1 user (show)

See Also:
Source RPM: gnome-shell-3.24.3-1.mga6.src.rpm
CVE:
Status comment:


Attachments
journalctl -b run as root after running startgnome (111.47 KB, text/plain)
2018-01-07 14:11 CET, Luis Menina
Details

Description Luis Menina 2018-01-07 14:00:02 CET
Description of problem:
If gdm is enabled, it restarts again and again.
I tried to disable the automatic launch of the graphical session, so I can log in, which works. Then calling startgnome or startgnome_classic fails.
I join the logs for `journalctl -b`

Please note that Xfce4 works, but it uses an Xorg session.

Version-Release number of selected component (if applicable):
gnome-shell-3.24.3-1

How reproducible:
always

Steps to Reproduce:
1. Install Mageia 6 with GNOME
2. At reboot GDM restarts in a loop

or (to avoid be trapped in the loop)
1. Install Mageia 6 with GNOME
2. Disable the graphical session being launched at startup
3. Reboot and log in
4. Run startgnome or startgnome_classic
Comment 1 Luis Menina 2018-01-07 14:11:23 CET
Created attachment 9881 [details]
journalctl -b run as root after running startgnome

I ran startgnome, it returns and error code of 143.
Then su'ed as root and run journalctl -b.
Comment 2 Luis Menina 2018-01-08 10:33:05 CET
There may be several problems here. I tried on a machine where GDM and the GNOME session works, and starting it in runlevel 3, logging in in console mode and running startgnome or startgnome_classic doesn't work either.
Marja Van Waes 2018-01-08 20:06:21 CET

Assignee: bugsquad => gnome
CC: (none) => marja11

Luis Menina 2018-01-09 16:33:09 CET

Summary: Impossible to open a GNOME session (classic or standard) on Dell Optiplex 320 (xfce works) => All GNOME sessions (standard, classic or over Xorg) fail on Dell Optiplex 320

Comment 3 Luis Menina 2018-01-09 16:52:48 CET
Not being able to log in runlevel 3 is now covered by bug #22362.
Luis Menina 2018-01-09 16:53:15 CET

Depends on: (none) => 22362


Note You need to log in before you can comment on or make changes to this bug.