Bug 22125 - Now Rawtherapee version is 5.3, with a lot of new functions, especially lens database.
Summary: Now Rawtherapee version is 5.3, with a lot of new functions, especially lens ...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Backports (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: http://rawtherapee.com/blog/rawtherap...
Whiteboard: MGA6-32-OK MGA6-64-OK
Keywords: Backport, validated_backport
Depends on:
Blocks:
 
Reported: 2017-12-05 06:17 CET by Thierry Houx
Modified: 2018-01-03 14:11 CET (History)
5 users (show)

See Also:
Source RPM: rawtherapee
CVE:
Status comment:


Attachments

Description Thierry Houx 2017-12-05 06:17:56 CET
Description of problem:
For good photo developments, correcting RAW file with lens parameters is very important; this new version offers this.

Version-Release number of selected component (if applicable):
Rawtherapee actual versoin: rawtherapee-5.1-1.2.mga6

How reproducible:


Steps to Reproduce:
1.
2.
3.
Thierry Houx 2017-12-05 06:19:03 CET

Summary: Now Rawtherapee version is 5.3, with a lot of new function, especially lens database. => Now Rawtherapee version is 5.3, with a lot of new functions, especially lens database.

Comment 1 Marja Van Waes 2017-12-05 08:10:23 CET
5.3 is already in cauldron. Our updates policy doesn't allow to update packages in stable releases for new features
https://wiki.mageia.org/en/Updates_policy#Version_Policy

However, the maintainer of rawtherapee might be willing to commit it to Mageia 6 backports_testing (so that it can be moved to backports after your positive feedback and after some testing by QA team).

Keywords: (none) => Backport
CC: (none) => marja11
Assignee: bugsquad => mrambo

Comment 2 Mike Rambo 2017-12-07 21:28:32 CET
Updated package uploaded for Mageia 6.

Advisory:
========================

Rawtherapee release 5.3 adds support for lensfun, a lens characteristics library, useful for photo editors such as rawtherapee to use in mitigating known irregularities in certain camera lenses. Backporting v5.3, already in cauldron, to mga6 (#22125).

Updated packages in core/backports_testing:
========================
rawtherapee-5.3-1.mga6

from rawtherapee-5.3-1.mga6.src.rpm

Assignee: mrambo => qa-bugs

Mike Rambo 2017-12-07 21:36:10 CET

Component: RPM Packages => Backports
CC: (none) => mrambo

Comment 3 Herman Viaene 2017-12-15 17:13:15 CET
MGA6-32 on Dell Latitude D600
No installation issues.
Tried rawtherapee in GUI mode, selected an ORF picture (Olympus raw format), changed some light parameters and saved to a jpeg. The resulting jpeg is 110kb from the original 14 Mb and at the CLI I get "Premature end of JPEG file
JPEG datastream contains no image" . I am not sure if this has anything to do with this small machine being overloaded by this program.
Tried at the CLI:
$ rawtherapee-cli -o p.tif -t -c P7212390.ORF 
RawTherapee, version 5.3, command line
Processing: P7212390.ORF
and got a noncompressed tif file of 49Mb, and perfectly viewable.
Good to go for me, unless someone else hits the same snag on a more powerful machine.

CC: (none) => herman.viaene
Whiteboard: (none) => MGA6-32-OK

Comment 4 Lewis Smith 2017-12-26 14:05:17 CET
Testing M6/64

First curiosity: that this is a backport. I was able to install rawtherapee from normal repos:
 # urpmi rawtherapee
    $MIRRORLIST: media/core/updates/rawtherapee-5.1-1.2.mga6.x86_64.rpm
but it then did *not* show in the MCC list for *_updates_testing repos. Nor:
 # urpmi --searchmedia "core updates testing" rawtherapee
Dim pecyn o'r enw rawtherapee [no pkg of this name]

However, installing it directly from *backports* testing repo worked:
 # urpmi --searchmedia "core backports testing" rawtherapee
    ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/6/x86_64/media/core/backports_testing/rawtherapee-5.3-1.mga6.x86_64.rpm
Should we have a backport which is essentially an update to an existing package?
---------------------------------------------------------
BTAIM, trying the update|backport: rawtherapee-5.3-1.mga6

From the menu GUI (which turned out to be a good way of driving RawTherapee), I added the only RAW file I have (huge, 86Mb):
 86107103 Meh  28  2012 /mnt/common/Mageia/images/Credo-Barcelona_0320.IIQ
which popped up "Leaf Credo 80 + Unknown" plus other info for the photograph, but seemed to successfully import the image with all its details such as colour distributions.
The entire complex interface all worked, though basic things like zooming & panning escaped me: this is a major & sophisticated application.
Exported the image as 8-bit JPEG, 8-bit TIFF uncompressed; 8-bit PNG. These operations took *extremely long*, many minutes:
   8918430 Rha  26 13:39 Credo-Barcelona_0320.jpg
  86979524 Rha  26 13:52 Credo-Barcelona_0320.png
 240038326 Rha  26 13:45 Credo-Barcelona_0320.tif
These vast images viewed fine with ImageMagick 'display', but the TIF caused problems with some viewers due to missing libraries.

All in all this update looks fine. OKing, but asking for feedback on the 'update or backport' question; if it is actually an update, its bug status needs changing, and an Advisory given. Once that it sorted, it can be validated.

Whiteboard: MGA6-32-OK => MGA6-32-OK MGA6-64-OK
CC: (none) => lewyssmith
Keywords: (none) => feedback

Comment 5 Mike Rambo 2017-12-27 14:01:37 CET
Please see Marja's comment #1 and the linked updates policy. This is a newer version than what was released with mga6 and, while there were speed optimizations and bug fixes mentioned in the release notes, it is primarily a feature update. It looks to me like it falls under that policy just as Marja stated. The main reason I backported it is because it adds the lens database feature not in the version originally released with mga6.

As far as the advisory is concerned, Luigi12 told me the advisory for a backport was a looser version of what was used for a bug fix so I made the advisory pretty much what I would have provided for a bug fix. I hope this answers your questions.

Keywords: feedback => (none)

Comment 6 Lewis Smith 2017-12-27 21:22:36 CET
Thank you Mike. I am confused about Mageia Update v Backport policy, but stand corrected both ways.
Backports do not have Advisories, so validating this.

Keywords: (none) => validated_backport

Comment 7 Thierry Houx 2017-12-28 17:46:23 CET
After a lot of RAW files developped, I confirm this version works well.
The lens correction works well (with last lensfun correction, bug 22170).

Sorry that updates policy doesn't allow to update packages, especially when corrections are so necessary for good usage and performances of this program.

For me, now, Rawtherapee works fine.
Comment 8 Thomas Backlund 2018-01-03 14:11:18 CET
package moved

Status: NEW => RESOLVED
Resolution: (none) => FIXED
CC: (none) => tmb


Note You need to log in before you can comment on or make changes to this bug.