Bug 21862 - synfig studio 1.2.1 - I request the update of the rpm
Summary: synfig studio 1.2.1 - I request the update of the rpm
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: New RPM package request (show other bugs)
Version: 6
Hardware: All Linux
Priority: Low normal
Target Milestone: Mageia 6
Assignee: QA Team
QA Contact:
URL: https://www.synfig.org/cms/en/download/
Whiteboard: MGA6-32-OK MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2017-10-14 17:39 CEST by jclb
Modified: 2017-12-06 12:43 CET (History)
6 users (show)

See Also:
Source RPM: synfigstudio
CVE:
Status comment:


Attachments

Description jclb 2017-10-14 17:39:16 CEST
"Synfig studio" this is = Synfig Animation Studio is a powerful, industrial-strength vector-based 2D animation software, designed from the ground-up for producing feature-film quality animation with fewer people and resources.

I made the request for update of  "synfig studio" we have 1.2.0 (Mageia6)

on https://www.synfig.org/cms/en/download/
proposed version 1.2.1
Comment 1 Marja Van Waes 2017-10-14 21:01:03 CEST
Afaics, 1.2.1 is a pure bugfix release, so it complies with our updates policy.

Assigning to the registered maintainer.

Assignee: bugsquad => rverschelde
CC: (none) => marja11

Marja Van Waes 2017-10-14 21:01:15 CEST

Status: UNCONFIRMED => NEW
Ever confirmed: 0 => 1

Josua Dietze 2017-11-27 20:29:17 CET

Assignee: rverschelde => digidietze
CC: (none) => digidietze

Comment 2 Josua Dietze 2017-11-27 20:30:31 CET
Assigning to me, as part of packager training - if there are no objections ...
Comment 3 Josua Dietze 2017-11-29 20:39:57 CET
I have submitted updated packages of Synfig Studio and its direct
requirements for Mageia 6.

Suggested advisory:
========================

The updated packages for synfigstudio are fixing a bunch of bugs as
described on the linked release information page. No new features
are added in this version.

Reference:
https://morevnaproject.org/2017/09/11/synfig-1-2-1-released/

========================



Updated packages in core/updates_testing:
========================

lib(64)etl-devel-1.2.1-1.mga6

lib(64)synfig-devel-1.~1-1.mga6
lib64synfig0-1.2.1-1.mga6
synfig-1.2.1-1.mga6

lib(64)synfigapp-devel-1.2.1-1.mga6
lib(64)synfigapp0-1.2.1-1.mga6
synfigstudio-1.2.1-1.mga6


Source RPMs:
etl-1.2.1-1.mga6.src.rpm
synfig-1.2.1-1.mga6.src.rpm
synfigstudio-1.2.1-1.mga6.src.rpm

========================


The basic functionality of the application was tested on MGA6
x86_64

Assignee: digidietze => qa-bugs

Comment 4 Herman Viaene 2017-11-30 11:18:54 CET
MGA6-32 on Dell Latitude D600 MATE
No installation issues.
Synfigstudio starts up, and I could draw a rectangle, cirkle and a little text, although this is a painfully slow exercise on this little machine. But seems OK.

CC: (none) => herman.viaene
Whiteboard: (none) => MGA6-32-OK

Josua Dietze 2017-12-02 16:53:06 CET

Severity: enhancement => normal

Comment 5 Len Lawrence 2017-12-04 13:22:50 CET
Mageia 6 :: x86_64

Installed the packages and launched Synfig Studio from the Graphics menu.

Updated the seven packages.

Launched Synfig Studio and tried out various tools.  Created circles and sketched a triangle.  Created a canvas of graded circles and a spiral gradient, just by poking around.  Tried saving to a file; appeared as 'Synfig Animation 1.sifz'.

It looks as if it is working, as Josua indicated in comment 3.

Validating this.  It can be pushed whenever the advisory is ready.

Whiteboard: MGA6-32-OK => MGA6-32-OK MGA6-64-OK
Keywords: (none) => validated_update
CC: (none) => tarazed25, sysadmin-bugs

Comment 6 Dave Hodgins 2017-12-05 21:05:39 CET
The etl srpm is very unusual in that it only has the one devel package, which
is not required by any other package so won't be installed on most users systems.
From it's contents, I'm guessing the package is only used as a build requires,
not a run time requires, so other then ensuring it updates cleanly, no other
testing of that package can be done. First time I remember seeing an update
like this.

Advisory committed to svn.

Keywords: (none) => advisory
CC: (none) => davidwhodgins

Comment 7 Mageia Robot 2017-12-06 12:43:57 CET
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2017-0123.html

Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.