Bug 21736 - KDE apps do not find the network printer
Summary: KDE apps do not find the network printer
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-18 16:56 CEST by James Kerr
Modified: 2017-11-16 11:12 CET (History)
2 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description James Kerr 2017-09-18 16:56:23 CEST
KDE apps such as kwrite and okular do not find the network printer.

GTK apps such as LO and firefox do find the network printer.

Using CUPS web interface to set the network printer as the "server default" makes KDE apps aware of the network printer and enables printing using those apps.

While that is an acceptable workaround when only a single network printer is available, it may not be adequate when the user has several network printers.

I think that this looks like a plasma/KDE bug and not a CUPS bug, but I've no idea which package is responsible.

IIRC the bug has existed since I upgraded from Mageia 5 to Mageia 6 on 17th July. I am reporting it now because it seems to be affecting at least one other user:

https://forums.mageia.org/en/viewtopic.php?f=0&t=11904&p=70096&hilit=CUPS#p70090
David Walser 2017-09-18 22:48:37 CEST

Assignee: bugsquad => kde

Comment 1 Jeff Robins 2017-09-21 08:50:10 CEST
I can confirm the bug and the work-around.  

I have 2 printers on the same server (MGA5 install) and I can see and print to both of them after setting one to serer default.

CC: (none) => jeffrobinsSAE

Comment 2 James Kerr 2017-10-16 10:34:53 CEST
Seems to be this:

https://github.com/apple/cups/issues/5046

So perhaps a cups issue and not a KDE issue
Comment 3 jcl darkc 2017-11-09 15:52:46 CET
 I confirm the bug also.

 it's impossible to print on a CUPS/network printer from any QT/kde applications (gwenview, okular ..), but it works fine from gtk based apps like firefox.

It seems to be a bug related to cups 2.2.4, it affects also archlinux users (see https://bugs.archlinux.org/task/54695).

 I found a solution :

 I recompiled cups 2.2.6 from cauldron SRPMS (ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/cauldron/SRPMS/core/release/cups-2.2.6-1.mga7.src.rpm), and now everything works as expected, I can use my cups printers from any applications (QT/KDE/GTK).

JC

CC: (none) => jcldc13

Comment 4 James Kerr 2017-11-16 11:12:31 CET
Fixed in cups-2.2.6

http://advisories.mageia.org/MGAA-2017-0109.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.