Bug 21672 - Update Parole (player Xfce)
Summary: Update Parole (player Xfce)
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://smdavis.us/2017/06/04/develop...
Whiteboard: MGA6-32-OK MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2017-09-06 17:18 CEST by magnux77
Modified: 2019-03-07 17:35 CET (History)
6 users (show)

See Also:
Source RPM: parole
CVE:
Status comment:


Attachments

Description magnux77 2017-09-06 17:18:07 CEST
Description of problem:
Version 0.9.2 of Parole has been delivered since june 4, 2017 which solves the annoying bug of the wrong display order of audio tracks. But Parole in Mageia 6 is still in 0.8.1. When will it be updated ?
Thanks a lot.



Version-Release number of selected component (if applicable):
Parole 0.8.1 -> Parole 0.9.2

How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Marja Van Waes 2017-09-07 00:05:01 CEST
(In reply to magnux77 from comment #0)
> Description of problem:
> Version 0.9.2 of Parole has been delivered since june 4, 2017 which solves
> the annoying bug of the wrong display order of audio tracks. But Parole in
> Mageia 6 is still in 0.8.1. When will it be updated ?


Assigning to the Parole maintainer.

Assignee: bugsquad => jani.valimaa
CC: (none) => marja11

Comment 2 magnux77 2019-02-18 20:00:14 CET
When Mageia 7 will be released, this problem will be solved. Parole will be upgraded to version 1.

Resolution: (none) => FIXED
Status: NEW => RESOLVED

Comment 3 Nicolas Lécureuil 2019-02-24 00:15:34 CET
if there is a bug in mageia 6 i think we need to update parole to version 1.0

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)
CC: (none) => mageia

Comment 4 Jani Välimaa 2019-02-24 11:15:15 CET
parole-1.0.1-1.mga6 is now in core/updates_testing for tests. Sorry about the long delay.

CC: (none) => jani.valimaa
Assignee: jani.valimaa => qa-bugs

Comment 5 Thomas Andrews 2019-02-24 22:34:50 CET
As there are no SRPMs listed for this bug, the only package tested was the one from Comment 4.

32-bit version tested on real hardware, Core2Duo, Intel graphics. 64-bit version tested in a Mageia 6 guest in a Mageia 7 VirtualBox host on the same hardware.

Packages installed cleanly on both systems. Tried an AVI video from an old camera on the 32-bit system, and it played OK. Tried .mp4 videos on both systems. Virtual system would not play the mp4 until after gstreamer packages were updated to tainted versions. Not at all unusual. The 32-bit gstreamer tainted packages had already been installed.

This looks OK to me. Validating.

CC: (none) => andrewsfarm, sysadmin-bugs
Keywords: (none) => validated_update
Whiteboard: (none) => MGA6-32-OK MGA6-64-OK

Comment 6 magnux77 2019-03-01 11:18:58 CET
Hi ! My problem was that Parole 0.8.1 plays tracks of an album not always in order of the track#, but sometimes in alphabetic order of the title of the track.
As i saw that Parole 0.9 delivered before Mageia 6 should solve this problem so I posted this bug to ask for Parole 0.9 delivery.

I tested Parole 1.0.1 / M7 this morning, my problem remains the same. I tested with a new user, i looked with Easytag, i didn't find anything. Somme albums are played in order of track#, some not. and in all the case : track # is the first characters of the title of the track, is in the ID3 tags, is not displayed by Parole.

I 'll close this bug in a while cause i think it's not a Mageia bug. But befor if someone has an idea, i'll appreciate. ;-)
Comment 7 Thomas Andrews 2019-03-01 14:02:14 CET
It may be an upstream bug, but then maybe not. We won't know until it's investigated. 

I'd recommend opening a new bug against Cauldron. Please try the updated version in Mageia 6 if you can, and report in the bug description if it is affected, too.

If there are no other problems with this update, I believe we should go ahead with it. If a fix is found for Cauldron, it can probably be applied to Mageia 6, as well.
Comment 8 magnux77 2019-03-02 14:04:39 CET
"Please try the updated version in Mageia 6 if you can"
I 'd like but i don't know how. Show me the way.

"I'd recommend opening a new bug against Cauldron."Why ?

It's impossible to log in Parole bugzilla...
Comment 9 Thomas Andrews 2019-03-02 15:25:21 CET
I meant a new bug here, in Mageia's Bugzilla.

Probably the easiest way for you to install and test just the parole update in Mageia 6 would be to use the QaRepo tool. See https://wiki.mageia.org/en/QA_Repo for some documentation on how to install and use it. It's really very easy, once you get the hang of it. For this particular test, use the package name from Comment 4 in the qarepo rpm list.

If you like the idea of helping to test updates, I invite you to join the QA team. Don't be concerned about whatever your level of expertise is, as we need input from all levels. See https://wiki.mageia.org/en/QA_Team for more details.

Removing the validation, for now, until magnux77 has a chance to try the update in Mageia 6.

Keywords: validated_update => (none)

Comment 10 magnux77 2019-03-02 17:37:29 CET
I bugzilled at Xfce.

Someone posted the same problem. In 2015 !
As it is not really critical (you can play et hear music) i think there is no real pressure to solve it.
https://bugzilla.xfce.org/show_bug.cgi?id=12335
Comment 11 Thomas Andrews 2019-03-02 21:19:55 CET
All right then, since it seems to be an ongoing upstream problem, and relatively minor, it's not enough to hold back the update. In addition, it's best for those who want to take the upgrade path from Mageia 6 to Mageia 7 that the update go forward.

I'm re-instating the validation. We still need a proper advisory before this can be pushed.

Keywords: (none) => validated_update

Comment 12 Dave Hodgins 2019-03-06 22:44:35 CET
Added advisory to svn as ...
$ cat 21672.adv 
type: bugfix
subject: Updated parole package fixes various bugs.
src:
  6:
   core:
     - parole-1.0.1-1.mga6
description: |
  Updated parole package fixes various bugs and translations. See
  /usr/share/doc/parole/ChangeLog after installing the update for details.
references:
 - https://bugs.mageia.org/show_bug.cgi?id=21672

Keywords: (none) => advisory
CC: (none) => davidwhodgins

Comment 13 Mageia Robot 2019-03-07 17:35:46 CET
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2019-0017.html

Status: REOPENED => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.