Bug 21279 - Boot installation failed when upgrading Mageia 5 to 6 on a 64-bit system
Summary: Boot installation failed when upgrading Mageia 5 to 6 on a 64-bit system
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: 6
Hardware: x86_64 Linux
Priority: Normal critical
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
Depends on:
Reported: 2017-07-18 22:52 CEST by Marie Fraser
Modified: 2017-07-24 14:20 CEST (History)
1 user (show)

See Also:
Source RPM:
Status comment:


Description Marie Fraser 2017-07-18 22:52:17 CEST
Description of problem:
I was upgrading from a DVD on which I had burned Mageia-6-x86_64-DVD.iso.  The first indication of a problem  was the error on grub2-install - i386-pc platform.  Since the machine would not boot, I tried to rescue from the DVD.  I have /boot/EFI, which mounts as /mnt/boot/EFI, but then get the message "Configuration files for Boot Loaders grub2 and lilo were found."  I tell it grub2 and it recognizes Mageia release 6 (official) for x86_64, but fails when installing for i386-pc platform.  Is there a file or files I need to remove to get my system recognized as a UEFI system?
Comment 1 Barry Jackson 2017-07-19 00:14:54 CEST
Was the boot mode of the Mageia5 that you upgraded UEFI or PC-BIOS ?

You must upgrade from install media booted in the same mode.

It sounds to me that you maybe have a UEFI installation and have tried to upgrade it with an install disk booted in PC-BIOS mode.


CC: (none) => zen25000

Comment 2 Marie Fraser 2017-07-19 00:47:01 CEST
I thought the Mageia5 machine was UEFI because I checked for the EFI disk before doing the installation.

I copied the ISO to the DVD using KDE, then booted from it for the installation.  How would I know that the DVD was booting in PC-BIOS mode and how would I change this?  I simply have the setting to boot from the DVD if one is loaded.

Thank you!
Comment 3 Barry Jackson 2017-07-19 01:18:30 CEST
Normally there are screen shots here:

The screen shots are missing due to a server security upgrade if I understand correctly.

I think the initial bootloader menu page says clearly at the top that it is the UEFI version, when the system is booted in that mode.

If your machine allows you to hit F12 (or similar) during the start of boot to select the boot media, then you should see two entries for the DVD, one will mention UEFI.

If you boot the installer in UEFI mode and repeat the upgrade (it should be really fast) then you may be able to complete the install correctly.

Please don't give up if this fails, just report back with any error messages you see.
Comment 4 Marie Fraser 2017-07-19 02:35:41 CEST
Thank you, that was the problem!  After F12, I looked further down the list and saw the UEFI mode for the DVD.  It was a quick installation after that and the system is running.
Comment 5 Barry Jackson 2017-07-19 10:35:37 CEST

Closing then.

Resolution: (none) => INVALID

Rémi Verschelde 2017-07-24 14:19:52 CEST

Blocks: (none) => 21340

Rémi Verschelde 2017-07-24 14:20:07 CEST

Blocks: 21340 => (none)

Note You need to log in before you can comment on or make changes to this bug.