Bug 21257 - xfce auto-login not working
Summary: xfce auto-login not working
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: Mageia 7
Assignee: Jani Välimaa
QA Contact:
URL:
Whiteboard:
Keywords: 7RC
Depends on:
Blocks:
 
Reported: 2017-07-17 12:26 CEST by Tony Blackwell
Modified: 2019-06-15 21:19 CEST (History)
1 user (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Tony Blackwell 2017-07-17 12:26:14 CEST
Description of problem:
Just dumps user at the password box of the usual login screen


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Marja Van Waes 2017-07-17 23:34:16 CEST
Assigning to the XFCE maintainer

Assignee: bugsquad => anssi.hannula
CC: (none) => marja11

Comment 2 Marja Van Waes 2017-07-17 23:34:42 CEST
(In reply to Marja van Waes from comment #1)
> Assigning to the XFCE maintainer

now really assigning to him!

Assignee: anssi.hannula => jani.valimaa

Comment 3 Tony Blackwell 2019-05-03 00:49:49 CEST
Hi from OP.
Still not working as at M7 x86_64 beta3

Keywords: (none) => 7beta3
Target Milestone: --- => Mageia 7

Comment 4 Jani Välimaa 2019-05-04 16:13:06 CEST
1. How are you configuring the auto login?
2. During or after the installation?
3. Which display manager are you using?
4. Xfce only install or multiple DEs?

I can't reproduce the issue when configuring the auto login after a fresh Xfce only installation with lightdm as DM.

As a side note, there's a bug in drakxtools' drakautologin where there's no effect which ever DE session one selects from the tool if lightdm is used as a display manager. The bug is fixed in GIT and waiting for a new drakxtools release.
Comment 5 Tony Blackwell 2019-05-05 02:58:53 CEST
Hi Jani,
Came back to this bug in context of reviewing my old bugs.
Current system is a recent M7 x86_64 Beta3 Classical upgrade from M6 x86_64 so could well still have old configuration baggage.

Installed upgrade (and original) with all desktops.
Chose xfce on login after re-boot post-installation, where it remains the default.
Went to autologin, where chose myself as user and xfce.  Get only the usual login screen on reboot.
Display manager with this M7 is the default SDDM  

Hmm, tried it on another laptop M7B3, but this was also installed as a classical upgrade from M6 as per my main system, still shows the problem (but this was a rudimentary just-installed but fully updated M6).  I guess it really needs a clean new install to fully test, but I never did solve the problem with M6.

I'm off overseas Tuesday for a month, so limited time to work on this prior.  Back 10th June, but can work on it using the small laptop mentioned above while away - but no reinstall...
Tony
Comment 6 Jani Välimaa 2019-05-05 10:10:03 CEST
Could you test auto login also for other DEs than Xfce?

I think the bug is in drakautologin and how it configures SDDM.
Comment 7 Jani Välimaa 2019-05-05 10:57:24 CEST
Tested with Xfce and SDDM and can't reproduce the issue. Auto login is working as expected. It worked also with MATE and SDDM.
Comment 8 Tony Blackwell 2019-05-05 11:10:56 CEST
Well, its real enough here.  We've a business, plus personal, plus family of laptops, plus 5 computers  set up for neighbourhood kids, and I never did get xfce autologin  working with M6.  Do0esn't work on 3 upgraded-to-M7 here.

Its not as if there is much choice in making the selection through the boot option in MCC :-)

Ideas?
Tony
Comment 9 Jani Välimaa 2019-05-12 09:16:53 CEST
Please test with mga7 and drakxtools-18.17-1.mga7.
Comment 10 Tony Blackwell 2019-05-12 16:31:17 CEST
Sorry, from where?  Not in core updates testing or core updates testing debug or similar...
Tony
Comment 11 Jani Välimaa 2019-05-12 17:14:36 CEST
It's in core/release for mga7. As mga7 isn't released yet and it's technically same as Cauldron at the moment, all pkg updates goes to release.

Simple 'urpmi --auto-update' should do the the trick with mga7b3.
Comment 12 Tony Blackwell 2019-06-15 21:19:09 CEST
Working as of M7 RC x86_64

Keywords: 7beta3 => 7RC
Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.