Bug 21216 - Cinnamon desktop background black under some display managers
Summary: Cinnamon desktop background black under some display managers
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal minor
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: advisory MGA6-64-OK
Keywords: PATCH, UPSTREAM, validated_update
: 20914 (view as bug list)
Depends on:
Blocks: 21340
  Show dependency treegraph
 
Reported: 2017-07-10 11:18 CEST by Lewis Smith
Modified: 2017-07-27 21:53 CEST (History)
3 users (show)

See Also:
Source RPM: cinnamon-session-3.2.0-1.mga6
CVE:
Status comment:


Attachments
report.bug.xz (x86_64) (221.54 KB, application/x-xz)
2017-07-12 07:50 CEST, ben mcmonagle
Details

Description Lewis Smith 2017-07-10 11:18:04 CEST
Description of problem:
In a system (real hardware) with all 6 desktops installed, Cinnamon desktop background is black if launched from GDM, LXDM, SDDM; but shows correctly from LightDM.
(In fact the black background is pleasing).

Version-Release number of selected component (if applicable):
Mageia 6, Classic ISO of 8 July 2017.

How reproducible:
Static problem.
Rémi Verschelde 2017-07-10 11:44:02 CEST

Assignee: bugsquad => joequant

Comment 1 ben mcmonagle 2017-07-11 22:50:39 CEST
The background / wallpaper is unable to be changed in either i586 or x86_64 all DE install.
The Mageia 6 wallpaper is in the "Change desktop background" options, as is "default", but they are un-selectable.
Using the mouse tool "Set as wallpaper" when hovered over an image is also not possible.



will attach report.bug.xz from either install, later.

CC: (none) => westel

Comment 2 ben mcmonagle 2017-07-12 07:50:42 CEST
Created attachment 9487 [details]
report.bug.xz (x86_64)
Lewis Smith 2017-07-13 14:52:15 CEST

Keywords: (none) => IN_ERRATA6

Comment 3 Martin Whitaker 2017-07-25 23:19:22 CEST
This bug has already been reported and fixed upstream:

  https://github.com/linuxmint/Cinnamon/issues/6375

I've applied the fix manually and confirmed it works for us.

CC: (none) => mageia
Keywords: (none) => UPSTREAM

Comment 4 Martin Whitaker 2017-07-25 23:23:58 CEST
*** Bug 20914 has been marked as a duplicate of this bug. ***
Martin Whitaker 2017-07-25 23:37:26 CEST

Blocks: (none) => 21340

Comment 5 Rémi Verschelde 2017-07-25 23:39:48 CEST
Thanks Martin!

Added the patch to Mageia 6's version (Cauldron has 3.4.1 which already contains that fix) in cinnamon-session-3.2.0-1.1.mga6.

Advisory:
=========

Updated cinnamon-session package fixes GTK+ 3.24 theme settings support

  Cinnamon 3.2.0 does not honor the theme settings of GTK+ 3.24 properly, which
  can manifest itself e.g. by a black background when run from some desktop
  managers (mga#21216). An upstream patch is backported to fix it.

References:
 - https://github.com/linuxmint/Cinnamon/issues/6375

RPM in core/updates_testing:
============================

cinnamon-session-3.2.0-1.1.mga6

SRPM in core/updates_testing:
=============================

cinnamon-session-3.2.0-1.1.mga6

Source RPM: (none) => cinnamon-session-3.2.0-1.mga6
Keywords: (none) => PATCH
Assignee: joequant => qa-bugs

Comment 6 Rémi Verschelde 2017-07-25 23:40:12 CEST
Note that the corresponding errata entry could be removed once this update is validated.
Lewis Smith 2017-07-26 20:02:10 CEST

Whiteboard: (none) => advisory

Comment 7 Lewis Smith 2017-07-26 20:42:51 CEST
Tested OK M6 x64

After applying the update to: cinnamon-session-3.2.0-1.1.mga6
the Cinnamon desktop displayed the correct Mageia background from all display managerss: GDM, LightDM, LXDM, SDDM.
Validating the update. Advisory already done. Errata yet to update.

Whiteboard: advisory => advisory MGA6-64-OK
Keywords: IN_ERRATA6 => validated_update
CC: (none) => sysadmin-bugs

Trou Du Cul Merdeux 2017-07-26 20:54:27 CEST

CC: (none) => trouducul
Severity: minor => critical
Status: NEW => ASSIGNED
Whiteboard: advisory MGA6-64-OK => advisory MGA6-64-OK MGA6-32-OK

Comment 8 Samuel Verschelde 2017-07-26 21:35:07 CEST
Restoring bug fields to how they were before a troll changed them.

Severity: critical => minor
Status: ASSIGNED => NEW
Whiteboard: advisory MGA6-64-OK MGA6-32-OK => advisory MGA6-64-OK
Keywords: validated_update => (none)
CC: trouducul => (none)

Comment 9 Lewis Smith 2017-07-26 21:42:03 CEST
@Samuel
Not sure what you mean. I am not a Troll. Please state your objections.
I took out IN_ERRATA6 because I thought you would want that. If you want it  back, please put it back. As for the Validated keyword, that was intended. We cannot currently afford the luxury of wanting 32-bit tests as well for all updates. If you agree, please restore that too.
Comment 10 Manuel Hiebel 2017-07-26 21:45:39 CEST
Lewis, it was against someone else, cf history ;)
adding back the stuff you added

Keywords: (none) => validated_update
Whiteboard: advisory MGA6-64-OK => advisory MGA6-64-OK advisory MGA6-64-OK MGA6-32-OK

Rémi Verschelde 2017-07-26 21:50:00 CEST

Whiteboard: advisory MGA6-64-OK advisory MGA6-64-OK MGA6-32-OK => advisory MGA6-64-OK

Comment 11 Samuel Verschelde 2017-07-26 21:51:01 CEST
(In reply to Manuel Hiebel from comment #10)
> Lewis, it was against someone else, cf history ;)
> adding back the stuff you added

Thanks for clarifying. I was not talking about you, Lewis, obviously :)

That troll had added validated_update to another bug report and I wrongly thought he had added it here too but it was you, so Manuel was right to restore it.
Comment 12 Mageia Robot 2017-07-27 21:53:03 CEST
An update for this issue has been pushed to the Mageia Updates repository.

http://advisories.mageia.org/MGAA-2017-0035.html

Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.