Bug 20976 - MCC set up printer - installs 2 meta packages but never gets to printer setup
Summary: MCC set up printer - installs 2 meta packages but never gets to printer setup
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: Nicolas Lécureuil
QA Contact:
Keywords: 6RC
Depends on:
Blocks: 18367
  Show dependency treegraph
Reported: 2017-05-30 01:31 CEST by jim Mac
Modified: 2022-12-28 18:06 CET (History)
1 user (show)

See Also:
Source RPM: system-config-printer
Status comment:


Description jim Mac 2017-05-30 01:31:41 CEST
Description of problem:

MCC->hardware->pinters - unable to set anything up after requested packages are installed.  Go back to MCC->hardware->pinters and software install is requested again.  Repeated many times - not able to set up printers

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1.  See above
jim Mac 2017-05-30 01:35:17 CEST

Status comment: (none) => Blocking - should not release if printer cannot be set up
Keywords: (none) => 6RC, PATCH

Comment 1 Marja Van Waes 2017-05-30 21:52:10 CEST
Hi Jim,

Thanks for the report.

How many boots ago was it that you tried to install a printer?

Please go to a terminal/konsole, become root and run the following command, while replacing the letter N with the number of times that you rebooted since you tried to install a printer and saw that those meta packages got installed:

  journalctl -ab-N > log.txt

(So journalctl -ab-4 > log.txt if you rebooted 4 times)

compress log.txt with xz:

  xz log.txt

and then attach log.txt.xz to this bug report.

Thanks :-)

There is no patch attached, so erasing that Keyword.
The "Status comment:" field is intended for information from our packagers about the progress that's made towards fixing the bug, emptying that, too.

Assigning to the registered maintainer of system-config-printer

CC: (none) => marja11
Assignee: bugsquad => mageia
Source RPM: (none) => system-config-printer
Status comment: Blocking - should not release if printer cannot be set up => (none)
Blocks: (none) => 18367
Keywords: PATCH => (none)

Comment 2 jim Mac 2017-06-01 07:32:23 CEST
Unknown how many reboots but between 3-7 times

journalctl command indicated produced no results trying values 1-4 for N 

got printing to work...  with the following steps:

1.  in MCC removed all cups packages that were removable (lib cups64 I think was locked and not removable...

2 in MCC->Hardware-->printers etc selected add printer - prompted for multiple packages to be installed(about 32) - selected yes... all packages seemed to install fine.

3,  went back to MCC printer setup and printers could now be installed and work now.

4.  Network printer installed correctly using this method are Brother DCP8065DN and HP 7310 all-in-one.

5.  Scanning has not been tested.  I will test this and report back as soon as I can.


before these steps I tried in MCC to install the meta packages the original printer setup dialog said it was installing and found that they had not been installed and that no other relevant cups packages could be installed - "sorry this package cannot be installed" etc


The cups packages on the original install DVD(selected Plasma5) have a problem that prevents other cups packages to be installed.

Let me know how else I can help - I am very excited about this new release.  I use mageia for servers once i know it is stable.

Comment 3 sturmvogel 2022-12-28 18:06:00 CET
This bug was filed against Mageia 6 RC. Magei 6 is EOL since Sep 2019.

Thus closing OLD.

Resolution: (none) => OLD

Note You need to log in before you can comment on or make changes to this bug.