Bug 20826 - Import dvdcss patch to brasero
Summary: Import dvdcss patch to brasero
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
: 23164 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-11 01:43 CEST by katnatek
Modified: 2018-06-14 20:15 CEST (History)
6 users (show)

See Also:
Source RPM: brasero-3.12.1-6.mga6.src.rpm
CVE:
Status comment:


Attachments
spec for brasero-3.12.2 for mageia 6 (12.60 KB, text/plain)
2018-02-16 20:12 CET, katnatek
Details
Revised spec for brasero 3.12.2 in Mageia 6 (12.65 KB, text/plain)
2018-02-21 20:04 CET, katnatek
Details

Description katnatek 2017-05-11 01:43:52 CEST
Description of problem:

due to upstream changes in libdvdcss, brasero don't detect the version of the library as must.

Arch (https://aur.archlinux.org/cgit/aur.git/tree/dvdcss-nocheck.patch?h=brasero-dvdcssfix) and fedora (http://pkgs.fedoraproject.org/cgit/rpms/brasero.git/tree/brasero-libdvdcss.patch) solve the issue with a patch
Comment 1 Rémi Verschelde 2017-05-11 12:46:20 CEST
Assigning to all packagers as brasero doesn't have a maintainer currently.

Assignee: bugsquad => pkg-bugs

Comment 2 katnatek 2018-02-15 00:31:50 CET
Please backport 3.12.2 , this issue is solved in that version
Comment 3 katnatek 2018-02-16 20:12:30 CET
Created attachment 9992 [details]
spec for brasero-3.12.2 for mageia 6

I backport brasero 3.12.2 from cauldron to mageia 6 in blogdrake's repositories
This is the spec based in the official mageia's spec for brasero in mageia 6 and cauldron
Comment 4 REINQUIN Franck 2018-02-17 11:29:46 CET
Thanks katnatek ! Works fine for me.

CC: (none) => OLDTIMER.BUGZILLA

Comment 5 David GEIGER 2018-02-17 12:41:01 CET
I pushed brasero 3.12.2 in 6/Core/Updates_testing repo.

Please it, thanks in advance!

CC: (none) => geiger.david68210

Comment 6 David GEIGER 2018-02-17 12:47:38 CET
Please test it*
Comment 7 katnatek 2018-02-17 20:17:18 CET
(In reply to David GEIGER from comment #6)
> Please test it*

Light test, works, its not really some that use too much and i like k3b more.
Your build and mine look equal so i disable blogdrake's repository to make sure i test yours ;)

Tested on Mga6 Xfce i586
Comment 8 katnatek 2018-02-19 19:31:25 CET
(In reply to David GEIGER from comment #6)
> Please test it*

In the mageia 6 spec for brasero

%find_lang %{name} --with-gnome

Is 

%find_lang %{name} --with-help

Maybe for that i did have to add this lines?

%{_datadir}/help/*/brasero/*.page
%{_datadir}/help/*/brasero/*/*.png

i will fix in my spec and make a test
Comment 9 katnatek 2018-02-20 20:43:53 CET
The --with-help makes the difference, with the last lines of the files section are not required

%{_datadir}/help/*/brasero/*.page
%{_datadir}/help/*/brasero/*/*.png

You can let --with-gnome as long as is used in the cauldron's spec but don't have effect if you build from mageia 6
Comment 10 katnatek 2018-02-20 20:48:09 CET
(In reply to katnatek from comment #9)
> The --with-help makes the difference, with the last lines of the files
> section are not required
I really likes bugzilla allow edit own comments :\ this line must be

The --with-help makes the difference, with that option the last lines of the files section are not required
Comment 11 katnatek 2018-02-21 20:04:18 CET
Created attachment 9999 [details]
Revised spec for brasero 3.12.2 in Mageia 6

Attachment 9992 is obsolete: 0 => 1

Comment 12 katnatek 2018-05-12 00:05:55 CEST
Change version to 6 because was reported in mga 6 sta2 times
And closing as fixed

Version: Cauldron => 6
Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 13 Marja Van Waes 2018-06-12 00:15:01 CEST
(In reply to katnatek from comment #12)
> Change version to 6 because was reported in mga 6 sta2 times
> And closing as fixed

It was fixed in Cauldron, but since daviddavid pushed brasero-3.12.2-1.mga6 to 6 core/updates_testing on 17 february (the day before you attached your revised spec), nothing happened for Mageia 6.

This report should have stayed open, because new brasero will never land in 6_core/updates without passing QA team's tests ;-)

You did say about brasero-3.12.2-1.mga6:

> Light test, works

but then proposed a spec file revision. 

Why was that?

Resolution: FIXED => (none)
CC: (none) => marja11
Status: RESOLVED => REOPENED

Comment 14 Marja Van Waes 2018-06-12 00:17:50 CEST
*** Bug 23164 has been marked as a duplicate of this bug. ***

CC: (none) => rolfpedersen

Comment 15 David GEIGER 2018-06-12 05:22:16 CEST
Assigning to QA,


Advisory:
=============================

Some users reported that our current brasero package don't detect the version of the libdvdcss library anymore due to upstream changes in libdvdcss.

This updates fixes this issue.


Packages in 6/core/updates_testing:
========================
brasero-3.12.2-1.mga6.i586.rpm
libbrasero-burn-gir3.1-3.12.2-1.mga6.i586.rpm
libbrasero-burn3_1-3.12.2-1.mga6.i586.rpm
libbrasero-devel-3.12.2-1.mga6.i586.rpm
libbrasero-media-gir3.1-3.12.2-1.mga6.i586.rpm
libbrasero-media3_1-3.12.2-1.mga6.i586.rpm
libbrasero-utils3_1-3.12.2-1.mga6.i586.rpm
brasero-3.12.2-1.mga6.x86_64.rpm
lib64brasero-burn-gir3.1-3.12.2-1.mga6.x86_64.rpm
lib64brasero-burn3_1-3.12.2-1.mga6.x86_64.rpm
lib64brasero-devel-3.12.2-1.mga6.x86_64.rpm
lib64brasero-media-gir3.1-3.12.2-1.mga6.x86_64.rpm
lib64brasero-media3_1-3.12.2-1.mga6.x86_64.rpm
lib64brasero-utils3_1-3.12.2-1.mga6.x86_64.rpm

Source RPM: 
========================
brasero-3.12.2-1.mga6.src.rpm

Assignee: pkg-bugs => qa-bugs

Comment 16 Rolf Pedersen 2018-06-12 17:24:00 CEST
I updated only brasero:

[rolf@z68x ~]$ rpm -qa | grep brasero
lib64brasero-burn3_1-3.12.1-6.mga6
lib64brasero-utils3_1-3.12.1-6.mga6
lib64brasero-media3_1-3.12.1-6.mga6
brasero-3.12.2-1.mga6
[rolf@z68x ~]$

The plugins browser (Edit > Plugins) now shows dvdcss as enabled.  I made a copy of a protected dvd to an iso on hard drive and that plays fine in vlc.  These two problems I reported in https://bugs.mageia.org/show_bug.cgi?id=23164 are, I would say, solved.
Thanks.
Comment 17 katnatek 2018-06-12 18:46:39 CEST
(In reply to Marja Van Waes from comment #13)
> It was fixed in Cauldron, but since daviddavid pushed brasero-3.12.2-1.mga6
> to 6 core/updates_testing on 17 february (the day before you attached your
> revised spec), nothing happened for Mageia 6.
> 

Maybe i forgot to disable testing repositories when tested and i got brasero updated, i will make double check next time

(In reply to Marja Van Waes from comment #13)
> This report should have stayed open, because new brasero will never land in
> 6_core/updates without passing QA team's tests ;-)
> 

OK
(In reply to Marja Van Waes from comment #13)
> You did say about brasero-3.12.2-1.mga6:
> 
> > Light test, works
> 
> but then proposed a spec file revision. 
> 
> Why was that?
Other thing i need to check next time, i don't check the David's spec, i put just in case he based in the spec i did originally posted, the changed spec just remove some unnecessary lines by put the right parameter in the %find_lang macross , but not change the final content of rpm
Comment 18 Len Lawrence 2018-06-13 13:14:06 CEST
Mageia 6, x86_64

lib64dvdcss2-1.4.1-1.mga6.tainted is installed.
Installed all the brasero packages and invoked the interface to confirm that libdvdcss was not detected.

Updated all seven packages and invoked the gui again.  In edit->plugins dvdcss is now checked.  Made a copy of a commercial DVD to an iso (7.7GB).
$ sudo mkdir /mnt/iso/
$ sudo mount -t iso9660 -o ro,loop /home/lcl/Videos/Humans_disc_1.iso /mnt/iso
$ ls /mnt/iso
audio_ts/  video_ts/
$ vlc /mnt/iso
The episodes play fine including the subtitles.

This is probably good enough for an OK.

CC: (none) => tarazed25
Whiteboard: (none) => MGA6-64-OK

Comment 19 claire robinson 2018-06-14 18:19:53 CEST
Validating

CC: (none) => sysadmin-bugs
Keywords: (none) => validated_update

Comment 20 claire robinson 2018-06-14 18:44:27 CEST
Advisoried

Keywords: (none) => advisory

Comment 21 Mageia Robot 2018-06-14 20:15:44 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0112.html

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.