Bug 20800 - MGA5 - MGA6 upgrade conflicts
Summary: MGA5 - MGA6 upgrade conflicts
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: All Linux
: release_blocker normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-07 23:38 CEST by Frank Griffin
Modified: 2017-06-07 20:53 CEST (History)
4 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
ddebug.log (146.43 KB, application/octet-stream)
2017-05-07 23:42 CEST, Frank Griffin
Details
ddebug.log1 (603.16 KB, application/octet-stream)
2017-05-07 23:43 CEST, Frank Griffin
Details
install.log (703.09 KB, text/plain)
2017-05-07 23:44 CEST, Frank Griffin
Details
install.log1 (644.14 KB, text/plain)
2017-05-07 23:44 CEST, Frank Griffin
Details
report.bug (470.73 KB, application/octet-stream)
2017-05-07 23:45 CEST, Frank Griffin
Details
ddebug.log (146.43 KB, application/x-bzip)
2017-05-14 23:15 CEST, Frank Griffin
Details
install.log (703.09 KB, text/plain)
2017-05-14 23:19 CEST, Frank Griffin
Details
ddebug.log (146.43 KB, application/octet-stream)
2017-05-14 23:33 CEST, Frank Griffin
Details
install.log (703.09 KB, text/plain)
2017-05-14 23:35 CEST, Frank Griffin
Details
ddebug.log (146.43 KB, application/octet-stream)
2017-05-15 18:32 CEST, Frank Griffin
Details
install.log (703.09 KB, text/plain)
2017-05-15 18:33 CEST, Frank Griffin
Details
ddebug.log (147.11 KB, application/octet-stream)
2017-05-16 17:20 CEST, Frank Griffin
Details
install.log (552.00 KB, text/plain)
2017-05-16 17:21 CEST, Frank Griffin
Details
ddebug.log (352.94 KB, application/octet-stream)
2017-05-26 16:33 CEST, Frank Griffin
Details
install.log (372.25 KB, text/plain)
2017-05-26 16:35 CEST, Frank Griffin
Details

Description Frank Griffin 2017-05-07 23:38:11 CEST
Remi requested feedback from MGA5-MGA6 upgrades.  I did one from a fresh install of MGA5 in a VBox VM and an upgrade to MGA6 in the same VM.

There were 65 failed transactions.  There were two sets of logs, ddebug.log/1 and install.log/1 as well as report.bug.xz.  I'll attach them all.

I'll keep the VM disk in case you want anything else.
Comment 1 Frank Griffin 2017-05-07 23:42:29 CEST
Created attachment 9277 [details]
ddebug.log
Comment 2 Frank Griffin 2017-05-07 23:43:18 CEST
Created attachment 9278 [details]
ddebug.log1
Comment 3 Frank Griffin 2017-05-07 23:44:03 CEST
Created attachment 9279 [details]
install.log
Comment 4 Frank Griffin 2017-05-07 23:44:42 CEST
Created attachment 9280 [details]
install.log1
Comment 5 Frank Griffin 2017-05-07 23:45:45 CEST
Created attachment 9281 [details]
report.bug
Comment 6 Marja van Waes 2017-05-09 12:02:10 CEST
Comment on attachment 9278 [details]
ddebug.log1

Thanks, Frank.

report.bug, install.log1 and ddebug.log1 are from the Mga5 install, install.log and ddebug.log are from the upgrade.

I'll obsolete the Mga5 logs.
Comment 7 Marja van Waes 2017-05-09 12:23:12 CEST
Sorry, the logs drive me crazy, I don't know how to handle them.

Assigning to the mageiatools maintainers, even if drakx-installer-stage2 isn't the culprit, because people like Thierry (btw, congrats with your newborn!) will be capable of extracting the needed information from the logs, and tell which packages are to blame.
Comment 8 David Walser 2017-05-14 02:48:33 CEST
The attachment in Comment 3 shows conflicts in some KDE packages (plasma-desktop-handbook and plasma-workspace-handbook with kde-l10n-handbooks-*).  That's the only thing that looks like a legitimate packaging error.  The rest looks like urpmi being silly.
Comment 9 Marja van Waes 2017-05-14 04:57:20 CEST
(In reply to David Walser from comment #8)
> The attachment in Comment 3 shows conflicts in some KDE packages
> (plasma-desktop-handbook and plasma-workspace-handbook with
> kde-l10n-handbooks-*).  That's the only thing that looks like a legitimate
> packaging error.  The rest looks like urpmi being silly.

thx, David.

Re-assigning
Comment 10 Nicolas Lécureuil 2017-05-14 08:10:17 CEST
Please test new plasma-desktop and plasma-workspace
Comment 11 Nicolas Lécureuil 2017-05-14 16:58:08 CEST
Please reopen if still valid with new rpms
Comment 12 Frank Griffin 2017-05-14 23:08:55 CEST
Probably not the same plasma rpms, feel free to reassign...
Comment 13 Nicolas Lécureuil 2017-05-14 23:10:35 CEST
i need debugs infos.
Comment 14 Frank Griffin 2017-05-14 23:15:15 CEST
Created attachment 9297 [details]
ddebug.log
Comment 15 Frank Griffin 2017-05-14 23:19:08 CEST
Created attachment 9298 [details]
install.log

install.log and ddebug.log from current test
Comment 16 Frank Griffin 2017-05-14 23:29:37 CEST
Agggh.  Please disregard.  I attached the logs from the wrong system.  Correcting now...
Comment 17 Frank Griffin 2017-05-14 23:33:59 CEST
Created attachment 9299 [details]
ddebug.log
Comment 18 Frank Griffin 2017-05-14 23:35:01 CEST
Created attachment 9300 [details]
install.log
Comment 19 Nicolas Lécureuil 2017-05-15 00:55:39 CEST
Installation failed:
	file /usr/share/doc/HTML/de/kfontview/index.docbook from install of plasma-desktop-handbook-5.8.6-7.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/de/knetattach/index.docbook from install of plasma-desktop-handbook-5.8.6-7.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/de/plasma-desktop/index.docbook from install of plasma-desktop-handbook-5.8.6-7.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/de/kfontview/index.cache.bz2 from install of plasma-desktop-handbook-5.8.6-7.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/de/knetattach/index.cache.bz2 from install of plasma-desktop-handbook-5.8.6-7.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/de/plasma-desktop/index.cache.bz2 from install of plasma-desktop-handbook-5.8.6-7.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/it/plasma-desktop/index.docbook from install of plasma-desktop-handbook-5.8.6-7.mga6.noarch conflicts with file from package kde-l10n-handbooks-it-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/it/plasma-desktop/index.cache.bz2 from install of plasma-desktop-handbook-5.8.6-7.mga6.noarch conflicts with file from package kde-l10n-handbooks-it-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/de/klipper/index.docbook from install of plasma-workspace-handbook-5.8.6-8.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/de/klipper/index.cache.bz2 from install of plasma-workspace-handbook-5.8.6-8.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch



The fixed packages are: plasma-workspace-handbook-5.8.6-9.mga6.noarch and plasma-desktop-5.8.6-8.mga6



Please reopen if still valid with them.
Comment 20 Frank Griffin 2017-05-15 18:32:22 CEST
Created attachment 9304 [details]
ddebug.log
Comment 21 Frank Griffin 2017-05-15 18:33:28 CEST
Created attachment 9305 [details]
install.log
Comment 22 Frank Griffin 2017-05-15 18:34:50 CEST
Still the same number of conflicts (65).
Comment 23 Frank Griffin 2017-05-15 23:17:55 CEST
I'm redoing the MGA5 VBox install and copying off the .vdi file so that I can rerun this test by doing a dd copy and MGA6 upgrade (which fails fairly soon after starting) instead of waiting for the MGA5 install (which takes several hours).

Is 65 some kind of magic urpmi or install number ?  Could there be thousands of these conflicts and the install quits after finding 65 ?  If so, we could be cycling through these tests for quite awhile.
Comment 24 Charles Edwards 2017-05-15 23:50:58 CEST
The transaction size for urpmi is set 'All' or 50 whichever is less.

If there are 50 or less rpms which need to be installed they will all be done
in 1 transaction.
If there are more than 50 rpms which need to be installed they will be installed
in multiple transactions of 50 until all are installed.

Because of this if there is any issues in Requires|Provides|Conflicts|Obsoletes
Or in the order with which each rpm is installed, it can easily cause the transaction to fail.

It is the same issue you saw Sat. with the Caulron gdb dnf-utils maven updates.
Comment 25 Frank Griffin 2017-05-16 00:22:38 CEST
So what is the path forward on this ?  Should the transaction size in install urpmi be expanded to All ?  Why is it not to begin with ?

This is really starting to get ridiculous.  Initially, I would have to use --split-level=1 --split-length=1 just to force installation of packages which had nothing to do with failing packages but just happened to be bundled into transaction sets that included failing packages for no better reason than they were next up.

Now I have to abandon --auto-select because urpmi can't figure out dependencies 
unless I specify a subset of packages by name ?
Comment 26 Rémi Verschelde 2017-05-16 08:09:17 CEST
You still have the old versions of the packages Nicolas fixed in comment 19:

Installation failed:
	file /usr/share/doc/HTML/de/kfontview/index.docbook from install of plasma-desktop-handbook-5.8.6-7.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch
	file /usr/share/doc/HTML/de/klipper/index.docbook from install of plasma-workspace-handbook-5.8.6-8.mga6.noarch conflicts with file from package kde-l10n-handbooks-de-4.14.3-1.mga5.noarch

So it's expected that it would still fail. If you are upgrading using the DVD, you need to make sure to enable update mirrors to get the latest packages. If using urpmi, check that your mirrors are up-to-date and have the right versions of those packages.
Comment 27 Frank Griffin 2017-05-16 17:20:46 CEST
Created attachment 9308 [details]
ddebug.log
Comment 28 Frank Griffin 2017-05-16 17:21:45 CEST
Created attachment 9309 [details]
install.log
Comment 29 Frank Griffin 2017-05-16 17:26:15 CEST
Looks like I  uploaded the wrong files last time around.  But I checked manually in my cauldron mirror for the packages Nicholas named, and redid the install.  Still getting a failure of 65 packages, but slightly different names.
Comment 30 Frank Griffin 2017-05-18 16:57:46 CEST
I've noticed some plasma updates go by; should I try this again ?
Comment 31 Nicolas Lécureuil 2017-05-26 08:59:49 CEST
Please yes
Comment 32 Frank Griffin 2017-05-26 16:33:53 CEST
Created attachment 9336 [details]
ddebug.log
Comment 33 Frank Griffin 2017-05-26 16:35:00 CEST
Created attachment 9337 [details]
install.log
Comment 34 Frank Griffin 2017-05-26 16:37:21 CEST
Unfortunately, similar result.  This time the number of errors shown was 68.  I have to repurpose this machine for about a week starting this evening, so I won't be able to retest until then.  But the reproducible case is pretty simple (if time-consuming).
Comment 35 Nicolas Lécureuil 2017-05-28 10:33:27 CEST
should be OK now.

Please reopen if still valid for you
Comment 36 Frank Griffin 2017-06-07 20:53:03 CEST
Well done !  I reran the upgrade today, and not a single error.

Note You need to log in before you can comment on or make changes to this bug.