Bug 20743 - Our version of qelectrotech ("QET") is old
Summary: Our version of qelectrotech ("QET") is old
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2017-04-28 11:22 CEST by Morgan Leijström
Modified: 2018-05-20 09:30 CEST (History)
2 users (show)

See Also:
Source RPM: qelectrotech-0.5-1.mga6
CVE:
Status comment:


Attachments

Description Morgan Leijström 2017-04-28 11:22:48 CEST
The new 0.6 currently at RC is vastly improved.
Can it make it into Mageia 6 release?
No other package depends on it.
I compile and use it locally as per https://wiki.mageia.org/en/QElectroTech
Comment 1 Rémi Verschelde 2017-04-28 11:24:37 CEST
Assigning to the register maintainer, daviddavid.

@ Morgan: Since daviddavid is unavailable currently, and you seem to be one of the main users of QET, maybe you'd like to learn the ropes of packaging and become the maintainer for this package?

Assignee: bugsquad => geiger.david68210

Comment 2 Morgan Leijström 2017-04-28 11:29:36 CEST
Thanks for the confidence :) but i am too overloaded to accept.
Comment 3 David GEIGER 2018-02-17 12:45:13 CET
So fixed for Cauldron with QET 0.6 RC4!

I wait now for all the new Qt5 stack be validated in 6/Core/Updates_testing repo to push also QET for mga6.
Comment 4 Morgan Leijström 2018-02-17 15:51:36 CET
Great, thanks  :)
Comment 5 Morgan Leijström 2018-03-08 23:36:02 CET
0.6 final is released https://qelectrotech.org/news.html
Comment 6 David GEIGER 2018-03-09 09:29:38 CET
(In reply to Morgan Leijström from comment #5)
> 0.6 final is released https://qelectrotech.org/news.html

Done!

So now awaiting for the new Qt 5.9.4 stack validated and pushed before pushing QET.
Comment 7 Morgan Leijström 2018-03-09 09:56:46 CET
Great. I will try it on mga6 as soon as i see it there.
Comment 8 Morgan Leijström 2018-03-12 12:06:00 CET
I updated OK to plasma5 Qt et al in testing yesterday.
Now i simply urpmi:ed the QElectroTech package fetched from Cauldron release:
Quick check all OK, will use it in production later this week.  Thanks!
Comment 9 David GEIGER 2018-05-12 06:33:54 CEST
So time to assigning to QA now,


Advisory:
=============================

Our current version 0.5 is now quite old (released on 2015.11.27) and unmaintained upstream.
This updates qelectrotech (QET) to a version which is supported upstream.


Packages in 6/core/updates_testing:
========================
qelectrotech-0.6-1.mga6.i586.rpm
qelectrotech-0.6-1.mga6.x86_64.rpm

Source RPM: 
========================
qelectrotech-0.6-1.mga6.src.rpm

Assignee: geiger.david68210 => qa-bugs

David GEIGER 2018-05-12 06:35:41 CEST

Version: Cauldron => 6
CC: (none) => geiger.david68210

Comment 10 Lewis Smith 2018-05-20 09:30:20 CEST
Testing M6 x64
with Qt5 updates in place.

BEFORE update: qelectrotech-0.5-1.mga6
In Graphics menu. Played with it minimally, quickly out of my depth.

AFTER successful update: qelectrotech-0.6-1.mga6
It has been re-organised, but behaves similarly. The few things I tried worked OK.
With Morgan's comment 8 OK, am OKing & validating this update.

Keywords: (none) => advisory, validated_update
Whiteboard: (none) => MGA6-64-OK
CC: (none) => sysadmin-bugs


Note You need to log in before you can comment on or make changes to this bug.