Bug 20713 - Backport Candidate: new version of java-1.8.0-openjfx
Summary: Backport Candidate: new version of java-1.8.0-openjfx
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Backports (show other bugs)
Version: 5
Hardware: All Linux
Priority: Low enhancement
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: has_procedure mga5-32-ok mga5-64-ok
Keywords: validated_backport
Depends on:
Blocks:
 
Reported: 2017-04-21 12:52 CEST by Nicolas Salguero
Modified: 2017-07-07 11:36 CEST (History)
3 users (show)

See Also:
Source RPM: java-1.8.0-openjfx
CVE:
Status comment:


Attachments

Description Nicolas Salguero 2017-04-21 12:52:36 CEST
Hi,

There is a new version of openjfx which come in sync with openjdk.

Best regards,

Nico.
Comment 1 Nicolas Salguero 2017-04-21 12:55:14 CEST
Packages in core/backports_testing:
========================
i586:
java-1.8.0-openjfx-1.8.0.131-1.b11.1.mga5.i586.rpm

x86_64:
java-1.8.0-openjfx-1.8.0.131-1.b11.1.mga5.x86_64.rpm

Source RPMs:
java-1.8.0-openjfx-1.8.0.131-1.b11.1.mga5.src.rpm

The test procedure is in bug 18120, comment 13.

Source RPM: (none) => java-1.8.0-openjfx
Assignee: bugsquad => qa-bugs
Status: NEW => ASSIGNED
Whiteboard: (none) => has_procedure
Priority: Normal => Low

Comment 2 Nicolas Salguero 2017-04-21 12:57:34 CEST
There is a new test procedure in bug 20220, comment 3.
Comment 3 Brian Rockwell 2017-06-15 18:47:17 CEST
I installed the latest version for i586.

$ uname -a
Linux localhost.localdomain 4.4.68-desktop586-1.mga5 #1 SMP Sun May 14 17:55:26 UTC 2017 i686 i686 i686 GNU/Linux
[brian@localhost ~]$ javac helloworld.java
[brian@localhost ~]$ java helloworld
Hello World!

Seems to be working as designed.

CC: (none) => brtians1
Whiteboard: has_procedure => has_procedure mga5-32-ok

Comment 4 Brian Rockwell 2017-06-19 03:50:03 CEST
Please note you also need openjdk installed to work properly.

brian@localhost java]$ uname -a
Linux localhost 4.4.68-desktop-1.mga5 #1 SMP Sun May 14 17:56:12 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[brian@localhost java]$ javac helloworld.java
[brian@localhost java]$ java -cp . helloworld
Hello World!
[brian@localhost java]$

[brian@localhost java]$ java -version
openjdk version "1.8.0_131"
OpenJDK Runtime Environment (build 1.8.0_131-b12)
OpenJDK 64-Bit Server VM (build 25.131-b12, mixed mode)

Whiteboard: has_procedure mga5-32-ok => has_procedure mga5-32-ok mga5-64-ok

Lewis Smith 2017-06-29 20:59:32 CEST

Keywords: (none) => validated_backport
CC: (none) => lewyssmith

Comment 5 Thomas Backlund 2017-07-07 11:36:06 CEST
 Moved to backports

CC: (none) => tmb
Resolution: (none) => FIXED
Status: ASSIGNED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.