Bug 20636 - Installer breaks settings in existing home
Summary: Installer breaks settings in existing home
Status: RESOLVED DUPLICATE of bug 6022
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal critical
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
URL:
Whiteboard:
Keywords: 6sta2, NEEDINFO
Depends on:
Blocks:
 
Reported: 2017-04-05 14:22 CEST by Nikita Krupenko
Modified: 2017-04-06 09:14 CEST (History)
5 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Nikita Krupenko 2017-04-05 14:22:07 CEST
Description of problem:
I installed MGA6 sta2 and used existing home. After install finished and system rebooted, a dialog for root password and new user appeared. I created the same user, that I have in the existing /home.

After that installer hanged. In the log I seen, that installer executed a perl script, that copied files from /home/live to my old home. I rebooted the system.

After that I discovered, that some of my configs has been overwritten. For example, all virtual machines in VirtualBox disappeared. The most serious issue is akonadi: I had several mailboxes configured in KMail and now they are broken - neither I cannot sync them nor I can delete them. Seems I need to purge the akonadi configs and data and configure all again.
Plasma settings are too overwritten, but it's not hard to reconfigure back.
May be some else application's data broken too, but I haven't found yet.

Thanks to the IMAP, I haven't lose my mail, but this easily could lead to data loss.

Version-Release number of selected component (if applicable): MGA6 sta2


Steps to Reproduce:
1. Install the system using existing home.
2. After reboot create the user with the same name as in the existing home.
Comment 1 Marja Van Waes 2017-04-05 14:46:43 CEST
What is the output of 

   ls -al /home


Please attach journal.txt that is the result of running, as root,

   journalctl -ab2 > journal.txt

Keywords: (none) => NEEDINFO
CC: (none) => isobuild, kde, marja11

Marja Van Waes 2017-04-05 14:46:58 CEST

Keywords: (none) => 6sta2

Comment 2 Nikita Krupenko 2017-04-05 14:56:03 CEST
total 20
drwxr-xr-x  4 root  root   4096 Mar  1 00:51 ./
drwxr-xr-x  1 root  root    230 Jan  2 03:36 ../
drwxr-x--- 18 nekit nekit  4096 Apr  2 06:57 live/
drwxr-xr-x 62 nekit nekit 12288 Apr  5 15:23 nekit/

I cannot give you the logs of the second boot from installed sta2, because I already deleted that installation and returned back a snapshot from the previous install.
Comment 3 Nikita Krupenko 2017-04-05 15:20:38 CEST
I'll try to reproduce on a virtual machine.
Comment 4 Marja Van Waes 2017-04-06 01:10:34 CEST
(In reply to Nikita Krupenko from comment #3)
> I'll try to reproduce on a virtual machine.

Well, actually, this is a duplicate of bug 6022.

I updated the wiki to be more explicit

https://wiki.mageia.org/mw-en/index.php?title=Installation_Media&action=historysubmit&diff=34919&oldid=34918

*** This bug has been marked as a duplicate of bug 6022 ***

Status: NEW => RESOLVED
Resolution: (none) => DUPLICATE

Comment 5 Martin Whitaker 2017-04-06 01:23:32 CEST
Unfortunately most people only read the Wiki *after* something's gone wrong :-(

I do think we should fix this.

CC: (none) => mageia

Comment 6 Nicolas Lécureuil 2017-04-06 09:14:12 CEST
or don't read the wiki at all :)

CC: (none) => mageia


Note You need to log in before you can comment on or make changes to this bug.