Bug 20542 - Firefox crashes on start after update to version 45.8 / ICU 58.2
Summary: Firefox crashes on start after update to version 45.8 / ICU 58.2
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: release_blocker critical
Target Milestone: Mageia 6
Assignee: All Packagers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-20 19:20 CET by Nikita Krupenko
Modified: 2017-03-21 14:39 CET (History)
6 users (show)

See Also:
Source RPM: firefox-45.8.0-2.mga6.src.rpm
CVE:
Status comment:


Attachments
Backtrace of the crash (7.29 KB, text/plain)
2017-03-20 19:21 CET, Nikita Krupenko
Details
Terminal output crash when attempting to compose email (2.77 KB, text/plain)
2017-03-20 19:40 CET, Roy Reese
Details

Description Nikita Krupenko 2017-03-20 19:20:29 CET
Description of problem:
Previous version 45.7.0-3.mga6 works fine

Version-Release number of selected component (if applicable): 45.8.0-1.mga6


How reproducible: Always
Comment 1 Nikita Krupenko 2017-03-20 19:21:18 CET
Created attachment 9125 [details]
Backtrace of the crash
Frédéric Buclin 2017-03-20 19:22:09 CET

Priority: Normal => High
Target Milestone: --- => Mageia 6
Severity: normal => critical

Comment 2 Rémi Verschelde 2017-03-20 19:28:26 CET
Same issue with firefox-45.8.0-2.mga6. I don't think it's related to the upgrade from 45.7.0 to 45.8.0, but to the upgrade of the system ICU lib to 58.2.

Priority: High => release_blocker
Source RPM: firefox-45.8.0-1.mga6.src.rpm => firefox-45.8.0-2.mga6.src.rpm

Comment 3 Jüri Ivask 2017-03-20 19:29:26 CET
Confirmed. So does Thunderbird...

Priority: release_blocker => High
CC: (none) => jyri2000
Source RPM: firefox-45.8.0-2.mga6.src.rpm => firefox-45.8.0-1.mga6.src.rpm

Rémi Verschelde 2017-03-20 19:36:04 CET

Priority: High => release_blocker
Source RPM: firefox-45.8.0-1.mga6.src.rpm => firefox-45.8.0-2.mga6.src.rpm

Rémi Verschelde 2017-03-20 19:38:35 CET

Summary: Firefox crashes on start after update to version 45.8 => Firefox crashes on start after update to version 45.8 / ICU 58.2

Comment 4 Roy Reese 2017-03-20 19:39:48 CET
Upgrading from build 1 to build 2 now produces a crash when I try to write a new message or respond to a message using the Web UI of www.gmx.es. Terminal output attached.

CC: (none) => aguador

Comment 5 Roy Reese 2017-03-20 19:40:54 CET
Created attachment 9126 [details]
Terminal output crash when attempting to compose email
Comment 6 Rémi Verschelde 2017-03-20 20:10:35 CET
@ Mike, I guess that means we're ready when you are to push FF 52.0.1 ;)

My only guess so far would be that FF 45 is not really compatible with ICU 58.2, so our best shot is to proceed with the planned upgrade.

CC: (none) => mrambo

Comment 7 Rémi Verschelde 2017-03-20 21:34:30 CET
(In reply to Nikita Krupenko from comment #0) 
> Version-Release number of selected component (if applicable): 45.8.0-1.mga6

Just to be sure, are you 100% sure the bug started with 45.8.0-1.mga6? The timing of your report, and my current clue, would hint that the bug would have started only with 45.8.0-2.mga6 (rebuild against icu 58.2).

45.8.0-1.mga6 was actually built several days ago. The update from today is that -2.mga6.
Comment 8 Jüri Ivask 2017-03-20 21:55:22 CET
The bug started with upgrade to 45.8.0-2.mga6. Downgrading firefox to 45.8.0-1.mga6 makes it to work again here.
Comment 9 Nikita Krupenko 2017-03-20 22:04:12 CET
(In reply to Rémi Verschelde from comment #7)
> (In reply to Nikita Krupenko from comment #0) 
> > Version-Release number of selected component (if applicable): 45.8.0-1.mga6
> 
> Just to be sure, are you 100% sure the bug started with 45.8.0-1.mga6? The
> timing of your report, and my current clue, would hint that the bug would
> have started only with 45.8.0-2.mga6 (rebuild against icu 58.2).
> 
> 45.8.0-1.mga6 was actually built several days ago. The update from today is
> that -2.mga6.

Yes, I'm sure as I updated it yesterday and it starts to crash, package version 45.8.0-2.mga6 released only today. I haven't tried 45.8.0-2.mga6 yet.
Comment 10 Nikita Krupenko 2017-03-20 22:08:06 CET
I also add, that now I have firefox 45.7.0-3.mga6 with all other updates installed and it works fine.
Comment 11 Marja van Waes 2017-03-20 22:20:06 CET
Assigning to all packagers collectively, since there is no registered maintainer for this package.

CC: (none) => marja11
Assignee: bugsquad => pkg-bugs

Comment 12 Thomas Andrews 2017-03-20 22:37:27 CET
(In reply to Jüri Ivask from comment #3)
> Confirmed. So does Thunderbird...

I'm not seeing Firefox 45.8.0-2 crash (I'm using it now), but after today's round of updates Thunderbird 45.7.1-2 crashes any time I attempt to bring up the composition window. Write, Reply, Reply list, Reply All, Followup all crash Thunderbird when I click on them. If I don't attempt to compose a message, it remains stable. This is happening on two very different sets of hardware.

If this is the wrong bug for this, please let me know and I will file a new one.

CC: (none) => andrewsfarm

Comment 13 Rémi Verschelde 2017-03-20 23:28:58 CET
I've sent firefox-45.8.0-3.mga6 to the buildsystem, which builds against the bundled icu code. (@ Mike: will need to revert that for 52.0.1 of course, see http://svnweb.mageia.org/packages?view=revision&revision=1093834).

Please test it once it reaches your mirror, it should hopefully fix the crash.
Comment 14 JanKusanagi 2017-03-21 01:07:18 CET
No problems so far with firefox-45.8.0-3 ;)
With -2 the crashes happened almost immediately.

Thanks!

CC: (none) => jan-bugs

Comment 15 Nikita Krupenko 2017-03-21 04:40:49 CET
Confirm, 45.8.0-3 works without crashes.
Comment 16 Roy Reese 2017-03-21 06:01:55 CET
Confirm that firefox 45-8-0-3 solved my crash problem as well.
Comment 17 Rémi Verschelde 2017-03-21 06:41:34 CET
Great, marking as fixed then.

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 18 Rémi Verschelde 2017-03-21 07:22:21 CET
(In reply to Thomas Andrews from comment #12)
> 
> I'm not seeing Firefox 45.8.0-2 crash (I'm using it now), but after today's
> round of updates Thunderbird 45.7.1-2 crashes any time I attempt to bring up
> the composition window. Write, Reply, Reply list, Reply All, Followup all
> crash Thunderbird when I click on them. If I don't attempt to compose a
> message, it remains stable. This is happening on two very different sets of
> hardware.

You should be having thunderbird-45.8.0-1, but I expect it would be problematic the same way as firefox is. I've now submitted thunderbird-45.8.0-2 which builds against its bundled ICU library, which should fix the crashes some are experiencing.
Comment 19 Jüri Ivask 2017-03-21 08:47:59 CET
Thanks, now also thunderbird (thunderbird-45.8.0-2) works OK again.
Comment 20 Thomas Andrews 2017-03-21 14:39:01 CET
Confirmed, I can now compose messages with Thunderbird again. Thanks. Using Gmail's web interface was very annoying.

Note You need to log in before you can comment on or make changes to this bug.