Bug 20426 - Skrooge startup tip window hidden behind main window
Summary: Skrooge startup tip window hidden behind main window
Status: RESOLVED WONTFIX
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal minor
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL:
Whiteboard:
Keywords: IN_ERRATA6, UPSTREAM
Depends on:
Blocks:
 
Reported: 2017-03-08 19:46 CET by Lewis Smith
Modified: 2017-07-13 14:56 CEST (History)
1 user (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Lewis Smith 2017-03-08 19:46:49 CET
Description of problem:
When Skrooge starts, by default it pops up a 'tip of the day' window. Under 3 desktops, this is hidden completely *underneath* the main window: Cinnamon, Gnome, Mate. Under 2 others, it is underneath the main window but not entirely hidden, so you know it is there: LXDE, XFCE. Only under Plasma is it correctly on top of the main application window.

Version-Release number of selected component (if applicable):
M6_STA2 updated to 8 March 2017.

How reproducible:
Just launch Skrooge.
Lewis Smith 2017-03-08 19:55:38 CET

Keywords: (none) => 6sta2

Marja Van Waes 2017-03-09 16:53:00 CET

CC: (none) => marja11
Assignee: bugsquad => kde

Comment 1 Lewis Smith 2017-04-10 20:12:13 CEST
Classic64 RC 7 April all desktops

The problem persists. It is undeniable that under Plasma, the startup tip-of-the-day window is on top of the main window; for all other desktops, it is underneath it. The default Skrooge window is full-screen; if you reduce that, you will probably see the TOTD window. Skrooge remembers its window size & position when re-launched, so once you see the TOTD window, you should do so next time (if you want it).
Comment 2 Rémi Verschelde 2017-04-11 05:43:06 CEST
I'd suggest to open a bug report upstream against skrooge: https://bugs.kde.org/enter_bug.cgi?product=skrooge

I don't think there is anything Mageia-specific that could induce this behaviour.
Rémi Verschelde 2017-04-11 05:43:17 CEST

Keywords: (none) => UPSTREAM

Comment 3 Lewis Smith 2017-05-08 21:33:09 CEST
Still true RC Classic ISO dated today. (XFCE)
RE Comment 2, I shall do that once confirmed for other desktops. Then close this bug.
Comment 4 Lewis Smith 2017-07-10 21:35:08 CEST
Confirmed as per Comment 0 installed from release Mageia 6 Classic ISO.
Only under Plasma does the 'tip of the day' window open unambiguously on top of the main Skrooge window; under all other desktops, it is underneath, and it is a matter of luck whether you see it or not.

I need to create a KDE bugs account to move this upstream, and am doing so now.
Closing as 'wontfix' since this is for upstream & is already marked as such.

Status: NEW => RESOLVED
Resolution: (none) => WONTFIX

Lewis Smith 2017-07-13 14:56:20 CEST

Keywords: 6sta2 => IN_ERRATA6


Note You need to log in before you can comment on or make changes to this bug.