Bug 20413 - Kalarm & Ktorrent under XFCE start with the top of the window hidden under the top taskbar
Summary: Kalarm & Ktorrent under XFCE start with the top of the window hidden under th...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal enhancement
Target Milestone: ---
Assignee: Jani Välimaa
QA Contact:
URL:
Whiteboard:
Keywords: IN_ERRATA6
Depends on:
Blocks:
 
Reported: 2017-03-07 21:46 CET by Lewis Smith
Modified: 2019-04-16 20:57 CEST (History)
2 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
Xfce screenshot 640x480 (83.64 KB, image/png)
2017-03-08 17:58 CET, Jani Välimaa
Details
Xfce screenshot 1440x900 (169.72 KB, image/png)
2017-03-08 18:02 CET, Jani Välimaa
Details
ktorrent behind top panel in XFCE (101.62 KB, image/png)
2017-03-08 21:27 CET, Marja Van Waes
Details
Showing problem with Kalarm (60.18 KB, image/png)
2017-03-08 21:44 CET, Lewis Smith
Details
Showing the problem with Ktorrent (66.93 KB, image/png)
2017-03-08 22:03 CET, Lewis Smith
Details

Description Lewis Smith 2017-03-07 21:46:57 CET
Description of problem:
Kalarm & Ktorrent under XFCE start with the top of the window hidden under the top taskbar. This makes it impossible to grab the window title bar to move it directly, or right-click to move it. Nor can you see the toolbar fully, or menu bar.
You *can* pull the window free with Alt+mouse, but you have to know that! And it depends on that key combination not being assigned otherwise (esp for Gimp).

How reproducible:
Just start those applications under XFCE.
Lewis Smith 2017-03-07 21:48:40 CET

Keywords: (none) => 6sta2

Comment 1 Marja Van Waes 2017-03-08 09:35:57 CET
@ wally

Not sure it's a XFCE problem... is it?

Assignee: bugsquad => jani.valimaa
CC: (none) => kde, marja11

Comment 2 Lewis Smith 2017-03-08 12:33:06 CET
Clarification.
Kalarm & Ktorrent both start ruthlessly 'top left' of the desktop.
Cinnamon, LXDE, Plasma only have a bottom taskbar; so no problem.
Gnome has just a top taskbar, but these programs start tight *underneath* it, the window complete; so no problem.
Mate has both top & bottom taskbars, but again the program windows are complete just *underneath* the top one; no problem.
XFCE alone, with both top & bottom taskbars, has the problem: the 2 program window tops are partially hidden under the top taskbar.
Comment 3 Jani Välimaa 2017-03-08 16:22:56 CET
I can't reproduce this with my Xfce machine. Ktorrent starts nicely below the top panel bar for new user.

I'll test with fresh VM install later.
Comment 4 Jani Välimaa 2017-03-08 17:58:39 CET
Created attachment 9045 [details]
Xfce screenshot 640x480

Can't reproduce with a fresh Xfce install in VBox either. Ktorrent window is below top panel, even with 640x480 resolution.
Jani Välimaa 2017-03-08 18:00:37 CET

Attachment 9045 mime type: application/octet-stream => image/png
Attachment 9045 filename: Screenshot_640x480png => Screenshot_640x480.png

Comment 5 Jani Välimaa 2017-03-08 18:02:01 CET
Created attachment 9046 [details]
Xfce screenshot 1440x900

Same with bigger resolution 1440x900.
Comment 6 Marja Van Waes 2017-03-08 21:27:14 CET
Created attachment 9048 [details]
ktorrent behind top panel in XFCE

I confirm what Lewis saw, see attachment.

This cauldron dates from october last year, and was last updated 4 hours ago, with the Copr repo for Xfce4 enabled.
Comment 7 Lewis Smith 2017-03-08 21:44:20 CET
Created attachment 9049 [details]
Showing problem with Kalarm

Kalarm: more info
When launched for the first time, the problem happens - illustrated.
If you close the window (Ctrl/Q, Alt/F4), the program remains in systray. If you 'restore' it from that icon menu, or re-launch Kalarm from the main menu Tools, the application window re-appears *correctly* under the top taskbar.
OTOH If you kill the first window *and* the systray icon, and re-launch from the Tools menu, the problem shows.

You may want to close this as too trivial. I at least cannot say intermittent.
Comment 8 Lewis Smith 2017-03-08 22:03:55 CET
Created attachment 9050 [details]
Showing the problem with Ktorrent

Ktorrent: more info

When launched for the first time, the problem happens - illustrated.
If you close the window (Alt/F4), the program remains in systray.
[Comment 7 error: Ctrl/Q kills the entire program, window & systray; Alt/F4 kills the window, leaves the program in systray].
If with the systray icon present you 'restore' it from that, or re-launch Ktorrent from the main menu Tools, the application window re-appears *correctly* under the top taskbar. As for Kalarm.
OTOH If you kill the first window *and* the systray icon, and re-launch from the Tools menu, the problem shows - mostly!
I have found while playing that sometimes, nothing in systray, re-launching the program from the Tools menu *correctly* locates the application window... This seems to depend on how soon you do it, or how often you have done it. The more often, the more correct.

I could not achieve this variation with Kalarm.

You may want to close this as too trivial.
Comment 9 Lewis Smith 2017-03-08 22:08:08 CET
In case it matters: AMD/ATI/Radeon HD7310 graphics, supposed to be proprietary driver but I cannot see it; 1920x1080 monitor.
Comment 10 Lewis Smith 2017-03-13 20:10:26 CET
Trying this problem on an installation of the new XFCE Live ISO, updated to now, to which I added Kalarm & Ktorrent (+ >140 libraries...)
The problem does NOT show, suggesting that it is related to the Classic installer with lots of desktops. I will go back to that, update it, and see what happens.
Comment 11 Lewis Smith 2017-03-13 21:02:14 CET
x64 STA2 Classic install all 6  desktops, updated to now.
Kalarm: still show the problem as per Comment 7.
Ktorrent: No longer shows the problem. Its window opens correctly 'from cold' just *underneath*  the top XFCE taskbar. Consistently.
Comment 12 Lewis Smith 2017-04-10 19:54:20 CEST
Classic64 RC 7 April

Despite comment 11, this problem remains as described for both KAlarm & Ktorrent.
Comment 13 Lewis Smith 2017-05-08 21:27:22 CEST
Still true RC Classic ISO dated today.
Lewis Smith 2017-07-13 14:53:44 CEST

Keywords: 6sta2 => IN_ERRATA6

Comment 14 Lewis Smith 2019-04-16 20:57:58 CEST
Mageia7 beta3 real x64 hardware, XFCE desktop from SDDM.
Glad to say that both programs now start correctly. Perhaps this has been true for ages... Closing the bug fixed.

Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.