Bug 20242 - KDE apps refuse to print after updates in February or January
Summary: KDE apps refuse to print after updates in February or January
Status: RESOLVED OLD
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: All Linux
Priority: Normal critical
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 18367
  Show dependency treegraph
 
Reported: 2017-02-05 04:36 CET by Thomas Andrews
Modified: 2018-08-23 09:45 CEST (History)
3 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
Journal from a session where a print was attempted (102.49 KB, text/plain)
2017-02-05 04:48 CET, Thomas Andrews
Details

Description Thomas Andrews 2017-02-05 04:36:51 CET
Description of problem:

After installing updates from within a day or two of February 1, 2017, Okular and Gwenview refuse to print at all. The programs appear to function normally until "Print" is selected from the "File" menu, at which point they become unresponsive, as if waiting for something. Eventually the programs have to be terminated forcibly.

Affected hardware: ASRock motherboard, Athlon X2 7750 processor, nvidia Geforce 9800GT graphics, HP Deskjet 5650 printer via usb, HP Officejet 6110 via usb. I do not currently have any other printers attached to any other systems, so I don't know if other hardware would be affected.

At first I thought the update to kernel 4.4.45 might be at fault, as I was testing it at the time the failure was first noticed. The system had been working for several days with that kernel, and then just stopped working after some updates. (Not sure which ones now.)

I have re-installed Mageia 5.1 on this hardware - twice - and after getting all updates and installing the printers the problem is there. On the first re-install I installed all the apps I had installed before the failure before trying to print. On the second attempt I left out some that I thought "might" have been the culprits, with the same result.

How reproducible: Always


Steps to Reproduce:
1. Install Mageia 5
2. Get updates
3. Install printer
4. Attempt to print from either Okular or Gwenview
Comment 1 Thomas Andrews 2017-02-05 04:48:06 CET
Created attachment 8928 [details]
Journal from a session where a print was attempted

The journal is from a session where I logged in, loaded a pdf into Okular, and attempted to print it.

The error would have shown near the end of the file, as I captured the journal right after the failure. At what I believe is the right point I see errors involving pulseaudio, dbus, and hp-systray, but I have no idea what this might mean. If I recall correctly, process 2585 (pulseaudio) was the one in the notice I received when I forcibly closed Okular. However, I'm not SURE about that.
Comment 2 Thomas Andrews 2017-02-05 04:53:36 CET
(In reply to Thomas Andrews from comment #0)

> I have re-installed Mageia 5.1 on this hardware - twice - and after getting
> all updates and installing the printers the problem is there. On the first
> re-install I installed all the apps I had installed before the failure
> before trying to print. On the second attempt I left out some that I thought
> "might" have been the culprits, with the same result.
> 
I did not make it clear in this paragraph that I did NOT install the 4.4.45 kernel in these sessions, and Okular still refused to print.

Also, I failed to mention that the Classical installer always installs the server kernel on this hardware, because the BIOS erroneously reports that ECC memory is installed. I do not know if the desktop kernel would show the same problem.
Comment 3 James Kerr 2017-02-05 12:53:25 CET
$ uname -r
4.4.45-server-1.mga5

I cannot reproduce this with an HP Envy 4502 and hplip-3.14.6-8.1. Printing works normally from okular and gwenview (except for bug #16330 and bug #16673)

Can you print from a non KDE app such as evince or LO?

CC: (none) => jim

Comment 4 Thomas Andrews 2017-02-05 15:00:11 CET
I can print from evince, but - separate issue - it won't let me print double-sided. One printer has a duplexer, which I use often for double-sided printing.

I am attempting to print tax forms, and I need them to be double-sided. And I need them printed by the end of February.

I have an install of Mageia 6 on this computer, and I will try to print with it. There is yet another issue there in that it will not let me be sure I'm printing in gray scale using only my black cartridge (filed in another bug) but if it prints I can get along with that.

Failing that, I guess the next step would be transferring the printer(s) to another computer.
Comment 5 Thomas Andrews 2017-02-05 19:40:59 CET
I was able to print from Okular in Mageia 6, same hardware.. At first the "grayscale" setting was ignored, but after adding my user to the "lp" group things seemed to work fine.

I have a couple of other ideas about what to try. It's entirely possible that it's only my stuff that's affected. Maybe I'll find it myself.
Comment 6 Marja Van Waes 2017-02-08 10:18:03 CET

Why does it first try to add a cups-Hewlett-Packard-OfficeJet-6100-Series device, a different one than you have?


Feb 05 02:33:06 localhost colord[2053]: Device added: cups-Hewlett-Packard-OfficeJet-6100-Series

I'm wondering whether that somehow blocks the following happening nicely:

Feb 05 02:33:06 localhost colord[2053]: Device added: cups-hp-deskjet-5600

and whether that then led to:

Feb 05 02:33:06 localhost udev-configure-printer[862]: MissingDriver()
Feb 05 02:33:06 localhost udev-configure-printer[862]: FAIL HERE

@ KDE maintainers

Do KDE applications have an own way of detecting & installing printers, outside what system-config-printer does or did?

@ Thomas

Can you run 

    rpm -qa --last | head -n50

(increase "50" if needed) 

to find all updates from the last time you successfully printed from Okular or Gwenview in Mageia 5, until printing became impossible?

Please attach that list.

Blocks: (none) => 18367
CC: (none) => kde, marja11

Comment 7 Thomas Andrews 2017-02-08 15:33:31 CET
(In reply to Marja van Waes from comment #6)
> 
> Why does it first try to add a cups-Hewlett-Packard-OfficeJet-6100-Series
> device, a different one than you have?
> 
> 
> Feb 05 02:33:06 localhost colord[2053]: Device added:
> cups-Hewlett-Packard-OfficeJet-6100-Series
> 
> I'm wondering whether that somehow blocks the following happening nicely:
> 
> Feb 05 02:33:06 localhost colord[2053]: Device added: cups-hp-deskjet-5600
> 
> and whether that then led to:
> 
> Feb 05 02:33:06 localhost udev-configure-printer[862]: MissingDriver()
> Feb 05 02:33:06 localhost udev-configure-printer[862]: FAIL HERE
> 
I have two printers on this machine, a Deskjet 5650 and an Officejet 6100. Both were installed through MCC. The Officejet doubles as my scanner/copier. I did not install the fax drivers for the Officejet, separately detected by system-config-printer, as I never use it and have no desire to. At the time of my first failure I also had cups-pdf installed, but did not on subsequent trials.

Speculation: Possible that I'm affected because I have TWO HP printers installed? It's always worked OK before.

> @ KDE maintainers
> 
> Do KDE applications have an own way of detecting & installing printers,
> outside what system-config-printer does or did?
> 
Personally wondering if this could be somehow related to Bug #16330.

> @ Thomas
> 
> Can you run 
> 
>     rpm -qa --last | head -n50
> 
> (increase "50" if needed) 
> 
> to find all updates from the last time you successfully printed from Okular
> or Gwenview in Mageia 5, until printing became impossible?
> 
> Please attach that list.

I cannot, at least not at this time. This was my production install, and this bug was severely hurting my productivity at this time of year. As Mageia 6 doesn't seem to be affected, I have replaced Mageia 5 with Mageia 6 as my production install. (Liking it very much, BTW.)

I have some new hardware ordered, due to be delivered tomorrow, that should allow me to try this again on another hard drive, assuming it works as promised. My intention is to install Mageia 5.1 as I usually do, install the printers and see if they work before getting updates, then start the laborious task of installing updates group by group, starting with those I know aren't at fault because the changelogs indicate they were earlier, and keep checking until failure.
Comment 8 Thomas Andrews 2017-02-11 05:31:50 CET
I don't know whether to be disappointed, or relieved. Definitely feeling perplexed.

I bought a hot plug drive bay adapter for my desktop and used it to install Mageia 5 from DVD, including the nvidia340 driver, on an old 80GB hard drive. I installed the two printers using software from the DVD, and checked things out. Print was working.

Using MCC, I disabled the DVD repositories and set up my usual US kernel.org mirror. I did not activate the tainted repositories at that time. I then installed updates, a few at a time, checking the print function between each group. I rebooted after installing the nvidia340 update group, and again after installing the server kernel update group, but did not reboot after installing the others between print tests. At the end, print was still working.

I activated the 64 and 32 bit tainted repositories, and again got all the updates. At the end, print still functioned. That's where I stopped.

This is not my usual procedure when installing, so maybe that made a difference - though I don't see how it should. Usually, I install from usb, set up a mirror, activate tainted, and get any updates that are waiting all in one batch. At that point I often install additional apps, like thunderbird, Then I'll install the printers using software from the online repositories.

I tried maybe four re-installs before filing this bug. On the first I tried not installing Google Earth (and associated dependencies) and Virtualbox. Print failed. I tried installing fewer extra apps yet, and print still failed. I tried backing up /home data including .mozilla, .thunderbird, and .virtualbox, formatting both / and /home during the install, restoring the data before getting updates and setting up the printer, as well as not installing any extra apps but Thunderbird, and print still failed.

And then I did this install, installing the printer from the DVD rather than the online repositories, and THEN going after the updates. And print works. Sigh. I'm going to bed.
Comment 9 Marja Van Waes 2017-02-11 14:14:17 CET
Thanks for all your tests, Thomas!

I'm glad it works fine, now, but share your frustration about not being able to reproduce the issue and at the same time find the culprit, even if you reproduced the issue several times before filing this bug report.

I agree that something in your old install procedure may have triggered this bug, it is better left open until the old procedure works fine, too.
Comment 10 Thomas Andrews 2017-03-13 16:15:34 CET
I have seen this once again, under slightly different circumstances.

I had put a new 32-bit 5.1 install on different hardware, (Asus-made Fujitsu D1711 motherboard, Sempron 3100+ processor, Geforce 6200 video card, BCM4318 wifi) and I was using it to check out another issue with Okular. I needed a printer to do it, but had no hardware to conveniently attach, so I installed cups-pdf and used system-config-printer to install that. 

Okular still worked to call the printer. The issue I was checking out was a non-issue with things set up that way. I needed a real HP printer to fully check it out. So I attached one, the Deskjet 5650 (with duplexer), and once again checked before installing it, and Okular still worked OK.

Then I installed the printer, through MCC, while Okular was still running. No new software was installed during the process, task-printing-hp having been installed at the same time as system-config-printer. I chose hplip, rather than "USB" when the printer was detected.

I switched over to Okular without even closing MCC, and Okular was broken. Deleting the printer I had just installed did NOT restore it to operation.

So from where I sit, it looks like the problem rests specifically with hplip's interaction with the Deskjet 5650, or maybe with a printer with a this duplexer installed. That could be why no one else is seeing it.

Hardware: x86_64 => All

Comment 11 Marja Van Waes 2017-03-22 15:40:43 CET
(In reply to Thomas Andrews from comment #10)

> 
> Then I installed the printer, through MCC, while Okular was still running.
> No new software was installed during the process, task-printing-hp having
> been installed at the same time as system-config-printer. I chose hplip,
> rather than "USB" when the printer was detected.
> 
> I switched over to Okular without even closing MCC, and Okular was broken.
> Deleting the printer I had just installed did NOT restore it to operation.
> 

And restarting Okular instead of deleting the printer?
Comment 12 Thomas Andrews 2017-03-23 16:25:51 CET
I'm sorry. By the time I saw this, I had shut down the computer and had not been back to it for several days. It's old, has been balky at using Mageia 6 because of the nvidia card, and I don't use it very much any more.

I tried it again this morning, after installing the proposed server kernel update to 4.4.55. Today, with the only listed printer being cups-pdf, the print function for Okular is again working.

I will try to find the time to connect the HP Deskjet 5650 printer to this machine again later today, and try different things.
Comment 13 Marja Van Waes 2017-04-19 10:21:46 CEST
(In reply to Thomas Andrews from comment #12)

> 
> I will try to find the time to connect the HP Deskjet 5650 printer to this
> machine again later today, and try different things.

Is it OK now, so that this report can be closed?
Comment 14 Thomas Andrews 2017-04-19 18:23:56 CEST
(In reply to Marja van Waes from comment #13)
> (In reply to Thomas Andrews from comment #12)
> 
> 
> Is it OK now, so that this report can be closed?

Unfortunately, no. I still see the problem.

The motherboard from Comments 12 and 10 gave up on me, apparently with a corrupted BIOS. I have replaced it with a much newer motherboard/processor, but by the time I got that up and running and checked out this problem, Bugzilla was offline for upgrades. I confess I forgot about the bug until I saw the email for this message, because I use Mageia 6 almost exclusively now.

Even on this new machine, everything works OK with no printer installed, and with the simulated cups-pdf printer.  But, as soon as I install either of my real printers, a Deskjet 5650 or the Officejet 6100, the bug shows up. Uninstall the real printers, disconnect them entirely, and it still doesn't work.

For months I've seen some printing packages in the testing repositories - system-config-printer, task-printing-hp, task-printing-server, etc. I don't believe they've been released to QA yet, so they must still be under development. Is it possible that those updates could take care of my problem? Or would installing them just add to it?
Comment 15 Marja Van Waes 2017-04-20 10:03:43 CEST
(In reply to Thomas Andrews from comment #14)

> 
> For months I've seen some printing packages in the testing repositories -
> system-config-printer, task-printing-hp, task-printing-server, etc. I don't
> believe they've been released to QA yet, so they must still be under
> development. Is it possible that those updates could take care of my
> problem? Or would installing them just add to it?


Please try, you can always downgrade them again if they make things worse.

It was asked in several bug reports to test those packages.



Anyway, assigning to KDE team, because I can't think of anything better (this only occurring with 2 KDE applications).

If the packages in updates_testing solve the issue, then we'll reassign this bug.

Assignee: bugsquad => kde

Marja Van Waes 2017-04-20 10:04:23 CEST

Summary: Okular and Gwenview refuse to print after recent updates => Okular and Gwenview refuse to print after updates in February or January

Comment 16 Thomas Andrews 2017-04-20 16:28:06 CEST
(In reply to Marja van Waes from comment #15)
> 
> Please try, you can always downgrade them again if they make things worse.
> 
> It was asked in several bug reports to test those packages.
> 
> 
> 
> Anyway, assigning to KDE team, because I can't think of anything better
> (this only occurring with 2 KDE applications).
> 
> If the packages in updates_testing solve the issue, then we'll reassign this
> bug.

Just a clarification, before trying the above packages...

I reported this as happening with Okular and Gwenview because those are the KDE apps I use and print from at all regularly. I just checked, and the same issue appears with other KDE apps, like Kolourpaint, Konqueror, KWrite, and Skrooge all show the same symptoms. 

I should have checked them, too. It's just that I almost never print from KWrite, and I just don't use the others at all. Changing the bug title to reflect this new information.

Summary: Okular and Gwenview refuse to print after updates in February or January => KDE apps refuse to print after updates in February or January

Comment 17 Thomas Andrews 2017-04-20 17:33:05 CEST
The packages in Updates Testing made no difference.

I tried two ways. First I tried a simple update of the packages, with no change. KDE apps still don't print.

I have another Mageia 5 install on the same hardware, that's waiting to test upgrades to Mageia 6 on real hardware. This install had not had any printers installed on it yet, and did not have any printing packages installed except for system-config-printer, which must have been installed from the install media. This time, I updated system-config-printer manually and installed task-printing-server and task-printing-hp from Updates Testing before attempting to install any printer at all. 

No Joy. I checked with Gwenview, after installing only the HP Deskjet 5650. After clicking on "Print" from the File menu, the menu disappears. A circle of dots is in the middle of the image, but it isn't spinning as it would if the computer was busy. I left it there. So far it's been about 10 minutes with no change, except that the screen save kicked in.

Just in case it's important, the affected hardware this time is an Intel DQ45CB motherboard, Intel Core 2 Duo E8400 processor, 6GB RAM, Broadcom BCM4318 wifi, HP Deskjet 5650 printer. The above tests were on x86_64 installs.
Comment 18 Marja Van Waes 2018-08-23 09:45:49 CEST
Hi Thomas,

Sorry if this never got fixed for you in Mageia 5.

I hope Mageia 6 works better.

If it doesn't, then please file a separate bug  report, because KDE applications in Plasma5 are entirely different from KDE applications in KDE4.

Closing this report as OLD, because Mga5 is no longer officially reported.

Status: NEW => RESOLVED
Resolution: (none) => OLD


Note You need to log in before you can comment on or make changes to this bug.