Bug 19192 - GDM is blurred, while other DM and DE (incl Gnome) displays OK, on Radeon X1400
Summary: GDM is blurred, while other DM and DE (incl Gnome) displays OK, on Radeon X1400
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: High major
Target Milestone: ---
Assignee: All Packagers
QA Contact:
URL:
Whiteboard: WORKAROUND
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-13 02:19 CEST by Morgan Leijström
Modified: 2017-06-14 11:01 CEST (History)
2 users (show)

See Also:
Source RPM: gdm-3.20.1-5.mga6.src.rpm
CVE:
Status comment:


Attachments

Description Morgan Leijström 2016-08-13 02:19:26 CEST
( cloned from the rest of Bug 18883#c13 )

Symptom: display looks like an old CRT display when operated at wrong horizontal frequency; each line is moved some millimetres right from the line above.

Display is OK throughout the graphical boot process, but go wacky when GDM starts.

There is no related error messages in Xorg log nor in system journal that i can see as related.

Laptop: Thinkpad T60, with 1400x1050 screen
GPU: ATI RV515/M54 [Mobility Radeon X1400]
Driver: "ATI Radeon HD 4870 and earlier"

GDM as well as other DM and several DE i tried worked OK at sta1 release, but first days in july it broke like above for all DM and the DE i tried - For a few weeks i have had to use the workaround to use vesa and 15bpp colour and only MATE (not Gnome nor Plasma worked)

After many updates today (held back a week) I can use any of SDDM, LXDM or XDM to log into Plasma, Gnome or MATE.

But not GDM.
Comment 1 Morgan Leijström 2016-08-13 02:28:58 CEST
The workaround is of course to use another DM, but it takes advanced user skills to understand and apply that from being at a blurred screen and i really think GDM is such a piece that should just work, therefore i set priority High, Major.

Priority: Normal => High
Whiteboard: (none) => WORKAROUND

Thierry Vignaud 2016-08-13 04:45:42 CEST

CC: (none) => olav

Comment 2 Marja van Waes 2016-08-13 20:57:24 CEST
Assigning to all packagers collectively, since there is no registered maintainer for this package.

CC: (none) => marja11
Assignee: bugsquad => pkg-bugs

Comment 3 Morgan Leijström 2017-06-14 10:34:47 CEST
Still valid after updates mga6 today, close to release.

If someone else experience this, it would be good to try a fresh install with only Gnome and GDM.

I just dont have the time right now, and this is my wifes production machine that runs nice in other aspects so i will not fiddle with it...

Anyhow it is easy to just use another DM.
Comment 4 Morgan Leijström 2017-06-14 11:01:12 CEST
Helpful hint if this happen; how to switch DM

Ctrl-Alt-F2 to get a command prompt
type "root", enter and enter root password
then install another DM if you do not have one, i.e for SDDM:
 urpmi sddm
then issue "drakdm" to change DM, let it restart session.

Note You need to log in before you can comment on or make changes to this bug.