Bug 18107 - netapplet and mgaapplet need bigger icons (drakx-net and mgaonline)
Summary: netapplet and mgaapplet need bigger icons (drakx-net and mgaonline)
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: Mageia 6
Assignee: Frédéric Buclin
QA Contact:
URL:
Whiteboard:
Keywords: 6dev1
: 17618 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-02 09:47 CEST by Len Lawrence
Modified: 2017-03-05 18:25 CET (History)
8 users (show)

See Also:
Source RPM: drakx-net-2.25-1.mga6, mgaonline-3.16-1.mga6
CVE:
Status comment:


Attachments
Screenshot showing doubled panel icons (931.35 KB, image/png)
2016-04-05 17:13 CEST, Len Lawrence
Details

Description Len Lawrence 2016-04-02 09:47:29 CEST
Description of problem:
This is particularly noticeable in the Mate panel but has affected Plasma to some extent in previous incarnations.  In Mate the net applet and update applet appear as two images together, sometimes with an extra fraction of the image to the right of that.  Currently Plasma does not show any anomalies.  Marking this as normal but note that there is no loss of function - it is purely aesthetic.


Version-Release number of selected component (if applicable):
6dev1 in general

How reproducible:
Always

Steps to Reproduce:
1. Install the Mate desktop from any of the 6dev1 isos
2. Look for netapplet and update applet doubling
3.
Comment 1 Marja van Waes 2016-04-05 10:55:40 CEST
Hmm, I was almost sure there was an existing bug report about this issue, but can't find it.

Anyway, assigning to maintainer

Keywords: (none) => 6dev1
CC: (none) => marja11
Component: Release (media or process) => RPM Packages
Assignee: bugsquad => tarakbumba
Source RPM: (none) => mate-applets

Comment 2 Atilla ÖNTAŞ 2016-04-05 11:08:08 CEST
Thank you reporting this Len, but i'm unsure that i understand this. Would you mind to attach a screenshot which represents the issue? Do you mean there are two net_applet and two updater applet displayed?
Comment 3 Len Lawrence 2016-04-05 14:07:44 CEST
Yes, I will get a screenshot when I have a spare moment.  The problem affects the updater and net applets at least.  The image in those instances is doubled but each multiple acts like a single icon.  It is if a certain width is assigned for the screen display icon and filled in with however many icon images will fit.  As I said the multiplication is not necessarily integral.  The icons form a chain within the allowed space and you can click anywhere in that space to launch a single instance of the application.  I cannot remember seeing this in former versions of Mageia but since the deployment of 6dev1 it has become common.  No idea if it is theme related.  I am using the default theme.  I need to see how the icons look on different machines with lower resolution monitors.

I shall get back to you.
Comment 4 Len Lawrence 2016-04-05 17:13:51 CEST
Created attachment 7634 [details]
Screenshot showing doubled panel icons

This was on a 4K Dell monitor.
Comment 5 Atilla ÖNTAŞ 2016-04-18 15:35:18 CEST
Len, do you install mageia6-dev1 on top of a clean home? If not there may be remained autostart files for netapplet and mgaupdate applet in .config/Autostart ?
Comment 6 Len Lawrence 2016-04-19 09:48:19 CEST
No.  I usually leave my home and data partitions untouched.  On my later machines they have disks to themselves.  If you think the trouble lies there I shall clean out .config before installing.  I might be able to try that out sometime today.
Comment 7 Len Lawrence 2016-04-19 12:23:23 CEST
Apparently not.  The machine where the fault was exhibited has lost its graphics - a damaged gold contact on the GTX 970 card (probably there when the machine was delivered) so I shall have to look for a new one.  I can try the test on a laptop - much later - I am overwhelmed just now.
Comment 8 Len Lawrence 2016-04-19 17:40:53 CEST
No, I see nothing relevant in autostart.  In fact I wiped autostart altogether and logged out and in and nothing changed.  I am convinced that this has something to do with geometry.  Noticing that the doubled icon took up about the same width as normal icons but half the height I tried scaling the panel.  As the panel shrank the doubled icon remained the same size whereas all the other icons shrank proportionally.  Reversing this the panel reached a height where copies of the doubled icon started appearing at the bottom.  It looks like netapplet and updateapplet ignore the current properties of the panel and multiply instead of autoscaling to fit their slots.  Weird behaviour.
Comment 9 Len Lawrence 2016-04-19 17:45:43 CEST
The other thing is - I always work with one panel, melding the top panel into the bottom one.  Could this have a bearing on the problem?

I shall invent another Mate user and use the default panel configuration and see if the doubling still occurs.
Comment 10 Len Lawrence 2016-04-19 17:52:31 CEST
Nope.  With two panels netapplet is still doubled and does not respond to panel scaling.
Comment 11 Atilla ÖNTAŞ 2016-05-02 20:11:13 CEST
I've found the problem. Our applets use one sized and not scalable status icons. Thus, when user increases panel size, panel fills the gap by doubling icons. We should use scalable vector graphics or provide different sized status icons. See that there is only two status icons as /usr/share/libDrakX/pixmaps/connected_big.png and /usr/share/libDrakX/pixmaps/connected.png for only two display sizes.

So, i think this bug report for either tv or our atelier team. I can't decide. I'm assigning this report to bugsquad again. Marja, would you mind to re-assign this either to tv or atelier team?

Assignee: tarakbumba => bugsquad

Comment 12 Len Lawrence 2016-05-02 20:25:09 CEST
Well done Attila.  Thanks for pursuing this.
Comment 13 Marja van Waes 2016-05-03 12:27:29 CEST
(In reply to Atilla ÃNTAÅ from comment #11)
> I've found the problem. Our applets use one sized and not scalable status
> icons. Thus, when user increases panel size, panel fills the gap by doubling
> icons. We should use scalable vector graphics or provide different sized
> status icons. See that there is only two status icons as
> /usr/share/libDrakX/pixmaps/connected_big.png and
> /usr/share/libDrakX/pixmaps/connected.png for only two display sizes.
> 
> So, i think this bug report for either tv or our atelier team. I can't
> decide. I'm assigning this report to bugsquad again. Marja, would you mind
> to re-assign this either to tv or atelier team?

Thanks, Atilla

I think Animtim didn't finish his work on our icons, yet, so assigning to him, in case he's willing to do this.

AFAIK, we don't use vector graphics anywhere for our icons, so only asking for more different sizes. The mgaapplet icons (from mgaonline) only come in one size, and the wlan status icons from drakx-net, too.

@ Timothée

Please re-assign to Atelier team if I'm wrong to assume you can and want to fix this.

CC: (none) => atelier-bugs, thierry.vignaud
Assignee: bugsquad => animtim
Summary: Multiplication of some Mate panel icons in successive 6dev1 releases => netapplet and mgaapplet need icons in more sizes (drakx-net and mgaonline)
Source RPM: mate-applets => drakx-net-2.25-1.mga6, mgaonline-3.16-1.mga6

Comment 14 Timothée Giet 2016-05-05 19:34:24 CEST
@Marja: I did finish my work on the icons, but indeed I'd like to see this issue solved.

Thing is, I replaced the icons as they were before, those never had several sizes.

And the problem happens only on some desktop, like on plasma5 they look very blurry, like if they are scaled down to 16px and then scaled up.
I checked on LXQt desktop, they look perfectly good.
(note, I noted the same issue on another computer with a manjaro distribution, the octopi notifier icon has the exact same issue in plasma5..)

I tried to install several sizes for one icon to check, and couldn't find a way to install them in a way that they are seen by the applet. It looks like they are hardcoded, or I didn't try the right way.
(I tried adding some 16 24 32 48 64 folders inside the pixmaps folder, and also tried to install them directly in pixmaps top folder but with -size.png at the end as I saw several other icons with such naming.


So I really think we should replace those to load the SVG files instead. SVG files are all in the sources, we just need to make sure to install them instead of the png, and make the respective code load svg.

It would easily solve all scalability issues in an easy way.

Yes we didn't use svg before, but it doesn't mean we can't change that, afaik all desktop nowadays should support that. (and for reference, all breeze icons are directly svg too..).

So, can we agree on the svg solution? If yes, who can look at this?
Comment 15 Marja van Waes 2016-05-05 21:01:58 CEST
(In reply to Timothée Giet from comment #14)
> @Marja: I did finish my work on the icons, but indeed I'd like to see this
> issue solved.
> 
> Thing is, I replaced the icons as they were before, those never had several
> sizes.
> 

Yeah, that's true.

<snip>
> 
> 
> So I really think we should replace those to load the SVG files instead. SVG
> files are all in the sources, we just need to make sure to install them
> instead of the png, and make the respective code load svg.

Oh, nice, they are indeed in the sources, thanks!

> 
> It would easily solve all scalability issues in an easy way.
> 
> Yes we didn't use svg before, but it doesn't mean we can't change that,
> afaik all desktop nowadays should support that. (and for reference, all
> breeze icons are directly svg too..).
> 
> So, can we agree on the svg solution? If yes, who can look at this?

If Thierry or someone else who knows how to do that can change the mgaonline and the drakx-net code to use the svg files, and if the maintainers of the different DEs can make any needed changes on their side, then I fully agree.

@ Thierry 
@ Akien (as packaging team leader)

WDYT?

(I think Atilla already indicated that would be a solution for him)

CC: sysadmin-bugs, thierry.vignaud => animtim, rverschelde, tarakbumba
Assignee: animtim => thierry.vignaud

Rémi Verschelde 2016-05-28 20:25:10 CEST

Attachment 7634 mime type: application/octet-stream => image/png

Rémi Verschelde 2016-05-29 11:14:20 CEST

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=17618

Comment 16 Rémi Verschelde 2016-05-29 11:23:15 CEST
@ Thierry, all: See bug 17618 comment 16 for more details about changing the icon sizes.

Changing all icon sizes to 128x128px is an OK workaround for most desktops, so it's not enough for Plasma, which still seems to downscale the icon and upscale it again.

The best solution would be to add proper support for SVG, and ensure we create applets that modern desktops know how to handle.

I tried a quick hack to enforce using SVG, but obviously gtkcreate_pixbuf can't handle this format out of the box: http://gitweb.mageia.org/software/mgaonline/tree/mgaapplet#n659
And that's about where my perl/GTK+3 tweaking knowledge stops :)
Comment 17 ben mcmonagle 2016-07-18 10:57:21 CEST
not sure if to append this report or create a new one.

For LXDE x86_64 single DE install:

network icon is 1 + 1/2 icon
mga_applet icon is 1 + 1/2 icon
mga_applet (refresh after update) is 1+1/2 icon

Mageia-6-RC-x86_64-DVD.iso
DATE.txt: Fri Jul 15 20:00:00 CEST 2016

CC: (none) => westel

Comment 18 Len Lawrence 2016-07-18 14:30:31 CEST
I think this has to be the same bug Ben.  We should leave it in the hands of atelier team or whoever has some idea about the best solution.
Comment 19 Barry Jackson 2017-03-05 13:48:28 CET
What's the status of this?
net_applet icon still looks blurry to me in plasma5

CC: (none) => zen25000

Comment 20 Rémi Verschelde 2017-03-05 14:01:31 CET
It should now be using the SVG icon, so it shouldn't be blurry.

Do you have drakx-net-2.28-1.mga6?
Rémi Verschelde 2017-03-05 14:01:46 CET

Assignee: thierry.vignaud => rverschelde

Comment 21 Frédéric Buclin 2017-03-05 15:14:47 CET
*** Bug 17618 has been marked as a duplicate of this bug. ***

See Also: https://bugs.mageia.org/show_bug.cgi?id=17618 => (none)
CC: (none) => nicolas.salguero

Comment 22 Mageia Robot 2017-03-05 16:50:03 CET
commit 8fa121631985e864843544dae9c6faf22bfa2b4a
Author: Frédéric Buclin <LpSolit@...>
Date:   Sun Mar 5 16:48:30 2017 +0100

    Set the size of icons to 128px when generated from SVG files (mga#18107)
---
 Commit Link:
   http://gitweb.mageia.org/software/mgaonline/commit/?id=8fa121631985e864843544dae9c6faf22bfa2b4a
Comment 23 Frédéric Buclin 2017-03-05 16:54:23 CET
net-applet was already fixed in drakx-net-2.28-1.mga6 released yesterday. I just committed a fix for mgaapplet. I tested on LXQt. Plasma was fine already.

Status: NEW => RESOLVED
Resolution: (none) => FIXED
Assignee: rverschelde => LpSolit
Target Milestone: --- => Mageia 6
Summary: netapplet and mgaapplet need icons in more sizes (drakx-net and mgaonline) => netapplet and mgaapplet need bigger icons (drakx-net and mgaonline)

Comment 24 Frédéric Buclin 2017-03-05 18:25:11 CET
Fix for mgaapplet is available in mgaonline-3.19-1.mga6.

Note You need to log in before you can comment on or make changes to this bug.