Bug 17552 - Firefox from the Mageia v6 dev1 x86-64 Classical ISO with a KDE installation cannot play .webm or YouTube files
Summary: Firefox from the Mageia v6 dev1 x86-64 Classical ISO with a KDE installation ...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
: High normal
Target Milestone: ---
Assignee: All Packagers
QA Contact:
URL: https://www.youtube.com/watch?v=ruxmW...
Whiteboard: dev1
Keywords: 6sta1
Depends on:
Blocks:
 
Reported: 2016-01-20 19:24 CET by Shlomi Fish
Modified: 2017-06-02 12:32 CEST (History)
6 users (show)

See Also:
Source RPM: firefox
CVE:
Status comment:


Attachments
rpm-qa inside the -dev1 plasma VM. (58.33 KB, text/plain)
2016-03-08 11:53 CET, Shlomi Fish
Details
mga6 dev1 rpm -qa output with selecting KDE as the desktop (58.31 KB, text/plain)
2016-03-12 13:22 CET, Shlomi Fish
Details

Description Shlomi Fish 2016-01-20 19:24:08 CET
Description of problem:

Firefox from the Mageia v6 dev1 x86-64 Classical ISO with a KDE installation cannot play .webm or YouTube files. I already installed the updates, and even tried enabling the tainted repositories and installing task-codec-audio and task-codec-video - still happens.

Version-Release number of selected component (if applicable):

Cauldron.

How reproducible:

Always.

Steps to Reproduce:
1. Install the KDE desktop.
2. Start Firefox.
3. Go to https://www.youtube.com/watch?v=ruxmWBHCGn4 or tohttp://www.shlomifish.org/Files/files/video/ and try to play the .webm files.


Reproducible: 

Steps to Reproduce:
Comment 1 ben mcmonagle 2016-01-21 05:42:44 CET
https://www.youtube.com/watch?v=ruxmWBHCGn4 

plays ok for me in Mageia-6-dev1-LiveDVD-PLASMA5-x86_64-DVD - installed system
[no flash-player-plugin installed]
Comment 2 Samuel Verschelde 2016-02-23 12:18:54 CET
Could someone from QA or packagers try to investigate? This has the potential to be an important issue.
Comment 3 Rémi Verschelde 2016-02-23 12:43:07 CET
I'm using Firefox on Plasma/cauldron daily and haven't noticed any such issue. I'll try with the links given above though.
Comment 4 Samuel Verschelde 2016-02-23 13:12:33 CET
(In reply to Rémi Verschelde from comment #3)
> I'm using Firefox on Plasma/cauldron daily and haven't noticed any such
> issue. I'll try with the links given above though.

I think we need to test from a fresh installation. Maybe a missing dependency.
Comment 5 claire robinson 2016-02-23 15:52:41 CET
No flash player is available initially so it'll use html5 and require relevant codecs installed, possibly from tainted.
Comment 6 Florian Hubold 2016-02-24 01:12:50 CET
FWIW works fine here, too.

Can you check whether https://bugs.mageia.org/show_bug.cgi?id=15043#c25 helps?

Also the output of "rpm -qa|sort|grep gstreamer" might be helpful.
Comment 7 Shlomi Fish 2016-02-24 12:04:58 CET
(In reply to Florian Hubold from comment #6)
> FWIW works fine here, too.
> 
> Can you check whether https://bugs.mageia.org/show_bug.cgi?id=15043#c25
> helps?
> 
> Also the output of "rpm -qa|sort|grep gstreamer" might be helpful.

Yes, I'll get to it.
Comment 8 Shlomi Fish 2016-03-08 11:52:33 CET
With the recent classic x86-64 DVD -dev1 snapshot in a VBox VM, I can play the YouTube file in the link (though the sound is very low), but I cannot play a regular HTTP-served .webm file such as:

* http://www.shlomifish.org/Files/files/video/Shania%20Twain%20-%20I'm%20Gonna%20Getcha%20Good%20%28Cover%20by%20Tay%20Barton%29-IC5Ecd5W6cQ.webm 

(short URL : http://is.gd/12jWx1 )

it  says the file is corrupt. 

I'll attach my rpm-qa soon.
Comment 9 Shlomi Fish 2016-03-08 11:53:17 CET
Created attachment 7526 [details]
rpm-qa inside the -dev1 plasma VM.
Comment 10 Shlomi Fish 2016-03-12 13:16:00 CET
With the recent classic x86-64 DVD -dev1 snapshot in a VBox VM, I cannot play either the video in question on YouTube or view a .webm file from the /video/ directory on my site. See:

http://www.shlomifish.org/Files/files/images/mga-x86-64-v6-classic-dvd-dev1-firefox-wont-play-youtube-webm-on-plasma.jpg

I'll attach the rpm -qa output soon.
Comment 11 Shlomi Fish 2016-03-12 13:22:29 CET
Created attachment 7563 [details]
mga6 dev1 rpm -qa output with selecting KDE as the desktop

This is the «rpm -qa» output inside the VM.
Comment 12 Shlomi Fish 2016-03-17 14:43:25 CET
Adding the 6dev1 keyword.
Comment 13 Marja van Waes 2016-04-28 21:11:01 CEST
Assigning to all packagers collectively, since there is no maintainer for this package.

It might be wise to wait investigating till the new QA 6sta1 isos are released... maybe this got somehow fixed with firefox-45.1.0?
Comment 14 Shlomi Fish 2016-05-03 16:32:47 CEST
still happens with a classic DVD i586 KDE install of 6sta1.
Comment 15 Shlomi Fish 2016-05-23 17:32:17 CEST
The plot thickens - this video plays fine in the latest sta1 x86-64 plasma5 LiveDVD - https://www.youtube.com/watch?v=BPNTC7uZYrI - while the other videos still exhibit the problem.
Comment 16 Chris B 2017-06-02 11:26:04 CEST
I can play all webm videos, youtube and those embedded on Shlomi's website, latest firefox, fully updated M6 RC.

Low sound in vbox: switch in the vbox settings the (default) audio controller from Intel HD Audio to ICH AC97.
Comment 17 Shlomi Fish 2017-06-02 12:32:23 CEST
(In reply to Chris B from comment #16)
> I can play all webm videos, youtube and those embedded on Shlomi's website,
> latest firefox, fully updated M6 RC.
> 
> Low sound in vbox: switch in the vbox settings the (default) audio
> controller from Intel HD Audio to ICH AC97.

I recall it being OK there as well. Resolving this bug.

Note You need to log in before you can comment on or make changes to this bug.