Bug 16980 - fglrx proprietary video driver seg faults
Summary: fglrx proprietary video driver seg faults
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
: Normal major
Target Milestone: ---
Assignee: Anssi Hannula
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-19 13:43 CEST by Bit Twister
Modified: 2016-07-17 02:35 CEST (History)
2 users (show)

See Also:
Source RPM: fglrx
CVE:
Status comment:


Attachments
dmesg snippet (4.77 KB, text/plain)
2015-10-19 13:44 CEST, Bit Twister
Details
dmesg snippet (4.95 KB, text/plain)
2015-11-12 13:09 CET, Bit Twister
Details
Xorg.0.log_failed-boot-default-proprietary (18.46 KB, text/plain)
2016-05-24 11:32 CEST, Morgan Leijström
Details
lspci-v_failed-boot-default-proprietary (13.52 KB, text/plain)
2016-05-24 11:38 CEST, Morgan Leijström
Details
lspcidrake-v_failed-boot-default-proprietary (5.42 KB, text/plain)
2016-05-24 11:39 CEST, Morgan Leijström
Details
journalctl-ab_failed-boot-default-proprietary.tar.gz (33.54 KB, application/octet-stream)
2016-05-24 11:41 CEST, Morgan Leijström
Details

Description Bit Twister 2015-10-19 13:43:04 CEST
Description of problem:

fglx proprietary video seg faults 

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Use mcc to configure video server for ATI Radeon HD 6400 and later (radeon/fglrx)


# lspcidrake | grep card
Card:ATI Radeon HD 6400 and later (radeon/fglrx): Advanced Micro Devices, Inc. [AMD/ATI]|Oland PRO [Radeon R7 240/340] [DISPLAY_VGA]

Workaround:  set xorg vesa video driver.


Reproducible: 

Steps to Reproduce:
Comment 1 Bit Twister 2015-10-19 13:44:14 CEST
Created attachment 7141 [details]
dmesg snippet
Comment 2 Bit Twister 2015-11-12 13:09:07 CET
Created attachment 7198 [details]
dmesg snippet
Comment 3 Bit Twister 2016-01-19 02:11:24 CET
Any chance of seeing if the amd-catalyst 15.201.1151-x86 release fixes my problem?
Comment 4 Thomas Backlund 2016-01-19 08:20:41 CET
Not any point for now as current fglrx does not support kernel 4.4 (could probably be patched), and not xorg 1.18 (which needs changes bt Amd to the binary-only parts of fglrx), and is not really happy with gcc 5 either... :/

So we still have to wait for Amd
Comment 5 Morgan Leijström 2016-05-24 09:46:13 CEST
What is the status here?

I upgraded this system online from mga5 a week ago, and it worked great.
I kept updating and after a reboot a couple days ago it could not start X.
I have to use the system so i use xorg vesa for now 

( which is painful on a 2560x1600 screen... and yes i am am lunetic using cauldron on my workstation but i needed a programs that were conveniently packaged her and not on mga5 ;) )

( also tried xorg ati and xorg amdgpu which failed, while i have no idea if they would have a chance.  Any idea on a better workaround than the vesa (too low resolution for my taste )

Card: Barts PRO [Radeon HD 6850]

# lspcidrake | grep card
[root@svarten ~]# Card:ATI Radeon HD 6400 and later (radeon/fglrx): Advanced Micro Devices, Inc. [AMD/ATI]|Oland PRO [Radeon R7 240/340] [DISPLAY_VGA]

I noted system only have mga5 versions of fglrx:
- fglrx-control-center-15.302-1.mga5.nonfree.x86_64
- fglrx-kernel-4.1.15-desktop-2.mga5-15.302-1.mga5.nonfree.x86_64
- fglrx-kernel-desktop-latest-15.302-1.mga5.nonfree.x86_64
- fglrx-opencl-15.302-1.mga5.nonfree.x86_64
- x11-driver-video-fglrx-15.302-1.mga5.nonfree.x86_64
I wonder if the system was using them despite running mga6 kernel 4.6.0?
To clear confusion i now uninstalled them.
(i still keep latest mga5 kernel as a backup)

I find no mga6 fglrx at all!?

I fail to find where is a log of urpmi/drakrpm activities?

IMO, this bug should be a release blocker
Comment 6 Morgan Leijström 2016-05-24 11:32:39 CEST
Created attachment 7843 [details]
Xorg.0.log_failed-boot-default-proprietary

Um, maybe there is another problem.
From my Xorg.0.log :
 (EE) Screen 0 deleted because of no matching config section.
 (II) UnloadModule: "radeon"
 (EE) Device(s) detected, but none match those in the config file

(but i can use vesa)
Comment 7 Morgan Leijström 2016-05-24 11:37:10 CEST
Small sidenotes: 

I read that amdgpu is not suitable for my GPU, interesting read https://www.reddit.com/r/Amd/comments/4gf9ev/thank_you_amd_for_your_open_source_linux_driver/

I also tried "HD4870 and earlier" as it was the only one in that series that do not need fglrx, but that fail too.
Comment 8 Morgan Leijström 2016-05-24 11:38:46 CEST
Created attachment 7844 [details]
lspci-v_failed-boot-default-proprietary
Comment 9 Morgan Leijström 2016-05-24 11:39:36 CEST
Created attachment 7845 [details]
lspcidrake-v_failed-boot-default-proprietary
Comment 10 Morgan Leijström 2016-05-24 11:41:16 CEST
Created attachment 7846 [details]
journalctl-ab_failed-boot-default-proprietary.tar.gz
Comment 11 Morgan Leijström 2016-05-25 08:12:47 CEST
Update: since updated x11 and xorg ati today
this system works with xorg ati free driver :) 
=> my system is fully useable again (not using fglrx)
Comment 12 Morgan Leijström 2016-07-17 02:17:46 CEST
Now the proprietary ati driver works on this system :)
Comment 13 Thomas Backlund 2016-07-17 02:23:12 CEST
you are not using any proprietary driver for amd/ati hw...

There is no such driver available in cauldron, 

fglrx is not supporting either kernel or xorg server.

So you are using the free radeon/ati drivers
Comment 14 Morgan Leijström 2016-07-17 02:35:23 CEST
Oh. Heh.

Anyway good thing is that when selecting to use the default choice when configuring the graphics, the
 "ATI > Radeon HD 6400 and later (radeon/fglrx)"
now results in a working system.

What is the plan here, if any?
Will proprietary driver be with us in the future,
Or drakx11 changed to say that it really will use the free driver?

Note You need to log in before you can comment on or make changes to this bug.