Bug 1677 - The BIOS fails to start Mageia 1
: The BIOS fails to start Mageia 1
Status: RESOLVED OLD
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 1
: i586 Linux
: Normal Severity: normal
: ---
Assigned To: Mageia Bug Squad
:
:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-06-07 23:46 CEST by Frédéric Buclin
Modified: 2012-08-02 13:14 CEST (History)
3 users (show)

See Also:
Source RPM:
CVE:


Attachments

Description Frédéric Buclin 2011-06-07 23:46:57 CEST
Since I upgraded to Mageia 1 (from Mandriva 2010.2), Mageia is unable to boot cleanly. Every time I start my PC, I see the BIOS output, then it reboots and fails with:

**** Warning: System BOOT Fail ****
Your system last boot fail or POST interrupted.
Please enter setup to load default and reboot again.

Press F1 to continue, DEL to enter SETUP.


If I press F1, then Mageia correctly boots. This never happened with Mandriva 2010.2.
Comment 1 DariuszSki 2011-06-09 15:51:49 CEST
I ran into an error when upgrading also from Mandriva 2011.2 to Mageia. This error stopped the computer from booting, it claimed there was no bootloader.

On checking with Knoppix live distro, indeed, Mageia failed to install a boot loader (then trashed the MBR). The only way I got my system to work was to clean install Mageia (/home on different drive).

Perhaps then, there is a problem with the installation routine that stops certain files being copied to /boot, and so crippling an installation. It could be what you're experiencing.
Comment 2 Frédéric Buclin 2011-06-13 11:28:28 CEST
I fixed the problem by reinstalling the Boot Loader.
Comment 3 Frédéric Buclin 2011-06-14 18:27:24 CEST
(In reply to comment #2)
> I fixed the problem by reinstalling the Boot Loader.

I take that back. It didn't survive a cold reboot. The problem is back. Could it be that Mageia doesn't shut down correctly, causing the error reported in comment 0?
Comment 4 Ahmad Samir 2011-06-14 18:53:32 CEST
When you boot the system, does it try to load GRUB at all? or fails before even reaching that stage?
Comment 5 Frédéric Buclin 2011-06-14 18:57:06 CEST
Hard to say. I guess it tries to load it, but I don't know how to check this step.
Comment 6 Ahmad Samir 2011-06-15 00:54:23 CEST
Did you check if there're any BIOS updates for your MOBO?
Comment 7 Frédéric Buclin 2011-07-01 17:59:02 CEST
(In reply to comment #6)
> Did you check if there're any BIOS updates for your MOBO?

I did, and upgrading the BIOS to the latest version available didn't help at all.
Comment 8 Manuel Hiebel 2011-10-11 21:31:36 CEST
Something related to accumulator ?
Comment 9 Marja van Waes 2011-12-09 17:29:01 CET
@ Frédéric

Is this bug still valid?

If so, which mobo and graphic card have you got? 

When you google the error string, you find an amazing lot of people are experiencing the same problem. Some claim it is mainly an Asus problem, others claim is is a bug in a certain kernel, and it even happens with Mdv 2011: 

http://forum.mandriva.com/fr/viewtopic.php?f=84&t=135695 

Having the last BIOS version doesn't always help:
http://forums.amd.com/game/messageview.cfm?catid=260&threadid=131177
see his second post of 04/05/2010 11:13 AM
Comment 10 Marja van Waes 2012-01-29 11:11:54 CET
@ Frédéric

Of course I should have asked whether this bug is still valid when upgrading to or installing Mageia 2 alpha

Is it?
Comment 11 Frédéric Buclin 2012-01-29 14:47:20 CET
(In reply to comment #10)
> Of course I should have asked whether this bug is still valid when upgrading to
> or installing Mageia 2 alpha

I cannot tell you. Cauldron is installed in a VM. And I won't upgrade my main OS till Mageia 2 is released. I cannot afford to have a broken or unstable OS for work.
Comment 12 Marja van Waes 2012-02-13 07:40:02 CET
cc'ing tmb (grub committer and kernel maintainer)
Comment 13 DariuszSki 2012-02-14 19:35:04 CET
I can't test this until Mageia is in beta, I don't have a machine that I can dedicate to alpha releases and any mess that might or might not cause.
Comment 14 Marja van Waes 2012-03-07 07:23:38 CET
(In reply to comment #13)
> I can't test this until Mageia is in beta, I don't have a machine that I can
> dedicate to alpha releases and any mess that might or might not cause.

Beta is here, but don't try beta on a production system. For important systems, please only use stable
Comment 15 Marja van Waes 2012-03-25 07:42:58 CEST
(In reply to comment #14)
> (In reply to comment #13)
> > I can't test this until Mageia is in beta, I don't have a machine that I can
> > dedicate to alpha releases and any mess that might or might not cause.
> 
> Beta is here, but don't try beta on a production system. For important systems,
> please only use stable

Do you have some spare space on your HD to make a Mga2b2 partition to test with?
Comment 16 Frédéric Buclin 2012-03-25 13:23:15 CEST
(In reply to comment #15)
> Do you have some spare space on your HD to make a Mga2b2 partition to test
> with?

No, I already use all the free space I have on my HD. And Beta 2 is pretty broken AFAIK. ;)
Comment 17 Marja van Waes 2012-04-19 15:37:31 CEST
@ Ski

Do you have a non-production system or partition you can use to test beta 3 with?

If this bug is still valid, it would be nice to know so it can hopefully be fixed before rc is released.
Comment 18 DariuszSki 2012-05-01 13:49:47 CEST
I have now installed Mageia2 beta3 on my semi-production machine, using a clean install. The problem originally reported appears to no longer exist. I can't close the bug report as I never filed it in the first place. I would say the problem is fixed... maybe by accident with changes to other stuff?

Mageia2 beta3 runs very well here.
Comment 19 Frédéric Buclin 2012-05-01 16:32:39 CEST
Doing a clean install is not what I reported. I reported the problem when upgrading from Mandriva. If the workaround is to do a clean install, then the upgrading process is broken. I plan to do a clean install once Mageia 2 is released, because I already ugpraded from Mandriva 2010.0 to 2010.1 to 2010.2 to Mageia 1, and maybe there is some mess or conflict with 3 consecutive upgrades.
Comment 20 Marja van Waes 2012-05-18 21:20:56 CEST
(In reply to comment #19)
> Doing a clean install is not what I reported. I reported the problem when
> upgrading from Mandriva. If the workaround is to do a clean install, then the
> upgrading process is broken. I plan to do a clean install once Mageia 2 is
> released, because I already ugpraded from Mandriva 2010.0 to 2010.1 to 2010.2
> to Mageia 1, and maybe there is some mess or conflict with 3 consecutive
> upgrades.

Removing the NEEDINFO keyword and leaving it open.
Comment 21 Frédéric Buclin 2012-08-02 13:14:45 CEST
I have upgraded to Mageia 2 (doing a clean install) so I cannot investigate this issue anymore. Marking the bug as old.

Note You need to log in before you can comment on or make changes to this bug.