Bug 16673 - Gwenview hangs if attempting to print a second copy of the same image
Summary: Gwenview hangs if attempting to print a second copy of the same image
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 5
Hardware: All Linux
Priority: Normal critical
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
Depends on:
Blocks: 18367
  Show dependency treegraph
Reported: 2015-08-30 03:45 CEST by Thomas Andrews
Modified: 2018-09-18 15:48 CEST (History)
5 users (show)

See Also:
Source RPM:
Status comment:


Description Thomas Andrews 2015-08-30 03:45:22 CEST
Description of problem:

When printing from Gwenview, the first copy of a jpg image prints normally, but if a second copy is attempted the program appears to "hang" immediately after the "print" button is pressed. The mouse moves the cursor, and the cursor will change from open hand to pointer, but drop-down menus do not drop down. The window closer "x" has to be pressed repeatedly to force KDE to close the program. The HP Device Manager does not show any job in the print queue, as if hplip never received the command to print.

This happens if the print parameters are left alone or changed. For example, changing the size of the printed image makes no difference.

If a different image is loaded after the first print without closing Gwenview, it will print normally. (I did not try printing a second image more than once.)

I'm using two HP usb printers, a Deskjet 5650 and an Officjet 6110, and it happens with both. I do not think the HP driver is at fault because I only see this in Gwenview, using both 32-bit and 64-bit systems. I do not have any other working printers.

Version-Release number of selected component (if applicable):

gwenview 4.14.3, as installed in a Mageia 5 KDE system

How reproducible:


Steps to Reproduce:
1. Print a jpg image with Gwenview
2. attempt to print another copy of the image, with or without changing print parameters


Steps to Reproduce:
Comment 1 Ben McMonagle 2015-08-30 08:20:22 CEST
Mageia 5 KDE x86
printer= Usb canon pixma pm280.

very long pause between 1st print and reprint, + 2 minutes,
but no other action required.

CC: (none) => westel

Comment 2 Thomas Andrews 2015-08-30 15:20:55 CEST
Further observations:

After clicking on the "print" button for the second print, I clicked to drop down the "File" menu, and waited. It dropped down after about a minute. I then decided to wait out that second print, and left to do some morning chores. After about 15 minutes I returned, and still no print. However, I was able at that time to use the print command to do a second print, but a third one hung things up again. After waiting a minute or so I attempted to close by using the window closer, but KDE said Gwenview wasn't responding.

Speculation: timeouts are kicking in, resetting whatever is hanging up.
Comment 3 Thomas Andrews 2015-09-05 04:17:47 CEST
Appears to be the same bug as https://bugs.mageia.org/show_bug.cgi?id=16330 seen in Okular.
Comment 4 Jin-tong Hu 2015-09-05 06:16:15 CEST
Same here on Mageia x86-64 with a network printer Sharp AR-M351U, both in Gwenview and in Okular. After printing a second copy, if I wait long enough, 
the hangs will end without any printout.

CC: (none) => piscestong

Samuel Verschelde 2015-09-07 17:04:59 CEST

Assignee: bugsquad => mageia

Comment 5 Thomas Andrews 2015-10-01 15:06:54 CEST
Wondering if the cups update that's in the testing repos would fix the problem. https://bugs.mageia.org/show_bug.cgi?id=16152
Comment 6 Marja Van Waes 2016-05-05 14:54:47 CEST
Is this bug still valid?

CC: (none) => marja11
Blocks: (none) => 18367

Comment 7 Thomas Andrews 2016-05-05 15:25:52 CEST
As of this morning, with Mageia 5, yes.
Comment 8 Marja Van Waes 2016-08-10 19:41:05 CEST
On the 25th of July, Phillipem uploaded the following packages to 
Cauldron's core/updates_testing:




@ Anyone reading this:

* If this bug is valid for you in cauldron, then please test whether updating your system-config-printer packages to version 1.5.7-5.mga6 fixes the problem and report back in this bug report.

* If you do not have this bug in cauldron, but you do run cauldron, then please update those packages, too, and report in bug 18367 whether they work as expected.

CC: (none) => makowski.mageia

Samuel Verschelde 2016-08-25 16:24:00 CEST

Assignee: mageia => kde

Comment 9 Thomas Andrews 2017-01-02 17:57:29 CET
Today is the first I've tried using my printers from Cauldron, and as of a few minutes ago I am not seeing this behavior there.
Comment 10 Johnny A. Solbu 2017-05-26 02:56:15 CEST
I still see it in Mageia 5.

CC: (none) => cooker

Comment 11 Johnny A. Solbu 2017-05-26 02:57:28 CEST
That is, I see hang's in other programs too, not just gwenview.
Comment 12 Marja Van Waes 2018-09-18 15:48:49 CEST
Hi Thomas,

Thank you for having taken the needed time to report this issue!

This bug was filed against Mageia 5. Did it get fixed? If so, please change its status to RESOLVED - FIXED.

If it didn't, then we regret that we weren't able to fix it in Mageia 5. Mageia 5 has officially reached its End of Life on December 31st, 2017 https://blog.mageia.org/en/2017/11/07/mageia-5-eol-postponed/
It continued to get limited extended support since then, but that support has now ended, too.
As a result we are closing this bug report as OLD.

If you still see this issue in a newer Mageia version, then please reopen this report and say so.

Resolution: (none) => OLD

Note You need to log in before you can comment on or make changes to this bug.