Bug 16493 - Add a mageia theme for sddm without user listing
Summary: Add a mageia theme for sddm without user listing
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: High major
Target Milestone: Mageia 6
Assignee: Florian Hubold
QA Contact:
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2015-07-29 16:37 CEST by Chris Denice
Modified: 2017-07-05 15:52 CEST (History)
5 users (show)

See Also:
Source RPM: sddm-0.11.0-1.mga5.src.rpm
CVE:
Status comment:


Attachments
mga-coffee theme, without user listing (310.51 KB, application/gzip)
2015-07-29 16:38 CEST, Chris Denice
Details
Replacement file to suppress the display of the flag (8.56 KB, text/x-qml)
2017-01-17 21:15 CET, papoteur
Details
Patch to suppress the display of the flag (2.37 KB, patch)
2017-03-13 22:07 CET, papoteur
Details | Diff

Description Chris Denice 2015-07-29 16:37:35 CEST
Hi there,
Since Kdm is gone now, I am reiterating an old wish which is to have a mageia greeter theme that does not list all users on the system (in addition to the usual one for those who wish to have user listing).

That is useful for sysadmin that do not want all login names to be listed in public places.

Since I guess that the kde team is quite busy with debugging plasma, I am providing such a theme in attachment, it is called mga-coffee for obvious reasons :)

That directory should go in  /usr/share/sddm/themes and "mga-coffee" specified in /etc/sddm.conf.

I'll be happy to package an update-alternatives for /etc/sddm.conf once we will have a mageia-sddm-default-config on request!

Cheers,
Chris.

Reproducible: 

Steps to Reproduce:
Comment 1 Chris Denice 2015-07-29 16:38:50 CEST
Created attachment 6870 [details]
mga-coffee theme, without user listing

1) Should go in /usr/share/sddm/themes

2) Modify /etc/sddm.conf as:

[Theme]
# use our custom theme based on Maui but with default Mageia background
Current=mga-coffee
Chris Denice 2015-07-29 16:40:31 CEST

Target Milestone: --- => Mageia 6

Manuel Hiebel 2015-07-29 18:09:06 CEST

Assignee: bugsquad => mageia

Comment 2 David Walser 2015-07-29 18:25:57 CEST
This is absolutely necessary for security reasons, and also MSEC disables the user lists when you switch to secure level, but it does not yet have support for SDDM.  This needs to be added.  I guess it could be written to use Chris's theme when in secure level.

Thanks Chris!

Severity: enhancement => major
CC: (none) => luigiwalser

David Walser 2015-08-01 22:40:43 CEST

Blocks: (none) => 15527

Comment 3 Nicolas Lécureuil 2015-08-01 23:29:00 CEST
Please add it.
Comment 4 Florian Hubold 2015-10-03 22:35:58 CEST
Taking this one, as I'm fixing some more sddm bugs along the way :)

CC: (none) => doktor5000
Status: NEW => ASSIGNED
Assignee: mageia => doktor5000

Comment 5 Florian Hubold 2015-10-03 22:53:50 CEST
Just tested with sddm-0.12.0-1.mga5, works fine for me :)
Added via http://svnweb.mageia.org/packages?view=revision&revision=886043 and thanks to Chris for providing the new theme ^^

Please provide feedback if something is not working.

Status: ASSIGNED => RESOLVED
Resolution: (none) => FIXED

Comment 6 Nicolas Lécureuil 2016-09-12 16:23:55 CEST
hi, 

maui is now deprecated. Can you provide a new mga version based on new sddm default theme ?

CC: (none) => mageia
Status: RESOLVED => REOPENED
Resolution: FIXED => (none)

Comment 7 Nicolas Lécureuil 2016-09-12 16:28:42 CEST
what about just using maldives or elarun with a mageia background ?
Comment 8 Rémi Verschelde 2016-09-12 16:50:32 CEST
(In reply to Nicolas Lécureuil from comment #6)
> maui is now deprecated. Can you provide a new mga version based on new sddm
> default theme ?

Actually my understanding is that maui was not deprecated, but it's now the default/what you have with no specific theme:

> REMOVED the "maui" theme as a standalone theme as it is now embedded in the > greeter. Remember to change the theme to empty if you had it set to "maui".

(From https://github.com/sddm/sddm/releases/tag/v0.14.0)
Comment 9 Chris Denice 2016-09-12 23:49:15 CEST
Hi,
I'll have a look if needed, sure!
Comment 10 Samuel Verschelde 2016-10-10 14:42:56 CEST
(Changing target milestone just for a test)

Target Milestone: Mageia 6 => ---

Comment 11 Samuel Verschelde 2016-10-10 14:44:20 CEST
(changed back)

Target Milestone: --- => Mageia 6

Samuel Verschelde 2017-01-17 10:29:39 CET

Blocks: 15527 => (none)

Samuel Verschelde 2017-01-17 10:37:02 CET

Priority: Normal => High

Comment 12 papoteur 2017-01-17 21:15:01 CET
Created attachment 8869 [details]
Replacement file to suppress the display of the flag

I propose this display without the flag of the layout. It brings no good information, but confusion. There is not yet better way.

CC: (none) => yves.brungard_mageia

Comment 13 Rémi Verschelde 2017-02-27 07:50:38 CET
Florian, Nicolas, could one of you test papoteur's fix in Comment 12 and add it to our theme? Or point me to the right package so that I have a look?

Keywords: (none) => PATCH

Comment 14 Nicolas Lécureuil 2017-02-27 10:13:58 CET
can you provide a patch please ?
Comment 15 papoteur 2017-03-13 22:07:41 CET
Created attachment 9087 [details]
Patch to suppress the display of the flag

Attachment 8869 is obsolete: 0 => 1

Comment 16 papoteur 2017-03-13 22:09:34 CET
The file Main.qml comes from mga-coffee in sddm package
Comment 17 Chris Denice 2017-03-16 17:14:02 CET
New sddm landing with patch implemented
Comment 18 Chris Denice 2017-05-25 15:26:08 CEST
Could you confirm we can close this bug too?
Comment 19 Italo Ramirez 2017-06-24 20:22:24 CEST
Do they speak of the same problem that is observed in the attached image? Corresponds to the first start after installation of Mageia 6 RC PLASMA.

Image:
https://ibb.co/eHHZdQ

Thk!

CC: (none) => gualadrake

Comment 20 papoteur 2017-06-25 17:12:57 CEST
@Italo
What is the problem in the picture you joined?
Comment 21 Chris Denice 2017-07-05 15:52:17 CEST
This bug seems to have derived miles away from the opened issue and none of us seems to know what is the issue now :D

I am closing because:

1) There is now a theme without users listing
2) The US flag is gone.

If there is any other issues than the two above, please open a new bug report, with eventually a link the relevant comments in this bug. Or reopen with some clear explanation :)

Cheers.

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.