Bug 16273 - wine-mono and wine-gecko must be rebuilt when wine is
Summary: wine-mono and wine-gecko must be rebuilt when wine is
Status: REOPENED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: release_blocker normal
Target Milestone: ---
Assignee: All Packagers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-02 14:56 CEST by Frank Griffin
Modified: 2021-07-22 20:51 CEST (History)
6 users (show)

See Also:
Source RPM: wine
CVE:
Status comment: Packages could be dropped if this can't be fixed


Attachments

Description Frank Griffin 2015-07-02 14:56:19 CEST
For both i586 and x86_64, if wine is rebuilt so must wine-mono and wine-gecko be.  Otherwise, launching a wine app gives warnings that suitable versions are missing and offers to download them.  The app will run if it does not use .NET or HTML rendering, but as we have the packages in the repositories, they should be kept in sync

Reproducible: 

Steps to Reproduce:
Comment 1 Marja Van Waes 2015-07-03 22:16:02 CEST
(In reply to Frank Griffin from comment #0)
> For both i586 and x86_64, if wine is rebuilt so must wine-mono and
> wine-gecko be.  Otherwise, launching a wine app gives warnings that suitable
> versions are missing and offers to download them.  The app will run if it
> does not use .NET or HTML rendering, but as we have the packages in the
> repositories, they should be kept in sync
> 


Assigning to the maintainer of wine-mono and wine-gecko, even he didn't push wine. 

And wishing Thierry a great holiday

CC: (none) => marja11, thierry.vignaud
Assignee: bugsquad => anssi.hannula

Comment 2 Frank Griffin 2015-07-04 03:47:36 CEST
I assume these were split out because of their size, but it would really make sense to recombine them with wine.
Comment 3 Marja Van Waes 2015-07-06 08:41:30 CEST
I had installed wine (with old wine-gecko and wine-mono) and had no problems booting into my related cauldron before you filed this bug report (but did get the same warning). Funny enough, a few hours after you filed it, and without having installed any updates and without having changed any settings the last two times I had used that cauldron, booting into into hung on 
"A start job is running for LSB: Allow users to run Windows(tm) applications ...."

This morning I found time to boot that cauldron again and check at what time it would time out... it was increased to 14min 26s and then a notice came to check "systemctl status wine.service" and nothing more happened. (no idea whether that can be related, only mentioning it in case it is)

@ Anssi

In case you're also (about to go) on holiday: of course a great holiday for you, too. I assigned to you because tv had told in a dev mail that he'd be gone for 3 weeks. And because you're registered as maintainer of wine-mono and wine-gecko

Feel free to assign back (even if I'd prefer if you'd grab maintainership of wine, too ;-) )
Comment 4 Frank Griffin 2015-07-06 12:27:23 CEST
I didn't see any startup hangs, but I note that the warnings do block the execution of any wine application, so maybe your wine.service conditionally invokes something that causes the warning.  Did systemctl status give any hints ?
Comment 5 Marja Van Waes 2015-08-02 21:23:25 CEST
(In reply to Frank Griffin from comment #4)
> I didn't see any startup hangs, but I note that the warnings do block the
> execution of any wine application, so maybe your wine.service conditionally
> invokes something that causes the warning.  Did systemctl status give any
> hints ?

Oops, never replied. I don't remember :-/

I no longer have that install, reinstalled Mga5 to do a very, very slow, step by step upgrade to cauldron while waiting for neoclust to fix kde4=>plasma5 related conflicts that I come across.
Comment 6 Rémi Verschelde 2016-01-19 11:40:52 CET
Setting as a release blocker so that we don't forget to do this before releasing Mageia 6. Currently at least wine-gecko is out of sync with wine. I think tv had a look at it already but it looks like a tough guy :)

Blocks: (none) => 15527
Priority: Normal => release_blocker

Morgan Leijström 2016-07-14 11:37:41 CEST

CC: (none) => fri

Samuel Verschelde 2016-09-10 00:57:47 CEST

Status comment: (none) => Packages could be dropped if this can't be fixed

Comment 7 David GEIGER 2016-09-24 11:12:31 CEST
Fixed now with:

- wine-1.8.4-2.mga6
- wine-gecko-2.44-2.mga6
- wine-mono-4.6.3-1.mga6

I have no more a pupo-up who says me that MONO and GECKO not found in the system.


Feel free to reopen if needed!

Status: NEW => RESOLVED
CC: (none) => geiger.david68210
Resolution: (none) => FIXED

Samuel Verschelde 2017-01-17 10:29:39 CET

Blocks: 15527 => (none)

Comment 8 Frank Griffin 2021-07-15 04:47:17 CEST
This is back.  Updating wine does not automatically rebuild wine-gecko (at least) and maybe wine-mono as well.

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)

Comment 9 Marja Van Waes 2021-07-21 21:38:15 CEST
(In reply to Frank Griffin from comment #8)
> This is back.  Updating wine does not automatically rebuild wine-gecko (at
> least) and maybe wine-mono as well.

There is no longer a registered maintainer for wine-gecko and wine-mono, so re-assigning to all packagers collectively

However, tv has pushed the last wine updates to cauldron and tmb was the last one to push wine-gecko and wine-mono. They're both in the CC of this report.

Assignee: anssi.hannula => pkg-bugs
CC: (none) => rverschelde, tmb

Comment 10 Frank Griffin 2021-07-22 20:51:35 CEST
I have a vague memory of requesting that these packages be automatically rebuilt when wine was, and tmb saying that they couldn't be because they were in contrib while wine was in release, so this was must have been in the Mandriva days.  Or maybe I'm recalling a different set of packages entirely.

Shouldn't prevent it now, though.

Note You need to log in before you can comment on or make changes to this bug.