Bug 15589 - Install unusable because installer used too little of the available space (after selecting Use the free space on a Microsoft Windows partition)
Summary: Install unusable because installer used too little of the available space (af...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
URL:
Whiteboard: 5RC Errata
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-30 14:50 CEST by André DESMOTTES
Modified: 2015-04-19 02:01 CEST (History)
9 users (show)

See Also:
Source RPM: drakx-installer-stage2
CVE:
Status comment:


Attachments
report.bug.xz (114.71 KB, application/x-xz)
2015-03-30 14:51 CEST, André DESMOTTES
Details
report.bug.xz compressed (189.33 KB, application/gzip)
2015-04-03 11:14 CEST, André DESMOTTES
Details
round of April 8 (114.83 KB, application/gzip)
2015-04-08 14:34 CEST, André DESMOTTES
Details
report.bug (153.44 KB, application/gzip)
2015-04-15 21:21 CEST, André DESMOTTES
Details

Description André DESMOTTES 2015-03-30 14:50:45 CEST
Description of problem:
Mageia-5-RC-x86_64-DVD.iso UEFI on real HW in dual boot with Windows. 
Windows 10 fills the whole disk.
1- At the partition step, message: "Computing the size of the MS Windows partition"
2- Amongst 3 options, I choose: Use the free space on a Microsoft Windows partition
3- Warning about the danger of resizing Windows partition
4- Message: To ensure data integrity after resizing ..... Click on OK
5- Error message: An error occurred. You must have a ESP FAT32 partition mounted in /boot/EFI. Click on OK
6- Back to point 2 above, I choose Custom disk partitioning
7- The ESP sda2 was mounted on /media/win_, I mount it on /boot/EFI
8- The installation go on but it takes only a few minutes and Mageia can't reboot in graphical mode, it seems KDE and KDM are missing. 

I have screnshots of all these step, just ask if wanted.
file report.bug.xz joined with next comment


Reproducible: 

Steps to Reproduce:
Comment 1 André DESMOTTES 2015-03-30 14:51:59 CEST
Created attachment 6161 [details]
report.bug.xz
Comment 2 Marja van Waes 2015-03-31 09:47:24 CEST
(In reply to André DESMOTTES from comment #0)
> Description of problem:
> Mageia-5-RC-x86_64-DVD.iso UEFI on real HW in dual boot with Windows. 
> Windows 10 fills the whole disk.
> 1- At the partition step, message: "Computing the size of the MS Windows
> partition"
> 2- Amongst 3 options, I choose: Use the free space on a Microsoft Windows
> partition
> 3- Warning about the danger of resizing Windows partition
> 4- Message: To ensure data integrity after resizing ..... Click on OK
> 5- Error message: An error occurred. You must have a ESP FAT32 partition
> mounted in /boot/EFI. Click on OK

This should be fixed with new drakx-installer-stage2, that was pushed yesterday

> 6- Back to point 2 above, I choose Custom disk partitioning
> 7- The ESP sda2 was mounted on /media/win_, I mount it on /boot/EFI
should be fixed with new stage2
> 8- The installation go on but it takes only a few minutes and Mageia can't
> reboot in graphical mode, it seems KDE and KDM are missing. 

According to the logs:

* disabling selected packages because too big for level 5: 3541184852 > 3318045403.9042

As you suggested on qa-discuss ml, / was indeed too small.

I'm amazed that when you chose the option to resize a windows partition, that you still got the screen where you could choose a Desktop. Or didn't you?.. I don't know how to see that in the logs :-/ 
If you didn't get the chooseDesktop screen: in the choosePackageGroups screen you can see how much diskspace is required for the selection you make, you can see it at the bottom/left: 

Total size [needed space]/[available space] MB

I had always assumed that it would not be possible to continue if 
[needed space] > [available space]
However, I never tried :-/


> 
> I have screnshots of all these step, just ask if wanted.
> file report.bug.xz joined with next comment
> 
> 
> Reproducible: 
> 
> Steps to Reproduce:

CC: (none) => marja11

Comment 3 André DESMOTTES 2015-03-31 11:04:49 CEST
(In reply to Marja van Waes from comment #2)
> 
> This should be fixed with new drakx-installer-stage2, that was pushed
> yesterday

> should be fixed with new stage2

It was the new drakx-installer-stage2, that was pushed on March 29th


> I'm amazed that when you chose the option to resize a windows partition,
> that you still got the screen where you could choose a Desktop. Or didn't
> you?.. I don't know how to see that in the logs :-/ 

I got the usual screen where we can choose between KDE, Gnome or Custom. I chose KDE
Comment 4 Marja van Waes 2015-03-31 11:51:31 CEST
(In reply to André DESMOTTES from comment #3)
> (In reply to Marja van Waes from comment #2)
> > 
> > This should be fixed with new drakx-installer-stage2, that was pushed
> > yesterday
> 
> > should be fixed with new stage2
> 
> It was the new drakx-installer-stage2, that was pushed on March 29th

Yeah, the iso you used was pushed March 29, and it contained v16.74

[marja@Mga5RC_EFI Downloads]$ xzcat lebarhon_report.bug.xz | grep "DrakX v"
* second stage install running (DrakX v16.74)
[marja@Mga5RC_EFI Downloads]$ 

yesterday's drakx-installer-stage2-16.75-1.mga5 should fix this
> 
> 
> > I'm amazed that when you chose the option to resize a windows partition,
> > that you still got the screen where you could choose a Desktop. Or didn't
> > you?.. I don't know how to see that in the logs :-/ 
> 
> I got the usual screen where we can choose between KDE, Gnome or Custom. I
> chose KDE

It would have been better to either not get that screen at all, but the choosePackageGroups screen.

Since the ESP should now be properly detected and used, I'll keep this bug report for installer continuing when there is too little space to install the chosen desktop

Summary: MGA5RC installer fails to create partitions with the option: Use the free space on a Microsoft Windows partition => Installing KDE or GNOME is offered when there is too little space (after selecting Use the free space on a Microsoft Windows partition)
Source RPM: (none) => drakx-installer-stage2

Marja van Waes 2015-03-31 11:53:30 CEST

Whiteboard: (none) => 5RC

Comment 5 André DESMOTTES 2015-03-31 12:29:54 CEST
(In reply to Marja van Waes from comment #4)


> It would have been better to either not get that screen at all, but the
> choosePackageGroups screen.
> 
> Since the ESP should now be properly detected and used, I'll keep this bug
> report for installer continuing when there is too little space to install
> the chosen desktop

Actually, there was at least 100GB free in the Windows partition. The bug is that the installer should create at least a 12 GB / partition instead of only 4,3 GB.
Comment 6 Marja van Waes 2015-03-31 12:47:36 CEST
(In reply to André DESMOTTES from comment #5)

> 
> Actually, there was at least 100GB free in the Windows partition. The bug is
> that the installer should create at least a 12 GB / partition instead of
> only 4,3 GB.

Does the windows partition contain data that cannot be moved near the end of partition? I wouldn't know how to check that, though... in older versions of Windows you could see that with the defragmentation tool.
Comment 7 André DESMOTTES 2015-03-31 14:38:52 CEST
I don't think so because:
- it is possible with Gparted to downsize the partition of much more
- if I do a second installation choosing again the same option "Use the free space on a Microsoft Windows partition" the installer downsizes again the Windows partition and creates new  partitions of 4,3 GB for / and of 8GB for /home.
Comment 8 Marja van Waes 2015-03-31 14:51:30 CEST
(In reply to André DESMOTTES from comment #5)

> Actually, there was at least 100GB free in the Windows partition. The bug is
> that the installer should create at least a 12 GB / partition instead of
> only 4,3 GB.

(In reply to Marja van Waes from comment #6)
> 
> Does the windows partition contain data that cannot be moved near the end of
> partition? I wouldn't know how to check that, though... in older versions of
> Windows you could see that with the defragmentation tool.

(In reply to André DESMOTTES from comment #7)
> I don't think so because:
> - it is possible with Gparted to downsize the partition of much more
> - if I do a second installation choosing again the same option "Use the free
> space on a Microsoft Windows partition" the installer downsizes again the
> Windows partition and creates new  partitions of 4,3 GB for / and of 8GB for
> /home.

(Now wondering how often you can repeat that... maybe until there is no windows left? ;-) )

Anyway, changing the summary again.

CC'ing tv and pterjan, I do not know which additional information is needed (if any) nor whom of the two to assign to.

CC: (none) => pterjan, thierry.vignaud
Summary: Installing KDE or GNOME is offered when there is too little space (after selecting Use the free space on a Microsoft Windows partition) => installer uses too little of the available space (after selecting Use the free space on a Microsoft Windows partition)

Comment 9 André DESMOTTES 2015-04-02 11:39:52 CEST
Bug still valid with the sixth build dated 1 April.

May be we could take off this option for Mageia 5, it is possible to use "Custom disk partitioning".
Comment 10 Marja van Waes 2015-04-02 11:56:32 CEST
(In reply to André DESMOTTES from comment #9)
> Bug still valid with the sixth build dated 1 April.
> 
> May be we could take off this option for Mageia 5, it is possible to use
> "Custom disk partitioning".

How much of the 100GB available space on the windows partition can you use when selecting "Custom disk partitioning"? I assume it doesn't allow to resize until there is no windows left...  is that true, and does it allow to use e.g. half of the free space... or does it block resizing further than ± -14 GB, too?

Summary: installer uses too little of the available space (after selecting Use the free space on a Microsoft Windows partition) => Install unusable because installer used too little of the available space (after selecting Use the free space on a Microsoft Windows partition)

Comment 11 André DESMOTTES 2015-04-02 12:50:28 CEST
(In reply to Marja van Waes from comment #10)

> How much of the 100GB available space on the windows partition can you use
> when selecting "Custom disk partitioning"? I assume it doesn't allow to
> resize until there is no windows left...  is that true, and does it allow to
> use e.g. half of the free space... or does it block resizing further than ±
> -14 GB, too?

If I use "Custom disk partitioning", and Resize, the installer says: 
Minimum size: 12958 MB

That frees 137 GB! I put the slider to the minimum size, created two partitions for / and /home, mounted sda2 on /boot/EFI and clicked on Done. then the system reboot ! :(

After the reboot, I chose "Custom disk partitioning" again, because with "Use existing partitions" you can't mount the ESP on /boot/EFI.
I mounted partitions on /boot/EFI, / and /home again and the installation went fine.
Comment 12 Marja van Waes 2015-04-02 15:49:37 CEST
(In reply to André DESMOTTES from comment #11)
> (In reply to Marja van Waes from comment #10)

> 
> If I use "Custom disk partitioning", and Resize, the installer says: 
> Minimum size: 12958 MB
> 
> That frees 137 GB! I put the slider to the minimum size, created two
> partitions for / and /home, mounted sda2 on /boot/EFI and clicked on Done.
> then the system reboot ! :(
> 
> After the reboot, I chose "Custom disk partitioning" again, because with
> "Use existing partitions" you can't mount the ESP on /boot/EFI.

Did you try? That should be automatically done, now (the ESP does not appear in the list, but when you continue all goes well),  assuming you used last night's iso 

CC'ing QA, because we don't know yet whether others can reproduce the issue that too little of the available free space is used after selecting "Use the free space on a Microsoft Windows partition"
It would also be good to know whether this issue also exists in non-EFI installs.

CC: (none) => qa-bugs

Comment 13 André DESMOTTES 2015-04-02 17:34:39 CEST
Yes I tried specially.

FYI, I did something else:
1- Installation of Windows on the half of the disk and then Mageia.
The installer doesn't detect the ESP, we have to do it manually and after the installation, Windows boots no more
2- Installation of Windows on the half of the disk, then Ubuntu and then Mageia.
The installer does automatically detect the ESP, add Mageia and the three OSs boot fine.

EFI Installation of Mageia alone or after Ubuntu is never a problem, whatever is done before Ubuntu. Mageia installation after Windows never works.

Ubuntu is unable to downsize a windows partition, the options are similar to "Erase and use the entire disk" and "Custom partitioning" nothing else.
Comment 14 Marja van Waes 2015-04-02 19:07:02 CEST
(In reply to André DESMOTTES from comment #13)

> 
> EFI Installation of Mageia alone or after Ubuntu is never a problem,
> whatever is done before Ubuntu. Mageia installation after Windows never
> works.
> 

IIUC, this is about the correct detection and mounting of the ESP.

Since installer changed, and should be version 16.75 on the iso, can you please attach a new report.bug.xz of the failed installation?
Comment 15 André DESMOTTES 2015-04-03 11:14:41 CEST
Created attachment 6177 [details]
report.bug.xz compressed

New try from today (April 03) with the last Classical DVD
mdkinst.sqfs 16.75

The ESP seems correctly detected and used, the / partition is still too small 4,3GB, Mageia doesn't reboot (indefinitely ask for the user password) but Windows does.
There is real improvement :)
Comment 16 Marja van Waes 2015-04-07 22:42:38 CEST
I wanted to check whether this bug exists in non-efi installs, too, and borrowed my daughter's windows laptop to try, but then saw in the doPartitionDisk screen that the pre-selected space of a windows partition was only the very small free space on the recovery partition.

So that was bug 1371 still valid :-/

I'll try to find another system with a lot of free space on a windows partition, but without a rescue partition
Comment 17 André DESMOTTES 2015-04-08 14:27:13 CEST
Bug still valid with round of April 8.
3.6 GB for /
Comment 18 André DESMOTTES 2015-04-08 14:34:41 CEST
Created attachment 6220 [details]
round of April 8
Comment 19 Marja van Waes 2015-04-09 13:46:24 CEST
Also valid on non-efi systems.

I had wiped at least 80GB of Mageia installs and added that space back to the windows partition.

Then installed and chose to use free windows space. Installer only freed up 9GB.

NOTE:
I do _not_ know what installer did in the past

My report.bug.xz is attachment 6226 [details] to bug 15663 (filed because, without  asking, installer used unused space on another disk, too)
Comment 20 Marja van Waes 2015-04-09 14:10:59 CEST
@ Daniel

Docteam is struggling to understand how diskdrake in installer (mis)behaves.
It seems now, that the option to use free space on a Windows partition can not be trusted, neither for EFI nor for legacy installs.

Is that your experience, too? If so, for both Mageia 4 and Mageia 5 (beta 3)?

We'd like to have helpful documentation that only contains correct instructions.

CC: (none) => contact, doc-bugs

claire robinson 2015-04-09 21:40:24 CEST

CC: (none) => eeeemail, tmb

Rémi Verschelde 2015-04-13 22:39:08 CEST

CC: (none) => rverschelde

Comment 21 André DESMOTTES 2015-04-15 18:48:40 CEST
Bug also valid for Mageia-5-RC-LiveDVD-KDE4-i586-DVD round 8
claire robinson 2015-04-15 18:50:10 CEST

CC: qa-bugs => (none)

Comment 22 Marja van Waes 2015-04-15 18:55:07 CEST
(In reply to André DESMOTTES from comment #21)
> Bug also valid for Mageia-5-RC-LiveDVD-KDE4-i586-DVD round 8

Should be added to the Errata if it doesn't get fixed

CC: (none) => stormi
Whiteboard: 5RC => 5RC Errata

Comment 23 André DESMOTTES 2015-04-15 21:21:21 CEST
Created attachment 6284 [details]
report.bug

Not fixed with Mageia 5RC DVD x86_64 Classical last round (April 15)
report.bug attached
Comment 24 Pascal Terjan 2015-04-16 23:40:15 CEST
"Then installed and chose to use free windows space. Installer only freed up 9GB."

It selects a default size but you can move the cursor.

The code assumes 6GB is enough and doesn't take more than 10% of the windows partition.

(c.f. https://bugs.mageia.org/show_bug.cgi?id=1371#c21)
Comment 25 Pascal Terjan 2015-04-16 23:44:30 CEST
Sorry it was not totally exact.

It suggests 10% of what can be freed, not the total size, and at least 6GB.

So if there are 90GB free, it will suggest 9GB.
Comment 26 Pascal Terjan 2015-04-17 00:23:06 CEST
I committed 2 changes:
- Select the Windows partition with most empty space instead of the one with most space that we won't use
- Suggest at least 20% of the empty space/20GB instead of 10%/6GB
Comment 27 Marja van Waes 2015-04-17 07:53:00 CEST
(In reply to Pascal Terjan from comment #26)
> I committed 2 changes:
> - Select the Windows partition with most empty space instead of the one with
> most space that we won't use
> - Suggest at least 20% of the empty space/20GB instead of 10%/6GB

\o/

Thanks a lot, Pascal :-)
Comment 28 Marja van Waes 2015-04-17 07:58:36 CEST
(In reply to Pascal Terjan from comment #24)
> "Then installed and chose to use free windows space. Installer only freed up
> 9GB."
> 
> It selects a default size but you can move the cursor.
> 

Without choosing "custom partitioning", so in this screen
http://docteam.mageia.nl/en/installer/content/images/dx2-doPartitionDisks.png

Wow, I never saw the three dots between the light blue and dark blue section on the "Use Free Space on a Windows Partition" bar.

We should really add that to installer help for Mageia 6!
Comment 29 André DESMOTTES 2015-04-17 09:57:47 CEST
I never saw them either, I am going to test them.
Comment 30 Pascal Terjan 2015-04-17 10:18:54 CEST
It used to look like this https://farm3.staticflickr.com/2429/4025954643_3de81b40fb_o.png when I created this screen in 2009 

But it seems our theme makes it much less visible :(
Comment 31 Marja van Waes 2015-04-17 10:30:25 CEST
(In reply to Pascal Terjan from comment #30)
> It used to look like this
> https://farm3.staticflickr.com/2429/4025954643_3de81b40fb_o.png when I
> created this screen in 2009 

That was indeed a whole lot clearer!

> 
> But it seems our theme makes it much less visible :(

:-(

Can it be somehow workarounded (for Mageia 6), so that most users will see it again?
Comment 32 Marja van Waes 2015-04-17 10:31:57 CEST
btw, didn't we switch to adwaita for installer recently? maybe it changed again?
Comment 33 Marja van Waes 2015-04-17 10:34:59 CEST
It is even worse now

https://bugs.mageia.org/attachment.cgi?id=6216
Comment 34 Pascal Terjan 2015-04-17 13:16:56 CEST
It's sad I noticed it so late :(

It definitely needs to be fixed
Comment 35 André DESMOTTES 2015-04-17 18:46:23 CEST
No more bug for me, except the invisible 3 dots.
Comment 36 Marja van Waes 2015-04-17 21:01:22 CEST
(In reply to André DESMOTTES from comment #35)
> No more bug for me, except the invisible 3 dots.

Same here... it is perfectly resizable, in spite of that fact being invisible.

I have to move the cursor away to see how many GBs the new size will be, btw, it won't show it when the cursor is still on the division between what'll be left of the windows partition, and the new space for Mageia.

 (In reply to Pascal Terjan from comment #34)
> It's sad I noticed it so late :(

No problem

> 
> It definitely needs to be fixed

I'll file a new bug report for that. Can it be assigned to you?

Closing this one as fixed :-)

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 37 Mageia Robot 2015-04-19 02:01:35 CEST
commit 71c5f17dd864c7783909f75f6e7d5bd9d56ce425
Author: Pascal Terjan <pterjan@...>
Date:   Sat Apr 18 23:58:12 2015 +0000

    use the windows partition with the most available space on current
    +    disk, not the last one across all disks (mga#15589)
---
 Commit Link:
   http://gitweb.mageia.org/software/drakx/commit/?id=71c5f17dd864c7783909f75f6e7d5bd9d56ce425

Note You need to log in before you can comment on or make changes to this bug.