Bug 15176 - mga6 sta2 LXDE screensaver displays GTK message: failed to load module " canberra-gtk-module"
Summary: mga6 sta2 LXDE screensaver displays GTK message: failed to load module " can...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: GNOME maintainers
QA Contact:
URL:
Whiteboard:
Keywords: 6sta2, IN_ERRATA5, IN_ERRATA6, NEEDINFO
Depends on:
Blocks:
 
Reported: 2015-02-01 03:47 CET by ben mcmonagle
Modified: 2019-02-04 23:30 CET (History)
4 users (show)

See Also:
Source RPM: Mageia-5-beta3-x86_64-DVD, Jan 29 18:54:15 CET 2015
CVE:
Status comment: Dup of bug 3536


Attachments

Description ben mcmonagle 2015-02-01 03:47:21 CET
Description of problem:
screensaver displays GTK message: failed to load module " canberra-gtk-module"
in yellow text top left of screen


Version-Release number of selected component (if applicable):
Mageia-5-beta3-x86_64-DVD, Jan 29 18:54:15 CET 2015, LXDE 

How reproducible:


Steps to Reproduce:
1.clean / fresh install of lxde only
2.wait for screen saver to start.
3.1st picture only displays the message top left., return to desktop and wait for screen saver to start again


Reproducible: 

Steps to Reproduce:
Comment 1 Nicolas Salguero 2015-02-12 15:54:26 CET
Hi,

The problem occurs because the package lib64canberra-gtk0 (or libcanberra-gtk0 for i586 arch) is missing.

A dependency on that package have been added to lxappearance which had the same problem so, after updating to lxappearance-0.6.1-2.mga5, the problem should be solved.

Regards,

Nico

CC: (none) => nicolas.salguero

Comment 2 Rémi Verschelde 2015-02-12 18:20:28 CET
This is not the proper fix for this issue, the warning about "canberra-gtk-module" affects all GTK+ applications, so if a dependency should be added, it should be in the main GTK+ library.

See: https://bugs.mageia.org/show_bug.cgi?id=3536

CC: (none) => remi

Comment 3 Nicolas Salguero 2015-02-12 18:35:16 CET
I have reverted my modification of lxappearance.
Comment 4 Nicolas Salguero 2015-05-20 13:22:34 CEST
Currently the problem seems to be over so I close the bug.

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 5 ben mcmonagle 2015-05-21 09:36:32 CEST
valid (today) Mga5Final Dual (64)
Comment 6 Nicolas Salguero 2015-05-21 09:49:20 CEST
I reopen the bug then.  For information, in my tests, the problem does not appear with Mga5Final X86_64 DVD.

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)

Comment 7 Samuel Verschelde 2015-05-21 10:56:53 CEST
I think it happens only in Dual.

Whiteboard: (none) => FOR_ERRATA

Comment 8 Nicolas Salguero 2015-05-21 11:13:07 CEST
I have updated the errata https://wiki.mageia.org/en/Mageia_5_Errata#LXDE concerning this problem so I close the bug.

Status: REOPENED => RESOLVED
Resolution: (none) => FIXED
Whiteboard: FOR_ERRATA => IN_ERRATA

Comment 9 Samuel Verschelde 2015-05-21 11:14:28 CEST
Please don't close the bug. It's in errata but it's still valid and we can try to solve it via a later update and/or for Mageia 6.

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)

Comment 10 Rémi Verschelde 2015-05-21 11:16:57 CEST
Though IMO it should be RESOLVED DUPLICATE of bug 3536... The only difference is that here the warning is visually displayed on the screensaver, which is kind of annoying.
Comment 11 Samuel Verschelde 2015-05-21 11:19:20 CEST
That's why I kept it open actually, because it's visible.
Comment 12 ben mcmonagle 2016-04-02 23:24:37 CEST
still valid for:

Mageia-6-dev1-x86_64-DVD.iso
DATE.txt: Wed Mar 16 23:02:20 CET 2016
ben mcmonagle 2016-04-02 23:29:00 CEST

Whiteboard: IN_ERRATA => IN_ERRATA| mga6-dev1 too

Marja Van Waes 2016-04-05 19:23:50 CEST

Keywords: (none) => 6dev1
CC: (none) => marja11
Whiteboard: IN_ERRATA| mga6-dev1 too => IN_ERRATA

Samuel Verschelde 2016-11-01 12:00:40 CET

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=3536

Samuel Verschelde 2016-11-01 12:01:36 CET

Keywords: (none) => FOR_ERRATA6, IN_ERRATA5
Assignee: bugsquad => gnome
Whiteboard: IN_ERRATA => (none)

Comment 13 Marja Van Waes 2017-03-06 17:25:42 CET
I just added it to the errata, but now I see that the last time it was confirmed valid is a year ago!

Is this issue still valid for last 6sta2?

Keywords: 6dev1, FOR_ERRATA6 => 6sta1.5, IN_ERRATA6, NEEDINFO

Comment 14 ben mcmonagle 2017-03-06 20:11:30 CET
(In reply to Marja van Waes from comment #13)
> I just added it to the errata, but now I see that the last time it was
> confirmed valid is a year ago!
> 
> Is this issue still valid for last 6sta2?

yes, after upgrade from 5.1 to 6 sta2.
Noted it last night, but had not got around to this bug. 
thanks for the prompt
Comment 15 ben mcmonagle 2017-03-12 07:47:01 CET
valid also for a single DE install from Mageia-6-sta2-i586-DVD.iso
DATE.txt: Wed Mar  1 11:09:58 CET 2017

Keywords: 6sta1.5 => 6sta2
Summary: M5B3 LXDE screensaver displays GTK message: failed to load module " canberra-gtk-module" => mga6 sta2 LXDE screensaver displays GTK message: failed to load module " canberra-gtk-module"

Comment 16 Olav Vitters 2017-03-12 14:43:35 CET
If it's up to gnome@ maintainers to decide, then it is a dupe. If you think it's specific to LXDE then assign it to them. In any case, having exactly the same bug assigned to the same assignee isn't helping.

Status comment: (none) => Dup of bug 3536
CC: (none) => olav

Comment 17 Marja Van Waes 2017-06-09 19:42:34 CEST
(In reply to Olav Vitters from comment #16)
> If it's up to gnome@ maintainers to decide, then it is a dupe. If you think
> it's specific to LXDE then assign it to them. In any case, having exactly
> the same bug assigned to the same assignee isn't helping.

I was going to close it as dup of 3536, but then i read this:

(In reply to Rémi Verschelde from comment #10)
> Though IMO it should be RESOLVED DUPLICATE of bug 3536... The only
> difference is that here the warning is visually displayed on the
> screensaver, which is kind of annoying.

(In reply to Samuel Verschelde from comment #11)
> That's why I kept it open actually, because it's visible.
Comment 18 ben mcmonagle 2019-02-04 23:30:10 CET
closing as last comment +12 months ago.
reopen if needed

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.