Bug 14505 - ClamTK does not start if oxygen-gtk is missing
Summary: ClamTK does not start if oxygen-gtk is missing
Status: REOPENED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Jack M
QA Contact:
URL:
Whiteboard: MGA6TOO
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-11 15:30 CET by Moreno Manzini
Modified: 2019-07-18 21:00 CEST (History)
14 users (show)

See Also:
Source RPM: clamtk
CVE:
Status comment:


Attachments

Description Moreno Manzini 2014-11-11 15:30:08 CET
Hi

Installing Camav and clamtk this program do not work correctly, the error is:

Icona �gtk-new� non presente nel tema at /usr/lib/perl5/vendor_perl/5.20.1/ClamTk/GUI.pm line 258.


This is a well know problem https://code.google.com/p/clamtk/issues/detail?id=2
but I can't solve.

I installed some Icon packages with gtk-new but nothing change.


The problem appear with GNOME and KDE4


Bye Bye, Moreno
Comment 1 Moreno Manzini 2014-11-11 15:44:45 CET
Hi

With LXDE, where the icon gtk-new is available in the theme, this problem do not appear but the program fail with on an other icon

Icona �gtk-file� non presente nel tema at /usr/lib/perl5/vendor_perl/5.20.1/ClamTk/GUI.pm line 480.



Bye Bye, Moreno
Comment 2 Moreno Manzini 2014-11-11 15:55:40 CET
Hi

ClamTk work correctly under MATE.


Bye Bye, Moreno
Comment 3 Alex Loginov 2014-11-13 23:09:21 CET
I have an error "Cannot decode string with wide characters at /usr/lib/perl5/5.20.1/i386-linux-thread-multi/Encode.pm line 175." with clamtk-5.07-3.mga5

CC: (none) => loginov_alex
Source RPM: (none) => clamtk

Manuel Hiebel 2014-11-14 22:46:31 CET

Keywords: (none) => Triaged
CC: (none) => ennael1, fundawang, jani.valimaa, luis.daniel.lucio, mageia, thierry.vignaud

Comment 4 Jani Välimaa 2014-11-15 11:22:32 CET
Added a patch to fix deprecated icon names. Please test if it helps.
Comment 5 Moreno Manzini 2014-11-15 17:22:24 CET
Hi

The patch solve only partially the problem.

Now the error with KDE is:
Icona �preferences-desktop� non presente nel tema at /usr/lib/perl5/vendor_perl/5.20.1/ClamTk/GUI.pm line 258.


With GNOME ,LXDE and MATE the error is:
Icona �document-edit� non presente nel tema at /usr/lib/perl5/vendor_perl/5.20.1/ClamTk/GUI.pm line 406.


Bye Bye, Moreno
Comment 6 Jani Välimaa 2014-11-15 20:26:15 CET
I've already modified the patch, but to see the results we'll have to wait until someone freeze pushes clamtk as I also updated it to the latest version.
Comment 7 Alex Loginov 2014-11-17 22:29:21 CET
clamtk-5.07-3.mga5.noarch.rpm works for me.
Many thanks.
Comment 8 Moreno Manzini 2014-11-18 07:14:45 CET
Hi

Perfect, the version clamtk-5.11-1.mga5 work on all DE.

A BIG THANKS!!!!!!!


Bye Bye, Moreno

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 9 Alex Loginov 2014-11-21 20:43:01 CET
clamtk-5.11-1.mga5.noarch does not work in KDE:
[user@localhost ~]$ LC_ALL=C clamtk
Icon 'preferences-system' not present in theme at /usr/lib/perl5/vendor_perl/5.20.1/ClamTk/GUI.pm line 262.

but:

find ./ -name preferences-system.png
./oxygen/128x128/categories/preferences-system.png
./oxygen/16x16/categories/preferences-system.png
./oxygen/22x22/categories/preferences-system.png
./oxygen/256x256/categories/preferences-system.png
./oxygen/32x32/categories/preferences-system.png
./oxygen/48x48/categories/preferences-system.png
./oxygen/64x64/categories/preferences-system.png
./HighContrast/16x16/categories/preferences-system.png
./HighContrast/22x22/categories/preferences-system.png
./HighContrast/24x24/categories/preferences-system.png
./HighContrast/256x256/categories/preferences-system.png
./HighContrast/32x32/categories/preferences-system.png
./HighContrast/48x48/categories/preferences-system.png
./ContrastHighLargePrint/48x48/categories/preferences-system.png
./ContrastHighLargePrintInverse/48x48/categories/preferences-system.png
./mate/16x16/categories/preferences-system.png
./mate/22x22/categories/preferences-system.png
./mate/24x24/categories/preferences-system.png
./mate/256x256/categories/preferences-system.png
./mate/32x32/categories/preferences-system.png
./mate/48x48/categories/preferences-system.png
./Adwaita/16x16/categories/preferences-system.png
./Adwaita/22x22/categories/preferences-system.png
./Adwaita/24x24/categories/preferences-system.png
./Adwaita/256x256/categories/preferences-system.png
./Adwaita/32x32/categories/preferences-system.png
./Adwaita/48x48/categories/preferences-system.png

and I have default oxygen theme.

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)

Comment 10 Moreno Manzini 2014-11-21 21:41:06 CET
Hi

I had the same problem immediately after update but after reboot all work fine.

Bye Bye, Moreno
Comment 11 Alex Loginov 2014-12-18 17:03:00 CET
Jani, hello,
it's regress in clamtk-5.11-1.mga5.noarch, please look again.
Comment 12 Jani Välimaa 2014-12-18 17:43:16 CET
Can't reproduce (but I'm not using KDE).

Oxygen is missing 24x24 icons. However, gtk2 fallbacks to Adwaita icons if some icons aren't found from used theme.
Comment 13 Alex Loginov 2014-12-19 09:08:18 CET
This algorithm does not work in KDE for clamtk and reboot did not help.
So, clamtk is broken for KDE.
Comment 14 Alex Loginov 2014-12-19 09:22:25 CET
Problems with preferences-system.png, network-workgroup.png
Comment 15 Jani Välimaa 2014-12-20 17:30:45 CET
Oxygen doesn't provide 24x24 icons and it's the size hardcoded in clamtk.

You can file an upstream bug againts oxygen to provide missing 24x24 icons and/or against clamtk to not crash if icons aren't found or fallback to another size like 22x22.
Comment 16 Alex Loginov 2015-01-11 23:43:32 CET
It because of nothing requires oxygen-gtk pkg, that's why I see this issue in KDE.
If install oxygen-gtk, then KDE is OK.
Comment 17 Moreno Manzini 2015-01-17 12:15:05 CET
Hi

With a fresh minimal KDE Beta 2 clatmtk work perfectly.

I think we can reclose this bug report.


Bye Bye, Moreno
Comment 18 Alex Loginov 2015-01-17 12:22:35 CET
Hi,Moreno,
Did you test with or without oxygen-gtk?
Comment 19 Moreno Manzini 2015-01-17 12:31:35 CET
Hi

Yes the oxygen-gtk and oxygen-gtk3 packages was automatically installed during the Mageia installation.


Bye Bye, Moreno
Comment 20 Alex Loginov 2015-01-17 12:39:05 CET
Does clamtk work without oxygen-gtk?
If to install with --no-recommends, then nothing requires oxygen-gtk. This bug report is about missing requires for clamtk, not recommends.
Comment 21 Alex Loginov 2015-01-17 13:13:16 CET
If to look at another distros, then OpenMandriva added Requires: oxygen-gtk in distro-kde4-config-OpenMandriva pkg. They understand, that problems will be with GTK applications in KDE without oxygen-gtk. I reported the same issue for engrampa, but we have a lot of GTK applications with the such potential problem.
Comment 22 Moreno Manzini 2015-01-17 14:26:21 CET
Hi

No, removing oxygen-gtk clamtk stop working.

I do not understand the core of the question.
I opened the bug report because clamtk do not work under a lot of DE, now the problem is resolved.

The oxygen-gtk is a very small package (56kb) is not a problem have this package installed by default.


bye bye, Moreno
Samuel Verschelde 2015-05-31 22:06:32 CEST

Summary: ClamTK do not start => ClamTK does not start if oxygen-gtk is missing
Whiteboard: (none) => MGA5TOO

Comment 23 Marja Van Waes 2016-10-16 22:11:38 CEST
(In reply to Alex Loginov from comment #21)
> If to look at another distros, then OpenMandriva added Requires: oxygen-gtk
> in distro-kde4-config-OpenMandriva pkg. They understand, that problems will
> be with GTK applications in KDE without oxygen-gtk. I reported the same
> issue for engrampa, but we have a lot of GTK applications with the such
> potential problem.

Assigning to KDE team.

Or did this already get fixed??

Keywords: Triaged => NEEDINFO
CC: (none) => marja11
Assignee: bugsquad => kde

Comment 24 Nicolas Lécureuil 2017-03-14 18:11:50 CET
up to clamTK maintainer to fix or add the missing deps.

CC: (none) => mageia
Assignee: kde => bugsquad

Rémi Verschelde 2017-03-14 18:25:28 CET

Assignee: bugsquad => shlomif

Comment 25 Fernando Molina 2017-09-29 18:13:32 CEST
Hi,

The same thing happens in mageia 6: clamtk does not work if oxygen-gtk is absent: missing dependence?

CC: (none) => fmolina

Rémi Verschelde 2017-10-25 11:58:59 CEST

Whiteboard: MGA5TOO => MGA5TOO MGA6TOO
Keywords: NEEDINFO => Junior_job

Comment 26 Jack M 2017-10-26 13:16:06 CEST
Working on this, should be easy enough.

CC: (none) => jackal.j
Assignee: shlomif => jackal.j

Comment 27 Jani Välimaa 2017-10-29 08:42:31 CET
IMO requiring oxygen-gtk isn't the right fix for this. It might fix the consequences, but not the real cause.

Why should clamtk require oxygen-gtk when it's clearly not required in other DE's than KDE? clamtk just reveals that there's something wrong or missing from KDE to make GTK apps to work correctly. Should we require oxygen-gtk in every other GTK app which turns out to not work perfectly in KDE without oxygen-gtk? That would be exaggerated. The fix should be only in one place.
Comment 28 Jack M 2017-10-29 09:01:01 CET
Well, that didn't strike me as a possibility at all. Looking at the packages in question (clamtk, oxygen-gtk), it does seem like kde should be bundled with oxygen-gtk by default (which it seems to be, but wasn't before), and testing through removal of these default packages seems like the wrong way to go.
Comment 29 Jani Välimaa 2017-10-29 09:31:30 CET
And IMO it's better to install oxygen-gtk to systems that needs or might need it (KDE) than systems that doesn't need it (GTK based).
Comment 30 Rémi Verschelde 2017-11-08 16:13:28 CET
No, the bug is that clamtk (or *some* GTK applications) would require oxygen-gtk in the first place. It's obsolete and no longer the theme used for GTK+ apps on KDE (where we use the default Adwaita theme, if not overridden by the user).
Comment 31 Jani Välimaa 2017-11-08 17:58:47 CET
Well, the thing is that clamtk _doesn't_ require oxygen-gtk.

I just installed fresh mga6 with plasma5 and I don't see any problems with clamtk startup. It starts fine without oxygen-gtk.

I guess I'll have to install mga5 also to see where's the problem if there's any.
Comment 32 Fernando Molina 2017-11-08 18:36:48 CET
Strange ...

When I first installed ClamTK on Mga 6 (not quite fresh), it didn't work until I installed oxygen-gtk (which carried some dependencies, don't remember which). Now, after Jani's message, I uninstalled oxygen-gtk-1.4.6-3.mga6.x86_64 and lib64oxygen-gtk-1.4.6-3.mga6.x86_64, and ClamTK still works, only that it takes about 30-40 s to start. Launching from konsole, I got this message:

Gtk-Message **: Failed to load module "canberra-gtk-module" at /usr/lib/perl5/vendor_perl/5.22.2/x86_64-linux-thread-multi/Gtk2.pm line 126.

Not sure what means, but after a while clamtk stars, in fact it is working right now.

May be I will try a fresh install when a get some time.
Comment 33 Jani Välimaa 2017-11-08 19:10:35 CET
Did also a fresh mga5 KDE4 (net)install and can't see any issues with clamtk after removing oxygen-gtk pkgs.
Comment 34 David Walser 2017-12-31 20:34:33 CET
Removing Mageia 5 from the scope for this bug; it's too late.

Whiteboard: MGA5TOO MGA6TOO => MGA6TOO
Keywords: Junior_job => (none)

Comment 35 rexy 2018-05-29 09:36:02 CEST
Ok for me. Clamtk 5.20.3.1 (mga6 core/updates_testing) works fine in mga6 (kde) even if oxygen-gtk is not installed.
I think, this dependency should be removed.
I think, update to the last stable 5.25 should be done for mga6 (like in cauldron).

CC: (none) => richard

Comment 36 marc fanjoux 2019-06-27 17:16:44 CEST
Hello
New installation of M7 rc .

Clamav 0.103 is installed it launches well in console
Clamtk 6.01 installed via the ccm does not start:

[marco@localhost ~]$ uname -r
5.1.5-desktop-1.mga7

[marco@localhost ~]$ clamtk
Wide character in subroutine entry at /usr/lib64/perl5/vendor_perl/Glib/Object/Introspection.pm line 67.
The "gtk-new" icon is not present in the oxygen at /usr/lib64/perl5/vendor_perl/Glib/Object/Introspection.pm line 67 theme.

CC: (none) => marcounet

Comment 37 marc fanjoux 2019-06-28 17:57:56 CEST
it is ok on Mageia 6.1 nok on mageia 7 rc !
Comment 38 Jani Välimaa 2019-06-29 10:06:48 CEST
(In reply to marc fanjoux from comment #36)
> Hello
> New installation of M7 rc .
> 
> Clamav 0.103 is installed it launches well in console
> Clamtk 6.01 installed via the ccm does not start:
> 
> [marco@localhost ~]$ uname -r
> 5.1.5-desktop-1.mga7
> 
> [marco@localhost ~]$ clamtk
> Wide character in subroutine entry at
> /usr/lib64/perl5/vendor_perl/Glib/Object/Introspection.pm line 67.
> The "gtk-new" icon is not present in the oxygen at
> /usr/lib64/perl5/vendor_perl/Glib/Object/Introspection.pm line 67 theme.

It's because deprecated icon fix patch was incorrectly dropped when updating to version 6.00 [1].

I will push it back when SVN reopens after mga7 is released. I have restored and rediffed it locally already.

[1] http://svnweb.mageia.org/packages?view=revision&revision=1377645
Comment 39 Jani Välimaa 2019-06-29 16:23:08 CEST
clamtk-6.01-1.1.mga7 is now in core/updates_testing for mga7.

I tried to use icons which are available in most of the themes, but please test with different icon themes and report if it doesn't work with some theme.
Comment 40 Jani Välimaa 2019-06-29 22:10:39 CEST
Updated patch and pushed clamtk-6.01-1.2.mga7 to core/udpates_testing for mga7.
Comment 41 marc fanjoux 2019-06-30 05:08:12 CEST
it is ok with clamtk-6.01-1.2.mga7

Thank you !
Comment 42 Phil Jones 2019-07-18 20:44:02 CEST
I tried clamtk-6.01-1.2.mga7 from core/updates_testing and it started o/k but I have had several random hangups doing various things. The only way I have to get out of the lookup is to log out and back in. Is the there any log information that could help?

CC: (none) => philip-h-jones

Comment 43 Phil Jones 2019-07-18 21:00:15 CEST
I have since found that when I have a hung version of clamtk that I can start another version but that also hangs up though it appears it doing a virus scan i.e disc activity.

Note You need to log in before you can comment on or make changes to this bug.