Bug 14463 - open JPG, PNG impossible in okular
Summary: open JPG, PNG impossible in okular
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 4
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA4-64-OK MGA4-32-OK advisory
Keywords: validated_update
Depends on:
Reported: 2014-11-05 13:33 CET by thierry rouillon
Modified: 2014-11-21 13:45 CET (History)
8 users (show)

See Also:
Source RPM: okular-4.12.5-1.mga4.src.rpm
Status comment:


Description thierry rouillon 2014-11-05 13:33:58 CET
Description of problem:
Impossible open a file JPG ou PNG with okular

Version-Release number of selected component (if applicable):
Okular Version 0.18.5  in KDE 4.12.5

How reproducible:

Choose a file exemple.jpg in your dolphin. 
Open with okular

The file open crash immediately


Steps to Reproduce:
Rémi Verschelde 2014-11-05 18:02:48 CET

CC: (none) => mageia, remi
Hardware: i586 => All
Assignee: bugsquad => lmenut

Comment 1 Luc Menut 2014-11-05 23:13:50 CET
Thanks for the bug report.
This should be fixed with okular-4.12.5-1.1.mga4 in core/updates_testing.
Please, could you try to update to
They should be available soon on mirrors.

Source RPM: (none) => okular-4.12.5-1.mga4.src.rpm

Comment 2 Olivier Delaune 2014-11-06 20:24:21 CET
Fixed here on Mageia 4 64-bits. To precise the first post, okular did not crash when it tries to open a jpg file, it just said that it could not open that file. After updating okular packages, the jpg pictures are well displayed.

CC: (none) => olivier.delaune

Comment 3 David GEIGER 2014-11-07 07:42:19 CET
Tested mga4_64,

I can reproduce this bug and I can confirm that with okular-4.12.5-1.1.mga4 it is now fixed.

Before :

Impossible to open an image with okular (.jpg or .png).

After :

Now it is possible, okular can open an image (.jpg or .png).

CC: (none) => geiger.david68210

Comment 4 Luc Menut 2014-11-17 00:39:05 CET

packages for i586:

packages for x86_64:

Assignee: lmenut => qa-bugs

Comment 5 user7 2014-11-17 16:10:08 CET
Luc: I tried to test this under Mga4, i586. As soon as I select okular 4.12.5-1.1.mga4 in rpmdrake, it tries to pull in a new dependency: libqmobipocket1-4.12.5-1.mga4.i586

Is this intentional?

CC: (none) => wassi

David GEIGER 2014-11-18 20:16:44 CET

Whiteboard: (none) => MGA4-64-OK

Comment 6 David Walser 2014-11-18 21:10:16 CET
Looks like this one still needs an advisory written.
Comment 7 José Jorge 2014-11-18 22:20:49 CET
Tested OK on MGA4_i586

CC: (none) => lists.jjorge
Whiteboard: MGA4-64-OK => MGA4-64-OK MGA4-32-OK

Comment 8 Luc Menut 2014-11-18 23:10:25 CET
(In reply to user7 from comment #5)
> Luc: I tried to test this under Mga4, i586. As soon as I select okular
> 4.12.5-1.1.mga4 in rpmdrake, it tries to pull in a new dependency:
> libqmobipocket1-4.12.5-1.mga4.i586
> Is this intentional?

yes, it restores support for mobipocket files.

CC: (none) => lmenut

Comment 9 Luc Menut 2014-11-18 23:22:45 CET
Suggested advisory:

Support for various image formats and mobipocket is missing in okular 4.12.5-1 packages.
This update restores reading various image formats (jpg, png, ...) and mobipocket files.

Comment 10 David Walser 2014-11-19 00:39:04 CET
Thanks Luc!

Validating this now.  Advisory in comment 9, package list in Comment 4.

Could someone please upload the advisory?

Sysadmins, once the advisory is uploaded, please push this to core/updates_testing.  Thanks.

Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Comment 11 Rémi Verschelde 2014-11-19 13:22:10 CET
Advisory uploaded.

Whiteboard: MGA4-64-OK MGA4-32-OK => MGA4-64-OK MGA4-32-OK advisory

Comment 12 Mageia Robot 2014-11-21 13:45:10 CET
An update for this issue has been pushed to Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.