Bug 144 - Complete freeze with Atheros wifi
Summary: Complete freeze with Atheros wifi
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: i586 Linux
Priority: Normal major
Target Milestone: ---
Assignee: Thomas Backlund
QA Contact:
Depends on:
Reported: 2011-02-20 23:22 CET by Anne Nicolas
Modified: 2011-10-29 12:11 CEST (History)
4 users (show)

See Also:
Source RPM: kernel
Status comment:


Description Anne Nicolas 2011-02-20 23:22:58 CET
I'm using Mageia up to date on a Compaq 311 netbook including Atheros wifi

ath9k: Atheros Communications Inc.|AR9285 Wireless Network Adapter (PCI-Express) [NETWORK_OTHER] (rev: 01)

Since first install of Mageia, system just freezes when wifi is up. Nothing specific in logs. I tried also panic=1 without any success.

Installing Mandriva 2010.2 kernel kernel-desktop586- just solved the problem.
Comment 2 Arnaud Patard 2011-02-21 16:19:08 CET
To add more info :
- I'm not sure if 2.6.37 is affected by the bug solved by commit 931299cf87701962ea1811dc216f48f3f7a4ebc8
- the other commit and some other ath9k related fixes are in so next step would be imho to try

CC: (none) => arnaud.patard

Comment 3 Thomas Backlund 2011-02-23 00:41:01 CET
If I read it correctly...

The first commit is in 2.6.37 as of v2.6.37-rc1-687-g931299c

The second one is not in

I'll check it better on the weekend when I release
Comment 4 Thomas Backlund 2011-02-26 14:38:07 CET is now available on the mirrors, please test.
Thomas Backlund 2011-02-26 14:39:03 CET

Keywords: (none) => NEEDINFO

Comment 5 Thomas Backlund 2011-02-27 13:16:17 CET
Oh, and there is a thread on ath9k-devel ml about ath9k being broken for some ath9k cards (iirc including some ATH9285) since 2.6.35, but no resolution yet :(
Comment 6 Anne Nicolas 2011-02-27 14:03:59 CET
Looks like it's much better for now. I just updated kernel and boot on it:

Linux tellure #1 SMP Sat Feb 26 01:38:11 UTC 2011 i686 i686 i386 GNU/Linux

And for now I'm using wifi without any pb
Comment 7 Anne Nicolas 2011-02-27 17:40:54 CET
After 2 reboots, I'm having  freezes again :(.
Comment 8 Thomas Backlund 2011-03-20 18:54:41 CET
Does kernel-2.6.38 work better ?
Comment 9 Anne Nicolas 2011-03-20 20:58:40 CET
Just updated and same freeze again
Comment 10 Thomas Backlund 2011-03-20 23:01:09 CET
A debug-enabled kernel is now at:

rename old logs, restart syslog and load the wireless module with: modprobe ath9k debug=0xfffffffff and after the lockup attach the logs
Comment 11 You-Cheng Hsieh 2011-04-27 06:07:59 CEST
Hello, freeze with kernel-desktop- Will you build new debug-enabled kernel, or should I use the kernel-desktop-2.6.38-1.2.mga-1-1.mga1.i586.rpm from above link to debug?

CC: (none) => yochenhsieh

Comment 12 Ahmad Samir 2011-05-27 02:10:16 CEST
Still valid?
Comment 13 You-Cheng Hsieh 2011-05-27 04:17:56 CEST
I don't have a working wifi AP to make a successful connection now. I'll ask in mailing list if any one could reproduce this bug.
Comment 14 Wolfgang Bornath 2011-05-27 05:05:11 CEST
Current Mageia (RC + updates), x86_64
wifi: AR9285
module: ath9k

Been using this all day long yesterday with heavy web usage. No freezes and/or other problems.

CC: (none) => molch.b

Comment 15 You-Cheng Hsieh 2011-05-27 05:09:46 CEST
Wobo, could you please test it on i586 installation(if you have)?
Comment 16 Anne Nicolas 2011-05-27 08:00:37 CEST
still valid
Comment 17 Thomas Backlund 2011-06-09 09:27:55 CEST
Just a small status update...

Seems atheros guys have finally found the breakage, so hopefully they will have a fix soon
Comment 18 Anne Nicolas 2011-06-09 09:36:49 CEST
good news indeed. thanks for the notice
Comment 19 Thomas Backlund 2011-06-12 16:25:38 CEST
Can you test kernel- from:


This contains a patch that reverts / disables the code that seems to break ath9k for some users...
Comment 20 Anne Nicolas 2011-06-12 20:16:06 CEST
Writting this answer using test kernel. All is working nicely for now. Thanks ! :)
Comment 21 Thomas Backlund 2011-06-12 20:25:16 CEST
(In reply to comment #20)
> Writting this answer using test kernel. All is working nicely for now. Thanks !
> :)

can you also give the exact model of your laptop and output of dmidecode so upstream can get better reference of hardwares that break.
Manuel Hiebel 2011-07-27 18:14:13 CEST

Keywords: NEEDINFO => (none)
Source RPM: (none) => kernel

Comment 22 Thomas Backlund 2011-09-01 22:24:24 CEST
Closing as its fixed both in Mageia 1 and Cauldron

Resolution: (none) => FIXED

Comment 23 Kristoffer Grundström 2011-10-29 12:11:48 CEST
This doesn't work for x86_64.

CC: (none) => kristoffer.grundstrom1983

Note You need to log in before you can comment on or make changes to this bug.