Bug 14114 - netprofile package alone is not sufficient to be useful
Summary: netprofile package alone is not sufficient to be useful
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: Release (media or process) (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: Mageia 6
Assignee: ISO building group
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-17 18:58 CEST by krisprolfs
Modified: 2017-07-11 18:53 CEST (History)
4 users (show)

See Also:
Source RPM: netprofile
CVE:
Status comment:


Attachments

Description krisprolfs 2014-09-17 18:58:28 CEST
Description of problem:
On default installation, to have different network profiles, there is a only one package : netprofile. It's not enough !
To have whole fonctionnality (different IP-addresses, masks, DNS saved on each profiles), we need an other package : netprofile-plugin-network.

Is it possible to bind to each other this two packages by a mutual dependence, to have the both packages installed by default ?

Version-Release number of selected component (if applicable):
Mageia 3 & 4


Reproducible: 

Steps to Reproduce:
krisprolfs 2014-09-18 00:06:27 CEST

Summary: package netprofile alone is not sufficient to be useful => netprofile package alone is not sufficient to be useful

Manuel Hiebel 2014-09-21 15:27:54 CEST

Keywords: (none) => Junior_job
Source RPM: (none) => netprofile

Comment 1 David Walser 2014-10-08 01:03:59 CEST
netprofile suggests netprofile-plugin-network, as well as some other things, so in normal circumstances, they will get installed together.

Resolution: (none) => INVALID
Status: NEW => RESOLVED

Comment 2 Manuel Hiebel 2014-10-08 09:53:20 CEST
ah yes, svnweb doesn't have syntax
Comment 3 Florian Hubold 2015-10-09 12:49:58 CEST
(In reply to David Walser from comment #1)
> netprofile suggests netprofile-plugin-network, as well as some other things,
> so in normal circumstances, they will get installed together.

Installer doesn't use suggests, so the OP is right - in a default install, one will only end up with netprofile and none of the plugins, just verified that on a clean mga5 install from free dvd.

Version: 4 => 5
Keywords: Junior_job => (none)
Status: RESOLVED => REOPENED
CC: (none) => doktor5000
Resolution: INVALID => (none)

Comment 4 Thomas Backlund 2015-10-10 10:13:26 CEST
áºell, technically installer does use suggests/recommends.

But since they are not on the installer iso they are not installed

Version: 5 => Cauldron
CC: (none) => sysadmin-bugs, tmb
Component: RPM Packages => Release (media or process)
Hardware: x86_64 => All
Target Milestone: --- => Mageia 6

Comment 5 Samuel Verschelde 2016-10-10 23:10:14 CEST
Assigning to the Iso Builders group so that adding netprofile-plugin-network to the classical ISOs is considered.

Assignee: bugsquad => isobuild
Status: REOPENED => NEW

Comment 6 Samuel Verschelde 2017-07-10 15:26:55 CEST
ISO builders, has netprofil-plugin-network been added to classical ISOs?
Comment 7 Anne Nicolas 2017-07-10 16:53:59 CEST
I've missed that one sorry. Package added in next isos

CC: (none) => ennael1

Comment 8 Rémi Verschelde 2017-07-10 21:02:38 CEST
Did we consider that maybe this "recommends" should be a "requires"?
Comment 9 Anne Nicolas 2017-07-11 18:53:23 CEST
Missing package has been added in bcd list for now

Note You need to log in before you can comment on or make changes to this bug.