Bug 13080 - Add the new Intel P-State option for the Linux kernel
: Add the new Intel P-State option for the Linux kernel
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 4
: All Linux
: Normal Severity: normal
: ---
Assigned To: Thomas Backlund
:
: http://www.phoronix.com/scan.php?page...
:
: Triaged
:
:
  Show dependency treegraph
 
Reported: 2014-03-24 18:46 CET by Pepe Perez
Modified: 2014-04-27 10:26 CEST (History)
3 users (show)

See Also:
Source RPM: kernel
CVE:
Status comment:


Attachments

Description Pepe Perez 2014-03-24 18:46:23 CET
Description of problem:

In Mageia, the driver for Cpupower is acpi-cpufrec for an Intel processor, but for Sandy Bridge, Ivy Bridge and Haswell processors, the driver should be intel_pstate. 

The acpi-cpufrec driver is obsolete, the new driver is intel_pstate.



Version-Release number of selected component (if applicable):

All Kernel-desktop of all versions of mageia (Mageia 3, 4 and Cauldron)



Thanks.

Reproducible: 

Steps to Reproduce:
Comment 1 Thomas Backlund 2014-04-21 21:23:53 CEST
Indeed. I have forgotten to enable it again since I disabled it due to some painful bugs in earlier kernels
Comment 2 Thomas Backlund 2014-04-24 16:06:24 CEST
Fixed in 3.12.18 currently building
Comment 3 Pepe Perez 2014-04-27 10:26:59 CEST
Tested and work fine.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.