Bug 12549 - Can not install Mageia from DVD, but good from USB flash
: Can not install Mageia from DVD, but good from USB flash
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: Installer
: 4
: All Linux
: Normal Severity: critical
: ---
Assigned To: Thierry Vignaud
:
:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-02-03 11:31 CET by Alex Loginov
Modified: 2014-06-29 13:40 CEST (History)
22 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Alex Loginov 2014-02-03 11:31:38 CET
Description of problem: Many uses can not install Mageia from DVD, but good from USB flash.
No problem with Mageia 2 and 3 before. This bug is for i586 and x86_64.

"ISOLINUX 6.02 Mageia ETCDisolinux:Disk error 01, AX=42D1, drive FE"


Version-Release number of selected component (if applicable): Mageia 4


How reproducible: 50% users


Steps to Reproduce:
1. install Mageia 4 from DVD
2. hangs

Workaround: disable AHCI


Reproducible: 

Steps to Reproduce:
Comment 1 Thomas Backlund 2014-02-03 16:34:51 CET
Well, disabling AHCI is _not_ an option.
Comment 2 Raphaël Vinet 2014-02-04 10:31:11 CET
Hi,


Same kind of problem here (DVD x86_64). Same kind but not exactly

Boot with the DVD. After some seconds a line line is displayed 
"ISOLINUX 6.02 Mageia ETCD copyright (c) 1994-2013 H.Peter Anvin et Al"

==> it stops here, no error, no strange things on screen, ... just the mentionned lined and nothing else

Rmk:
Updating M3 to M4 with command line is not better ... emergency mode on boot (I am very lucky :p) but it is another story. I would like a good iso dvd ;)
Comment 3 John ten Wolde 2014-02-07 01:29:47 CET
This seems to be a known issue upstream.  It effects older motherboards.  See this discussion:

http://www.marshut.com/ihnmrv/sysinux-6-will-not-boot-isos-on-bios-i-e-pre-uefi-systems.html

Here are my experiences on 3 machines using the Mageia-4-dual-DVD.iso burned to DVD (with K3B) and written to USB stick (via isodumper).  NB: this is the *same* DVD and USB stick in all three cases.

1. i586 Intel D865PERL (ca. 2004)
    * USB stick halts on boot with "isolinux.bin missing or corrupt"
    * DVD boot/install successful!

2. x86_64 HP Pavilion dv7 notebook (ca. 2007)
    * USB stick boot/install successful!
    * DVD halts on boot with "ISOLINUX 6.02 Mageia ETCD isolinux: Disk error 01, AX = 4275, drive FE"

3. x86_64 Toshiba Satellite L300D notebook (ca. 2008)
    * USB stick boots successfully.
    * DVD boots successfully.

I won't have a chance to do the install on machine #3 for a few days, but at this point just that it recognizes *both* media is nothing short of amazing.
Comment 4 Marcello Anni 2014-02-07 16:44:19 CET
any news to fix (or workaround) this issue? many users are complaining about it, if they didn't manage to install our distro all the great work all the mageia guys have done is unuseful :-(


cheers,
Marcello
Comment 5 Erwan VELU 2014-02-07 16:49:10 CET
I shall spend some time on it. I have to reproduce it and looks what is broken in syslinux.

If a fix is found it will surely means making the ISO again.
Comment 6 Thomas Backlund 2014-02-07 16:49:48 CET
well, the workaround is to install from usb isn't it ?
Comment 7 Erwan VELU 2014-02-07 16:54:24 CET
That's one but on some host USB booting will not work. So we shall be in position to make a successful DVD booting.

Can you check that it was working fine on MGA3 ?
Comment 8 Erwan VELU 2014-02-07 17:07:09 CET
Some says that http://git.zytor.com/?p=syslinux/syslinux.git;a=commit;h=870b84dd8714ddfccc9288025331423efa6d76b7 shall fix it. So 6.0.3-* should make the job.
Comment 9 Bob Walker 2014-02-11 07:33:14 CET
The same happens for my HP DV5T - X86_64
"ISOLINUX 6.02 Mageia ETCDisolinux:Disk error 01, AX=42D1, drive FE"

Any fix yet?
Comment 10 Pierre Jarillon 2014-02-11 11:33:44 CET
DVD or CI was upgrading mga3 to mg4 when the power fails. Bad luck... As it was impossible to boot again on the session. I tried to boot on a DVD : 
After some seconds a line line is displayed as a glance "ISOLINUX 6.02 Mageia..." and the PC reboots. I have burned another DVD and had no more success.
Other CD and DVD of Mageia 3 can boot without any problem.
Comment 11 Thomas Backlund 2014-02-12 16:59:18 CET
I will release a test boot.iso later tonight so you can test if that works for you...
Comment 12 Thomas Backlund 2014-02-12 22:46:06 CET
Test isos available at:
http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/12549/
Comment 13 Bob Walker 2014-02-13 00:38:12 CET
(In reply to Thomas Backlund from comment #12)
> Test isos available at:
> http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/
> 12549/

Made DVD's for both. Verified md5sums.
Results for HP DV5T laptop

boot.iso and boot-nonfree.iso:

Bios displays the following prompt:
0. No Emulation    System Type: 00
1. No Emulation    System Type: 00

Continued to try to install. Got to the install/rescue text-mode display. Selected from the install source menu - selected CDrom. The system could not find the CDrom.

Both iso's behaved the same.
Comment 14 Norman Carver 2014-02-13 00:42:19 CET
I have also had no luck getting Mageia-4-x86_64-DVD.iso disc to boot on multiple Dell Precision workstations.  I briefly see the isolinux message flash, then goes to black screen and BIOS restarts--over and over.

Downloaded/burned boot-nonfree.iso and it boots fine, and was able to then start MGA4 installation from Mageia-4-x86_64-DVD disc on second cdrom drive by selecting cdrom option.

Hope this information is helpful.  Let me know if you want any further testing.
Comment 15 Thomas Backlund 2014-02-13 00:54:09 CET
(In reply to Bob Walker from comment #13)
> (In reply to Thomas Backlund from comment #12)
> > Test isos available at:
> > http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/
> > 12549/
> 
> Made DVD's for both. Verified md5sums.
> Results for HP DV5T laptop
> 
> boot.iso and boot-nonfree.iso:
> 
> Bios displays the following prompt:
> 0. No Emulation    System Type: 00
> 1. No Emulation    System Type: 00
> 
> Continued to try to install. Got to the install/rescue text-mode display.
> Selected from the install source menu - selected CDrom. The system could not
> find the CDrom.
>


Here , when you get to the selection screen, but before you select the cdrom and let it continue, you should be able to swap dvds so you get the install dvd in, and wait a little while until the optical drive has detected the new iso, it should be able to continue the install...

> Both iso's behaved the same.

And if you use the original release boot isos:
http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/4/x86_64/install/images/

I assume you hit the error in comment 9 ?
Comment 16 Thomas Backlund 2014-02-13 00:56:42 CET
(In reply to Norman Carver from comment #14)
> I have also had no luck getting Mageia-4-x86_64-DVD.iso disc to boot on
> multiple Dell Precision workstations.  I briefly see the isolinux message
> flash, then goes to black screen and BIOS restarts--over and over.
> 
> Downloaded/burned boot-nonfree.iso and it boots fine, and was able to then
> start MGA4 installation from Mageia-4-x86_64-DVD disc on second cdrom drive
> by selecting cdrom option.
> 

This sounds like a great improvement :)

> Hope this information is helpful.  Let me know if you want any further
> testing.

If you test the original release boot-nonfree.iso at:

http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/4/x86_64/install/images/

does it too get you the black screen / BIOS reboot ?

(just to confirm the boot*.iso actually triggers the same issue as the DVDs)
Comment 17 Norman Carver 2014-02-13 04:43:54 CET
I was surprised to find this, but the Dell Precision desktop that I have at home boots just fine from the Mageia-4-x86_64-DVD.iso disc (and the original boot-nonfree.iso disc).  This machine is virtually identical to the couple I tried at work that did not boot from the DVD (they are all Dell Precision T3400's).

Anyway, when I get to work tomorrow I will try the experiment with the old boot-nonfree.iso on my office machine that won't boot from the install DVD.  Unfortunately that will not be until noon central time US.

In the meantime, I used dmidecode to compare the BIOS's on the two machines since I have SSH access to my office machine.  The machine at home that can boot is running newer BIOS version A08 while the office machine that won't is running A04, so that is likely the cause of the different behaviors.
Comment 18 Bob Walker 2014-02-13 07:54:37 CET
(In reply to Thomas Backlund from comment #15)
> (In reply to Bob Walker from comment #13)
> > (In reply to Thomas Backlund from comment #12)
> > > Test isos available at:
> > > http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/
> > > 12549/
> > 
> > Made DVD's for both. Verified md5sums.
> > Results for HP DV5T laptop
> > 
> > boot.iso and boot-nonfree.iso:
> > 
> > Bios displays the following prompt:
> > 0. No Emulation    System Type: 00
> > 1. No Emulation    System Type: 00
> > 
> > Continued to try to install. Got to the install/rescue text-mode display.
> > Selected from the install source menu - selected CDrom. The system could not
> > find the CDrom.
> >
> 
> 
> Here , when you get to the selection screen, but before you select the cdrom
> and let it continue, you should be able to swap dvds so you get the install
> dvd in, and wait a little while until the optical drive has detected the new
> iso, it should be able to continue the install...
> 
> > Both iso's behaved the same.
> 
> And if you use the original release boot isos:
> http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/4/x86_64/
> install/images/
> 
> I assume you hit the error in comment 9 ?

Yes. When I booted with the boot.iso image, I had the usual issue with the bios display. I selected 0, which took me to the selection screen. I swapped the DVD with the Mageia 4 release and it booted, though it took a while for the DVD to respond. I checked again with the boot-nonfree.iso - same thing, except that when the Mageia 4 DVD was inserted, the read of the DVD timed out. I hit retry and, this time, the DVD was correctly read, which took me to the install screen.

Hope this helps. If you need more testing, let me know.

Thanks for your help.
Comment 19 Pierre Jarillon 2014-02-13 12:13:02 CET
(In reply to Thomas Backlund from comment #12)
> Test isos available at:
> http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/
> 12549/

I have burned boo-nonfree.iso on a CD.
It boot in text mode allowing a choice betweem ftp, nfs, CD,... I stopped there.
The test were made on the PC unable to boot the DVD (reboot in loop).

IMO, you have found! Congratulations for this and all the job you did.
Comment 20 Norman Carver 2014-02-13 19:26:12 CET
(In reply to Thomas Backlund from comment #16)
> (In reply to Norman Carver from comment #14)
> > Hope this information is helpful.  Let me know if you want any further
> > testing.
> 
> If you test the original release boot-nonfree.iso at:
> 
> http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/4/x86_64/
> install/images/
> 
> does it too get you the black screen / BIOS reboot ?
> 
> (just to confirm the boot*.iso actually triggers the same issue as the DVDs)

So I can now confirm that indeed the original boot-nonfree.iso has the same problem as the install DVDs on the machines that cannot boot from the Mageia 4 install DVDs.  Since the new boot-nonfree.iso works fine, the fix that was applied seems likely to also fix the install DVDs!

However, it seems likely that the problem is due to BIOS bugs since version A04 machines do not boot, but an A08 machine does, and latest BIOS is actually A11.  I will be shortly updating the BIOS version on one A04 machine that is having booting problems and will report back.

Thanks for good and fast work on this!
Comment 21 Norman Carver 2014-02-13 21:46:41 CET
Just to followup...Updating BIOS on a Dell Precision machine that would not boot the Mageia 4 install DVDs did fix the problem.
Comment 22 Thomas Backlund 2014-02-13 23:13:31 CET
Thanks for your tests... 

We will rebuild the isos including all updates released since Mga4 release...

The rebuild will be done next week so we can get some of the still pending fixes icluded, most imprtantly the one (pkcs11) that makes apps crash or hang with nvidia drivers....

I will post here again when there are isos ready for test...
Comment 23 Thomas Backlund 2014-02-18 23:47:18 CET
As promised there is now an i586 classic DVD and one x86_64 currently being mirrored out:

http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/12549/DVD-test/

(or matching path on any other mageia mirror, depending on their update frequency)

Not, theese are not the final isos, we are still fixing some stuff, but with theese you should be able to confirm that the fix works (or not) on full DVD images

Please report here about how they work...
Comment 24 Bob Walker 2014-02-19 03:54:55 CET
(In reply to Thomas Backlund from comment #23)
> As promised there is now an i586 classic DVD and one x86_64 currently being
> mirrored out:
> 
> http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/
> 12549/DVD-test/
> 
> (or matching path on any other mageia mirror, depending on their update
> frequency)
> 
> Not, theese are not the final isos, we are still fixing some stuff, but with
> theese you should be able to confirm that the fix works (or not) on full DVD
> images
> 
> Please report here about how they work...

HP DV5T - DVD spins, slows down, spins, slows down, etc
Message: ISOLinux 6.02 Mageia ETCDisolinux: Disk error 01, AX=42D2, drive FE

Does not work. 

description: Notebook
product: HP Pavilion dv5 Notebook PC (KQ571AV)
vendor: Hewlett-Packard
version: Rev 1
width: 64 bits
capabilities: smbios-2.4 dmi-2.4 vsyscall32
configuration: boot=normal chassis=notebook family=103C_5335KV sku=KQ571AV 
description: BIOS
vendor: Hewlett-Packard
physical id: 0
version: F.21
date: 08/20/2009
size: 1MiB
capabilities: pci upgrade shadowing cdboot bootselect socketedrom edd   int13floppynec int13floppytoshiba int13floppy360 int13floppy1200 int13floppy720 int13floppy2880 int9keyboard int10video acpi usb
Comment 25 Anne Nicolas 2014-02-19 10:51:44 CET
Which iso did you use for your test?
Comment 26 Thomas Backlund 2014-02-19 14:41:07 CET
(In reply to Bob Walker from comment #24)
> 
> HP DV5T - DVD spins, slows down, spins, slows down, etc
> Message: ISOLinux 6.02 Mageia ETCDisolinux: Disk error 01, AX=42D2, drive FE
> 
> Does not work. 
> 

Yeah, sorry about that. 

Seems there was a breakage in the iso build process, so it did not get the needed fixes :(

I'll post again when we have fixed isos available.
Comment 27 Bob Walker 2014-02-19 18:10:14 CET
Anne, I used the x86_64 iso. Verified md5, sha1. It did boot on my Dell desktop.
Thomas, no problem - I'll await the new iso.
Comment 28 John ten Wolde 2014-02-19 22:17:30 CET
Updating the BIOS on the Intel D865PERL (machine #1 in Comment 3) got it to boot from USB stick successfully, so two out of my three machines start off both USB and DVD using the original-release ISOs.  Only the HP dv7 still has the DVD problem.  Haven't tried the test ISO yet.
Comment 29 Tom Zog 2014-02-20 01:11:47 CET
Sorry, my first post ever:

I used the i586 boot non-free iso and it booted a Dell e510/5150 that would not work using the original dvd or live usb.

I was stuck with BIOS v07 from ~2007 as that is the latest one Dell has for that machine.

The original DVD booted fine on a DELL XPS and Latitude laptop. Both are newer.

Thanks,
T
Comment 30 Alex Loginov 2014-03-01 19:07:25 CET
Mageia-4-x86_64-DVD.iso from ennael (Sat Feb 22 15:03:34 CET 2014; md5: f018ca084d36ca01336d5e02470ad6b4): MGA4-64-OK
Comment 31 Marja van Waes 2014-03-02 11:39:11 CET
(In reply to Raphaël Vinet from comment #2)

> Same kind of problem here (DVD x86_64). Same kind but not exactly
> 
> Boot with the DVD. After some seconds a line line is displayed 
> "ISOLINUX 6.02 Mageia ETCD copyright (c) 1994-2013 H.Peter Anvin et Al"
> 
> ==> it stops here, no error, no strange things on screen, ... just the
> mentionned lined and nothing else
> 

Hit this, too, with a pre-release iso, but mistakenly thought I'd be the only one hit by it, so only mentioned on the pad then and didn't file a bug report. Sorry about that :-[

Tested the 32-bits version of February 27th
md5: 92b8184606ea9406fd5d17da7f86ea30

It boots fine, now.

And the 64-bits version of February 27th
md5: 8ef20d8da2392c5d5123156d8d222bba

Same issue as dvg mentioned on the QA-discuss mailing list: the DVD starts booting, then immediately reboots and this continues for ever.

@ AlexL
I remove the "MGA4-64-OK" from the whiteboard because of this. Is the 32bits version OK for you, too?
Comment 32 Alex Loginov 2014-03-02 12:19:47 CET
ennael gave me x86_64 only. I don't know ISO's url of February 27th.
Comment 33 Thomas Backlund 2014-03-02 12:21:53 CET
There will be new ones out for test hopefully today, I'll notify this bugreport then...
Comment 34 Thomas Backlund 2014-03-02 23:22:04 CET
Ok, new test isos just pushed to primary mirror,

as soon as mirrors catch up, you will se them here:
(and on any mga mirror when they catch up)
http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/12549/DVD-test/

named as:

Mageia-4.1-test-i586-DVD
Mageia-4.1-test-x86_64-DVD

Please let us know if they work for you (or not)
Comment 35 Alex Loginov 2014-03-03 19:31:34 CET
Mageia-4.1-test-i586-DVD.iso (md5 ec3c769d64ae8bfb4024eb5f58b37ed0): MGA4-32-OK
Comment 36 Bob Walker 2014-03-04 08:49:56 CET
(In reply to Thomas Backlund from comment #34)
> Ok, new test isos just pushed to primary mirror,
> 
> as soon as mirrors catch up, you will se them here:
> (and on any mga mirror when they catch up)
> http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/
> 12549/DVD-test/
> 
> named as:
> 
> Mageia-4.1-test-i586-DVD
> Mageia-4.1-test-x86_64-DVD
> 
> Please let us know if they work for you (or not)

Mageia-4.1-test-x86_64-DVD on HP DV5T

Bios displays the following prompt:
0. No Emulation    System Type: 00
1. No Emulation    System Type: 00

Pressing '0' starts the boot from DVD and proceeds to the install menu.

Note: Powering off and powering back on with the DVD in will recognize the CDROM/DVD drive about 1 out of 5 times. The DVD spins up, slows down, spins up, etc. and I believe the HP bios times out before the DVD has a chance to be read (just guessing...) and proceeds to boot the secondary boot choice (hard drive).

Not sure why the boot from DVD has changed since Mageia 3. This would be related to so-called "Secure Boot"?....
Comment 37 Raphaël Vinet 2014-03-04 11:04:18 CET
Hi,

No change for me with Mageia-4.1-test-x86_64-DVD

Boot with the DVD. After some seconds a line line is displayed 
"ISOLINUX 6.02 Mageia ETCD copyright (c) 1994-2013 H.Peter Anvin et Al" and stops here
Comment 38 Erwan VELU 2014-03-04 18:07:05 CET
I think it's time to give the 6.03-pre6 a chance.
Syslinux have a couple of patches that could explain the current situation.

Thomas, how can I help you ?
Comment 39 Thomas Backlund 2014-03-04 18:15:04 CET
Ennael, there is still something broken in bcd build process:

here is the mdsum on the fixed isolinux in boot.iso that is known to work

# md5sum isolinux.bin
7fde360a8939f80fb7f70efdb0f6b9db  isolinux.bin


here is what ended up on x86_64 test iso

# md5sum isolinux.bin
4a31813024c7b910d8eded85e233f5c1  isolinux.bin
Comment 40 Thomas Backlund 2014-03-04 18:44:19 CET

and I see on i586 DVD:

# md5sum  isolinux.bin 
7fde360a8939f80fb7f70efdb0f6b9db  isolinux.bin

compared to the fixed one from boot.iso
# md5sum  isolinux.bin 
0609b34c7599d21f177c6dccbbf84fe8  isolinux.bin
Comment 41 Anne Nicolas 2014-03-04 18:47:37 CET
This has always happened as said in genisoimage. We use -boot-info-table:

-boot-info-table Specifies that a 56-byte table with information of the CD-ROM layout will be patched in at offset 8 in the boot file. If this option is given, the boot file is modified in the source filesystem, so make sure to make a copy if this file cannot be easily regenerated!
Comment 42 Thomas Backlund 2014-03-04 19:03:08 CET
Hm, 

so maybe we should use isolinux.bin directly from the fixed syslinux package in updates_testing then, and not the one coming from boot.iso as that has alrready been hit once with the -boot-info-table ?
Comment 43 Thomas Backlund 2014-03-04 19:03:45 CET
or we push a 6.03-pre build to testing
Comment 44 Thomas Backlund 2014-03-04 23:54:49 CET
(In reply to Erwan VELU from comment #38)
> I think it's time to give the 6.03-pre6 a chance.
> Syslinux have a couple of patches that could explain the current situation.
> 
> Thomas, how can I help you ?

Maybe fix 6.03-pre6 so it builds:
http://pkgsubmit.mageia.org/uploads/failure/cauldron/core/release/20140304224539.tmb.valstar.26449/log/syslinux-6.03-0.pre6.1.mga5/build.0.20140304224606.log

http://pkgsubmit.mageia.org/uploads/failure/4/core/updates_testing/20140304225006.tmb.valstar.26863/log/syslinux-6.03-0.pre6.1.mga4/build.0.20140304225105.log
Comment 45 Bob Walker 2014-03-10 00:32:37 CET
When might this be fixed? I would like to install Mageia 4....
Comment 46 Anne Nicolas 2014-03-10 00:41:06 CET
Sorry we have all a real life that can be more or less busy... ISos are in progress
Comment 47 Bob Walker 2014-03-10 00:47:41 CET
(In reply to Anne Nicolas from comment #46)
> Sorry we have all a real life that can be more or less busy... ISos are in
> progress

Anne,

Not trying to be pushy. I am quite aware that people donate their time - just wanted to get a status update since this thread has become a bit dormant. Do you have an estimate on the release? I'm anxious to test the new iso that is built...
Comment 48 Anne Nicolas 2014-03-10 00:49:12 CET
I'm trying to make it as soon as possible. the pb is managing updates on iso is a bit a nightmare and packages are missing for kernel especually. So trying to fix it as soon as possible
Comment 49 Thomas Backlund 2014-03-11 23:24:53 CET
New testisos are mirroring out:

Mageia-4.1-test2-i586-DVD
Mageia-4.1-test2-x86_64-DVD


http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/12549/DVD-test/

(or matching path on any mirror closer to you when they have synced)
Comment 50 Marja van Waes 2014-03-16 12:33:59 CET
I tried with the DVDs of March 13th from the QA repo.

The *64* bits boots fine for me,

the *32* bits hangs again here on:

Verifying DMI Pool Data
Boot from CD/DVD
ISOLINUX 6.02 Mageia ETCD Copyright (C) 1994-2013 H. Peter Anvin et all

I did not (yet) try the dual, nor a boot.iso.... which file in the isolinux directory tells which isolinux version is used?
Comment 51 Marja van Waes 2014-03-16 12:35:43 CET
s/DVDs/classical DVDs/
Comment 52 Marja van Waes 2014-03-16 14:17:17 CET
the working 64bits classical iso has
ISOLINUX 6.02 Mageia too, btw, at least that string is in isolinux.bin.

I thought we'd be having isolinux 6.03-pre6 now (sorry if I should know better,:-/ )
Comment 53 Bob Walker 2014-03-16 19:52:43 CET
I downlaoded the 64-bit iso. Still problems on the HP-DV5T. The disk never runs without the following:

Bios displays the following prompt:
0. No Emulation    System Type: 00
1. No Emulation    System Type: 00

After pressing 0, I'm able to boot to the install screen. However, I did the install, logged in, and performed an update. 

This is the first time I've had a distro NOT able to read from the CD/DVD drive...
Comment 54 Thomas Backlund 2014-03-16 20:11:11 CET
(In reply to Bob Walker from comment #53)
> I downlaoded the 64-bit iso. Still problems on the HP-DV5T. The disk never
> runs without the following:
> 
> Bios displays the following prompt:
> 0. No Emulation    System Type: 00
> 1. No Emulation    System Type: 00
> 

This comes from the reader / bios having troulbe handling the eltorito-alt-boot
that is needed for providing efi boot support on the iso.

 
> After pressing 0, I'm able to boot to the install screen. However, I did the
> install, logged in, and performed an update. 


Good, so it does boot and does not hang on syslinux anymore.


> This is the first time I've had a distro NOT able to read from the CD/DVD
> drive...

It's not the distro as such... remember it has already worked for a lot of users

The selection menu you get at the beginning is your hw / bios not being able
to decide wich boot sector on the iso to load, so it asks for your choice.

Now some of this can be due to genisoimage bugs when creating eltorito iso images, something we will work on improving for mga5 as we plan to switch
to xorriso as it has better support for creating efi bootable images.

but we need to have initial efi support on theese isos to have something
to base further work on for mga5

But anyway, the primary issue here, tha hanging on syslinux error message seems to have been fixed for you so it can actually be installed from.
Comment 55 Thomas Backlund 2014-03-24 12:29:12 CET
New testisos are mirroring out:

Mageia-4.1-test3-i586-DVD
Mageia-4.1-test3-x86_64-DVD


http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/12549/DVD-test/

(or matching path on any mirror closer to you when they have synced)
Comment 56 Marja van Waes 2014-03-25 13:12:03 CET
(In reply to Thomas Backlund from comment #55)
> New testisos are mirroring out:
> 
> Mageia-4.1-test3-i586-DVD
> Mageia-4.1-test3-x86_64-DVD
> 
> 
> http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/
> 12549/DVD-test/
> 
> (or matching path on any mirror closer to you when they have synced)

@ *ALL* who suffered from this bug:

*Please*, those of you who have some time: do test those last isos and report back here, even if someone else already reported it was fixed (or not) for him/her and even if it was fixed for you with an earlier test-iso.

QA team doesn't have all your hardware. In fact, AFAIK I'm the only member who hit this bug, and I don't have access to that system now
Comment 57 Sander Lepik 2014-03-25 14:33:40 CET
My friend confirmed that those ISOs now work on his laptop.
Comment 58 Marcello Anni 2014-03-25 15:51:24 CET
i've updated my Mageia 3 system (SAMSUNG RC530) with the i586 DVD iso and everything went fine. anyway, i didn't try the official Mageia 4 ISO so i'm not speaking about this bug, but only about the general quality of this last iso. thanks


cheers,
Marcello
Comment 59 Pierre Jarillon 2014-03-25 17:15:18 CET
I confirm that Mageia-4.1-test2-x86_64-DVD.iso boots fine now on the PC where I have found the bug :-)
Congratulations  Thomas!
Comment 60 Raphaël Vinet 2014-03-26 17:50:01 CET
Hi,


I will see with my laptop and with mum's laptop but certainly not before next week-end


A+
Raph
Comment 61 Marja van Waes 2014-03-29 21:57:14 CET
(In reply to Thomas Backlund from comment #55)
> New testisos are mirroring out:
> 
> Mageia-4.1-test3-i586-DVD
> Mageia-4.1-test3-x86_64-DVD
> 
> 
> http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/
> 12549/DVD-test/
> 
> (or matching path on any mirror closer to you when they have synced)

Sorry, both give a noise as if booting from DVD is tried, but then the system tries to reboot instead.

(In reply to Pierre Jarillon from comment #59)
> I confirm that Mageia-4.1-test2-x86_64-DVD.iso boots fine now on the PC
> where I have found the bug :-)
> Congratulations  Thomas!

Thanks! Do you mind trying the test3 version too, Pierre?

@ Sander, Marcello and Raphaël
Thanks for the feedback (to come) :-)
You're all talking about the test3 iso(s), I suppose?
Comment 62 Raphaël Vinet 2014-03-30 11:05:36 CEST
Hi,


As promissed ...
Installation of Mageia-4.1-test3-x86_64-DVD is ok for me (done today without problems) :)

Thx
Comment 63 Marcello Anni 2014-03-30 14:43:42 CEST
in reply to comment #61:

yes marja, i'm talking about the test3 iso :-)
Comment 64 Pierre Jarillon 2014-03-30 22:52:40 CEST
> Thanks! Do you mind trying the test3 version too, Pierre?

I have  burned a DVD: It works fine too!
I have also tried Rescue and Hardware with success.
Comment 65 Marja van Waes 2014-03-31 20:18:09 CEST
(In reply to Pierre Jarillon from comment #64)
> > Thanks! Do you mind trying the test3 version too, Pierre?
> 
> I have  burned a DVD: It works fine too!
> I have also tried Rescue and Hardware with success.

Thanks, Pierre.


There'll be feedback from the initial reporter of this bug, too, if everything goes well:

2014:03:31:20:06 < AlexL> marja: please wait my report about syslinux, because user cannot download iso without torrent, network is unstable
Comment 66 Alex Loginov 2014-04-01 21:03:20 CEST
Mageia-4.1-test3-i586-DVD.iso: OK
Comment 67 Marja van Waes 2014-04-02 09:50:18 CEST
(In reply to Alex Loginov from comment #66)
> Mageia-4.1-test3-i586-DVD.iso: OK

Thanks, Alex :-)

I suppose the few people for whom this didn't get solved, can, if their systems don't allow to boot from USB, use something like Super Grub2 Disk http://www.supergrubdisk.org/super-grub2-disk/ to boot the iso from USB or from a partition on their HD?

When I get to my system again, hopefully next weekend, I'll try that
Comment 68 William Kenney 2014-04-02 16:50:39 CEST
I've had good success DVD installing 32-bit Dual into an old:
MSI Hermes 651
Intel Celeron CPU 1.70GHz, 128Kb cache
SiS961/962 SMBus Controller Gigabyte MoBo
 SiS7012 PCI Audio
 SiS650/651/740 GUI 2D/3D Video
 Realtek RTL-8139 eth0 100Mhz
1GB DIMM
Maxtor 6Y160P0 160GB IDE (hda)
DVD R/W drive
This system is about 10-years old. The Xfce seems to like it
just fine. NFS, Adobe, SSH, Proftp, Awstats, Webmin, CUPS all
installed just fine. System updated and rebooted back to a
working desktop successfully.
Mageia-4.1-dual-DVD.iso   MD5: 58b80e2d9b9f27456c331f4ff8343efc
Comment 69 David Walser 2014-04-04 01:41:43 CEST
*** Bug 12669 has been marked as a duplicate of this bug. ***
Comment 70 Marja van Waes 2014-04-06 11:42:46 CEST
(In reply to Marja van Waes from comment #67)

> 
> I suppose the few people for whom this didn't get solved, can, if their
> systems don't allow to boot from USB, use something like Super Grub2 Disk
> http://www.supergrubdisk.org/super-grub2-disk/ to boot the iso from USB or
> from a partition on their HD?
> 
> When I get to my system again, hopefully next weekend, I'll try that

I tried with super-grub2-disk-hybrid-2.01-rc3.iso and with ploplinux-4.0.2-x64.iso on DVD.

Both DVDs booted fine, but I didn't manage to get them to boot my USB-key. I only tried with one of the 6 available USB-ports

supergrub2 has an option to boot an iso from /boot/boot-isos/ or /boot-isos/
I couldn't try that on that system with a test3 DVD, because there was too little space.
However, it did *not* find the boot isos I had put in /boot/boot-isos/ on one of my Mageia root partitions. 

Note: I did not and do not have time to read the documentation for supergrub2 or ploplinux, so this only means marja did not get it to work!!
Comment 71 kalagani kalagani 2014-04-07 18:59:00 CEST
(In reply to Norman Carver from comment #14)
> I have also had no luck getting Mageia-4-x86_64-DVD.iso disc to boot on
> multiple Dell Precision workstations.  I briefly see the isolinux message
> flash, then goes to black screen and BIOS restarts--over and over.
> 
> Downloaded/burned boot-nonfree.iso and it boots fine, and was able to then
> start MGA4 installation from Mageia-4-x86_64-DVD disc on second cdrom drive
> by selecting cdrom option.
> 
> Hope this information is helpful.  Let me know if you want any further
> testing.

Same pb Norman on a HPnc5800 BIOS 1.53 but instead of burned a CD, made a USB key with the boot-nonfree.iso because none second drive available.
So I was also able to start MGA4 installation by selecting cdrom option...
Comment 72 Pascal Gautronneau 2014-04-22 11:49:53 CEST
Hi,

just tried to install from a Mageia-4-x86_64-DVD disc or the boot-nonfree.iso on a CD and both result in : "ISOLINUX 6.02 Mageia ETCD isolinux: Disk error 01, AX = 4275, drive FE"

It is on a hp compaq 6910p

I've tried to create a bootable usb disc from my macbook, but when I try to boot on it, it crash without any message.

Thanks in advance for any help
Comment 73 Marja van Waes 2014-04-22 13:09:10 CEST
(In reply to Pascal Gautronneau from comment #72)
> Hi,
> 
> just tried to install from a Mageia-4-x86_64-DVD disc or the
> boot-nonfree.iso on a CD and both result in : "ISOLINUX 6.02 Mageia ETCD
> isolinux: Disk error 01, AX = 4275, drive FE"
> 
> It is on a hp compaq 6910p
> 
> I've tried to create a bootable usb disc from my macbook, but when I try to
> boot on it, it crash without any message.
> 
> Thanks in advance for any help

Please try with the Mageia-4.1-test3-x86_64-DVD.iso in the 
Mageia-4.1-test3-x86_64-DVD/ directory here (or in the same directory on your favourite mirror):
http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/12549/DVD-test/

And please do tell us whether that iso solves the problem :-)
Comment 74 Pascal Gautronneau 2014-04-22 13:21:26 CEST
Hope it will, that means 2 hours downloading and a DVD that will go to trash it it doesn't ;-)
Comment 75 Pascal Gautronneau 2014-04-22 15:59:28 CEST
Installation is ongoing!! Thanks a lot for your support :-)
Comment 76 Marja van Waes 2014-04-22 16:43:32 CEST
Thanks for the feedback, Pascal :-)

So, if I counted well, the test3 iso was tested on 7 of the systems where the Mageia 4 iso failed to boot from DVD

It only failed (both arches) to boot properly on a system of me, a Lenovo 3000 J100 (PQBD3ND). I should have kept the QA repo 64 bits DVD of March 13, which did work :-/
Comment 77 Marja van Waes 2014-04-23 16:13:11 CEST
(In reply to Marja van Waes from comment #76)

> It only failed (both arches) to boot properly on a system of me, a Lenovo
> 3000 J100 (PQBD3ND). I should have kept the QA repo 64 bits DVD of March 13,
> which did work :-/

On IRC, Ady2, who hunts bugs for upstream Syslinux, said the following (I hope I'll only paste the essential stuff, as he requested):

2014:04:23:12:49 < Ady2> marja9:  have you tested the latest (2014APR11) <mageia_mirror>/mirrors/mageia/distrib/cauldron/i586/install/images/boot.iso ? 
DD'ing it to a “clean” USB drive? Or (Re)Burning a RW optical media in 4x speed? Updating your BIOS? Or a different optical drive / media? (I'm guessing your system is not EFI).
2014:04:23:13:01 < Ady2> marja: Hmm, the initial menu could be covering up some error message. You could try using pre-built binaries from kernel.org 6.03-pre11, isolinux.bin and all related modules. V.6.03-pre11 allows to press ALT so to boot to prompt instead of menu.
2014:04:23:13:02 < Ady2> Comparing the behavior with pre-built binaries could provide some clue.
2014:04:23:13:09 < Ady2> marja: This more technical than what generic users should care about (and the list is only partial), but FWIW and FYI http://www.syslinux.org/wiki/index.php/Syslinux_6.02_notes#isolinux_Disk_error_message

I did not use a re-writable disk, btw, tried with two DVD brands and with two different burners. It is an old non-EFI system.
This weekend, I hope to be near that system again (and a 2nd identical system), I'll then start with testing the last 32 and 64 bits boot.iso on both systems, and, if that doesn't work and provided I find enough time, follow Ady's other suggestions.
Comment 78 John ten Wolde 2014-04-28 00:08:48 CEST
Hmm, it seems I'm the only early reporter who hasn't posted test results yet, so here they are.  Apologies for the delay.

I used one of the test isos linked by Marja (comment 73):

Mageia-4.1-test3-x86_64-DVD.iso (Mon Mar 24 10:52:49 CET 2014)
md5: 10f14054270ea855e89b1829196b5ad3

Just a reminder that this test is on an HP Pavilion dv7 (x86_64) notebook, so not surprisingly, my results are similar to what Bob Walker (comment 13) got on his HP dv5T except that I never arrive at the install/rescue text-mode display.

0. No Emulation    System Type: 00
1. No Emulation    System Type: 00

If I choose 0, the system returns:

ISOLINUX 6.03 Mageia ETCD copyright (c) 1994-2013 H.Peter Anvin et al

Then after several minutes it adds:

Failed to load ldlinux.c32
Boot failed: press a key to retry...


If I choose 1, the machine appears to idle indefinitely (but it doesn't hang as I can still turn Caps/Num Lock on and off).

Both the Intel D865PERL and Toshiba Satellite L300D (from comment 3), which booted the original dual-arch release DVD just fine also boot the test DVD without issue.

I regret that my report wasn't happier.  :-(
Comment 79 Muhammad Tailounie 2014-04-29 19:31:08 CEST
I have tried the ISO in http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/12549/DVD-test/Mageia-4.1-test3-x86_64-DVD/ on two computers. HP 550 laptop and Dell Dimension 3100C. 

The original ISOs' do not boot on the HP laptop, but the ISO I got from the above link works fine.

Still the original live ISO cannot boot completely on the laptop.


I think this last ISO works fine.

Thank you
Comment 80 Amir Omahic 2014-05-01 15:43:04 CEST
Hi,

just confirm that official iso-image doesn't work on

HP Compaq NC6400
Intel Core2 CPU T5600 @ 1833 MHz
ROM Date 09/05/2007
ROM BIOS version F.0B


but Megeia4 successfully installed from DVD with 'Mageia-4.1-test3-x86_64-DVD'

http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/people/tmb/mga4/bugs/12549/DVD-test/Mageia-4.1-test3-x86_64-DVD/

Thanks!
Comment 81 Marja van Waes 2014-05-14 17:16:10 CEST
(In reply to Marja van Waes from comment #76)

> So, if I counted well, the test3 iso was tested on 7 of the systems where
> the Mageia 4 iso failed to boot from DVD
> 
> It only failed (both arches) to boot properly on a system of me, a Lenovo
> 3000 J100 (PQBD3ND). 

On that system, the following classical isos from the QA repo boot fine from DVD:

The dual from Wed May  7 17:10:44 CEST 2014
The 32 bits from Wed May  7 22:27:00 CEST 2014
The 64 bits from Wed May  7 22:27:53 CEST 2014

\o/\o/\o/
Comment 82 Rémi Verschelde 2014-06-20 00:09:27 CEST
This bug should have been fixed by the new set of ISOs (Mageia 4.1 on your favourite mirrors).
Comment 83 ernandes 2014-06-28 16:04:45 CEST
(In reply to Rémi Verschelde from comment #82)
> This bug should have been fixed by the new set of ISOs (Mageia 4.1 on your
> favourite mirrors).

I have a Dell Vostro 1510 (Core 2 Duo) and I am still facing this problem with both
DVD and USB with Mageia 4.1. Neither one installs.
Comment 84 Manuel Hiebel 2014-06-28 16:07:42 CEST
since it affect also usb, it looks not this bug
Comment 85 Marja van Waes 2014-06-29 13:40:53 CEST
(In reply to ernandes from comment #83)

> 
> I have a Dell Vostro 1510 (Core 2 Duo) and I am still facing this problem
> with both
> DVD and USB with Mageia 4.1. Neither one installs.

(In reply to Manuel Hiebel from comment #84)
> since it affect also usb, it looks not this bug

Indeed, that must be a different issue, so closing this bug again.

@ ernandes

I can't find an open bug report about installer failing to boot from both DVD and USB (hope I didn't look over it)

I suppose you have set the boot order in your BIOS to DVD and USB before hard disk, and that you made sure the checksums of the iso were correct. If I'm right about that, then please file a new bug report.

In that new report:
* Tell exactly which iso you tried to install and  
* If you see any messages when trying to boot the iso, please quote them
* and tell what else happens (endlessly rebooting or a hard freeze or whatever)
* please give the output of lspcidrake -v (from a konsole in an existing Mageia install or, if you can boot a current or old Mga LiveCD/DVD, from running a Live session)

Note You need to log in before you can comment on or make changes to this bug.