Bug 11794 - stage2, drop down menu needs their buttons
Summary: stage2, drop down menu needs their buttons
Status: RESOLVED DUPLICATE of bug 13673
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal minor
Target Milestone: ---
Assignee: Thierry Vignaud
QA Contact:
Whiteboard: 4RC
: 12250 13100 (view as bug list)
Depends on:
Blocks: 11778
  Show dependency treegraph
Reported: 2013-11-27 14:33 CET by Manuel Hiebel
Modified: 2015-05-11 11:03 CEST (History)
7 users (show)

See Also:
Source RPM: gtk+3.0
Status comment:

capture of a menu (disk wizard, the red is the partition) (2.38 KB, image/png)
2013-11-27 14:33 CET, Manuel Hiebel
screenshot partition (35.80 KB, image/png)
2014-08-26 17:17 CEST, Georges Eckenschwiller
other screen (43.67 KB, image/png)
2014-08-26 17:18 CEST, Georges Eckenschwiller

Description Manuel Hiebel 2013-11-27 14:33:46 CET
Created attachment 4537 [details]
capture of a menu (disk wizard, the red is the partition)

On each drop down menu, if click for the first in will show an empty line (some px high), for the second time it will show the content.
Comment 1 Thierry Vignaud 2013-11-28 14:31:45 CET
That might might actually be a gtk+3 issue.
Thierry Vignaud 2013-11-28 15:09:55 CET

Severity: normal => minor

Comment 2 Thierry Vignaud 2013-12-03 17:41:13 CET
What about current Cauldron?

Keywords: (none) => NEEDINFO

Comment 3 Manuel Hiebel 2013-12-03 23:08:26 CET
will check (I have no working one currently), but it's still the same in the last stage2
Comment 4 Thierry Vignaud 2013-12-05 15:01:47 CET
Did you check?
Comment 5 Manuel Hiebel 2013-12-05 17:03:24 CET
looks ok, (as on the live pre-beta2)

Keywords: NEEDINFO => (none)

Comment 6 William Kenney 2014-01-08 21:21:46 CET
*** Bug 12250 has been marked as a duplicate of this bug. ***

CC: (none) => wilcal.int

Comment 7 claire robinson 2014-01-15 11:16:19 CET
Valid 4RC Classic DVD 64 (build 8, Date.txt: Tue Jan 14 23:23:20 CET 2014)
claire robinson 2014-01-15 11:16:46 CET

Whiteboard: (none) => 4RC

Comment 8 Frank Griffin 2014-01-15 12:30:16 CET
I'm not sure if this is the same thing, but I saw this behavior on a cauldron install yesterday.  In "Custom" diskdrake, if you select a partition and click "Mount Point", you have to click twice on the dropdown for the preloaded mount points in order to get the list.  A single click produces no response at all.

CC: (none) => ftg

Comment 9 Frank Griffin 2014-01-15 15:47:57 CET
This behavior also presents with the dropdown in Bootloader Configuration for the partition on which to install grub.
Comment 10 Thierry Vignaud 2014-01-20 02:40:47 CET
Olav I really think this is a gtk+3 issue, either in embedded environment or b/c we maybe lacks some files in installer.

CC: (none) => olav

claire robinson 2014-01-22 17:34:22 CET

CC: (none) => eeeemail

Comment 11 papoteur 2014-01-22 18:47:17 CET
I see also this problem, but I count three clicks to obtain the list.

CC: (none) => yves.brungard_mageia

Thierry Vignaud 2014-01-22 19:05:31 CET

Source RPM: (none) => gtk+3.0

Georges Eckenschwiller 2014-04-01 11:16:11 CEST

CC: (none) => paiiou

Comment 12 Georges Eckenschwiller 2014-05-03 10:22:23 CEST
(In reply to papoteur from comment #11)
> I see also this problem, but I count three clicks to obtain the list.
> Mageia4-RC-DVD-i586

Same problem (three clicks), with boot-nonfree.iso i586 (1 may)
Comment 13 Georges Eckenschwiller 2014-06-28 17:25:51 CEST
*** Bug 13100 has been marked as a duplicate of this bug. ***
Comment 14 Georges Eckenschwiller 2014-06-28 17:30:50 CEST
On cauldron, the problem changed :
- A moment was given, I could not open any more lists ( a red cross)
- Today there is not a list anymore, only a field to be filled
Comment 15 Georges Eckenschwiller 2014-07-07 11:23:33 CEST
(In reply to Georges Eckenschwiller from comment #14)
> On cauldron, the problem changed :
> - A moment was given, I could not open any more lists ( a red cross)
> - Today there is not a list anymore, only a field to be filled

I correct my last remark:
It is only the button of the list that is missing.
By clicking to the right of the field, where should be the button, the list opens well
Test with stage2 from 03/07/2014 and boot-nonfree.iso from 30/06/2014
Comment 16 Olav Vitters 2014-07-07 11:35:31 CEST
Is there a way to start this up from within Cauldron? It's showing Oxygen-gtk theme and a little bit broken. I've removed the default theme bit a locally built rpm, I'd like to test how that affects things.
Comment 17 Georges Eckenschwiller 2014-08-18 09:45:14 CEST
It goes from bad to worse.
I tried a net - install today:
The radio buttons and the checkboxes do not show any more their state.

Impossible to make an installation.

It could come from the last update of gtk3.
Since the use of gtk3, I see only problems with the installer, often small, it is true.
But now I am blocked in the tests of cauldron.

I wonder if it would not be more sensible to make the installer under qt, rather than under gtk3 !
Comment 18 Georges Eckenschwiller 2014-08-26 11:36:59 CEST
I suggest modifying the title, because the problem evolved:
- Lists display now with a simple click
- The radio buttons and the checkboxes show their state since the update of oxygen-gtk3-1.4.0-4.

There is an absence of buttons
Georges Eckenschwiller 2014-08-26 11:38:05 CEST

Summary: stage2, drop down menu needs to be clicked twice to show content => stage2, drop down menu needs their buttons

Comment 19 Hugo Pereira Da Costa 2014-08-26 14:48:12 CEST
Can you post a screenshot of the buttons which are missing ?

CC: (none) => hugo.pereira

Comment 20 Hugo Pereira Da Costa 2014-08-26 14:50:18 CEST
Also, do you see the same problem with other drop down menus ? 
(in for instance oxygen-gtk3-demo)
Comment 21 Georges Eckenschwiller 2014-08-26 17:17:01 CEST
Created attachment 5374 [details]
screenshot partition
Comment 22 Georges Eckenschwiller 2014-08-26 17:17:46 CEST
Here are screenshot.
The button is lacking on all the lists during the installation.
The problem exists also then, after the restart, with MCC

I do not know oxygen-gtk3-demo.  How to launch?
Comment 23 Georges Eckenschwiller 2014-08-26 17:18:54 CEST
Created attachment 5375 [details]
other screen
Comment 24 Hugo Pereira Da Costa 2014-08-26 17:29:07 CEST
1/ thanks for the screenshots
2/ sorry for being slow, still not sure which buttons you are referring too
So just to make sure are we talking about the little pointing down arrow in 

Or in http://wstaw.org/m/2014/08/26/plasma-desktopwH4218.png ?

If yes, well, that's another gtk3 bug
you need to have gnome-icon-theme-symbolic-3.10.1-2.mga4 (or adwaita-icon-theme-symbolic), or anything with icon and symbolic installed to get them (because gtk3 is unable to fall back to an existing icon)

Can you confirm that if you install one of the above package you get these arrow back in mcc ? 
And if yes, well, I guess people will have to fix the installer (or gtk)
Comment 25 Georges Eckenschwiller 2014-08-26 18:43:25 CEST
Yes it is the little pointing down arrow.

Actually, none of the packages are installed.

If I ask for gnome-icon-theme-symbolic, urpmi install adwaita-icon-theme (no symbolic). But the images are not correct

If I ask for adwaite-icon-theme-symbolic, urpmi do not find.
Both package asked are lacking in cauldron
Comment 26 Thierry Vignaud 2015-05-11 11:03:32 CEST
I think this one is fixed by the switch to Adwaita.

*** This bug has been marked as a duplicate of bug 13673 ***

Resolution: (none) => DUPLICATE

Note You need to log in before you can comment on or make changes to this bug.