Bug 11158 - LXDE Shutdown Reboot Suspend Hibernate have no effect - 4alpha2 DVD 32
: LXDE Shutdown Reboot Suspend Hibernate have no effect - 4alpha2 DVD 32
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: Cauldron
: i586 Linux
: Normal Severity: major
: ---
Assigned To: Mageia Bug Squad
:
:
: 4beta1 4alpha3 4alpha2
:
:
:
  Show dependency treegraph
 
Reported: 2013-09-04 18:10 CEST by claire robinson
Modified: 2014-02-12 14:16 CET (History)
5 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
journal.txt showing before and after enabling policykit & reboot (235.60 KB, text/plain)
2013-09-04 18:21 CEST, claire robinson
Details

Description claire robinson 2013-09-04 18:10:43 CEST
4alpha2 DVD i586 with default LXDE installation

Shutdown, Reboot, Suspend or Hibernate are offered but do nothing.




Reproducible: 

Steps to Reproduce:
Comment 1 claire robinson 2013-09-04 18:17:16 CEST
I remember when testing for mageia 3 isos we had an issue with these options not being offered which was due to policykit not starting. It isn't currently starting either (see bug 11159) but the options are offered now and once policykit is started they still do nothing.
Comment 2 claire robinson 2013-09-04 18:21:21 CEST
Created attachment 4323 [details]
journal.txt showing before and after enabling policykit & reboot

Attaching journal.txt showing boots with and without policykit enabled
Comment 3 claire robinson 2013-09-30 13:18:53 CEST
valid 4alpha3
Comment 4 claire robinson 2013-09-30 13:21:36 CEST
*** Bug 10953 has been marked as a duplicate of this bug. ***
Comment 5 psyca 2013-10-03 02:44:52 CEST
same on Mageia 4 Alpha 3 x64
Comment 6 claire robinson 2013-11-05 09:12:25 CET
Valid 4beta1 still.
Comment 7 claire robinson 2013-11-05 10:08:40 CET
rpm -qa | grep polkit shows..

polkit-gnome
polkit
lib64polkit1_0
polkit-desktop-policy
Comment 8 claire robinson 2013-11-05 10:09:29 CET
report.bug.xz is attachment 4479 [details]
Comment 9 Colin Guthrie 2013-11-05 12:09:55 CET
OK, so this is really just about logind. In lxsession, it starts by asking logind via dbus whether it can shutdown and invokes the appropriate code thereafter.

Looking at the source, I can see obvious errors. The GError structure is passed around uninitialised and even the function prototypes do not match their implementation. This is horrible code :( Just running the lxsession-logout binary manually clearly shows the assertions in the glib dbus code which checks the error structure.

Seems it was broken in https://github.com/lxde/lxsession/commit/2b9a246046eea0bb5130a63f7476b81ceaafd1fd which was clearly not tested.

It's since been reworked at lot and I don't have time to poke at this, so just wrote a very quick patch to make things work with the current setup.

Should be resolved in next build. Ugg.
Comment 10 claire robinson 2013-11-05 17:35:54 CET
Thanks for sorting this one out Colin, it's been problematic for a while now.
Comment 11 mike marmer 2013-12-30 02:10:31 CET
I had this problem and I solved it as follows:
apt-get purge systemd
---------------------------------
then your system will revert to using consolekit which apparently the buttons need. It had me stumped for a while because the buttons worked on 3 of 4 boxes that I installed LXDE but not on the 4th box.
Comment 12 Colin Guthrie 2013-12-30 13:48:12 CET
(In reply to mike marmer from comment #11)
> I had this problem and I solved it as follows:
> apt-get purge systemd
> ---------------------------------

Erm, this is just so wrong it's not even funny!

1. apt-get is not a native Mageia command.
2. If you remove systemd, you can no longer boot on Mageia as it's the only supported init system.

> then your system will revert to using consolekit which apparently the
> buttons need. 

ConsoleKit is legacy and is not even shipped on Mageia any longer so this is doubly wrong.

> It had me stumped for a while because the buttons worked on 3
> of 4 boxes that I installed LXDE but not on the 4th box.

It's still the wrong solution. Instead of burying your head in the sand, try fixing things *properly*. I fixed the problem in Mageia by actually understanding the problem and fixing it at the code level. It needs further fixes to properly adapt to logind, but your "fix" is anything but! It's a totally unsupported and invalid fix!

For reference the fix is here:
http://svnweb.mageia.org/packages?view=revision&revision=549605

It's also not a "Works For Me" resolution but a "Fixed" one. Please do not mess about with already resolved bugs and change the status and meaning of the resolution.

Note You need to log in before you can comment on or make changes to this bug.