Bug 1055 - Not all countries available in localedrake
Summary: Not all countries available in localedrake
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: Mageia 7
Assignee: Mageia tools maintainers
QA Contact:
URL:
Whiteboard: MGA5TOO MGA6TOO
Keywords: FOR_ERRATA5, FOR_ERRATA6
Depends on: 460
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-29 13:01 CEST by Dick Gevers
Modified: 2019-05-18 13:21 CEST (History)
11 users (show)

See Also:
Source RPM: draklive-install drakxtools
CVE:
Status comment:


Attachments
Tentative patch to fix the problem. (522 bytes, patch)
2013-05-13 19:56 CEST, Shlomi Fish
Details | Diff

Description Dick Gevers 2011-04-29 13:01:58 CEST
Description of problem:

I installed Mageia from the Beta 2 Live CD (GNOME) and if I start localedrake (embedded from MCC) I do not have a chance to change the country to for example The Netherlands.
Only if I "urpmi locales-nl" do I have the chance to change to language Dutch and country NL.

It's not a problem that it isn't on the Live CD, but after completing the install and updating respositories, localedrake, IMHO, ought to know about all languages & countries that exist. Now there is no obvious way for a new user to do it.

Some other examples that can't be found: Slovenia, Israel, Libya. I'm sure there are others.
Comment 1 Ahmad Samir 2011-04-29 19:26:12 CEST
Which is what bug 460 is about, IIUC.

*** This bug has been marked as a duplicate of bug 460 ***

Status: NEW => RESOLVED
Resolution: (none) => DUPLICATE

Comment 2 Dick Gevers 2011-04-29 23:26:04 CEST
https://bugs.mageia.org/show_bug.cgi?id=460 was about the fact that Burmese was shown without good reason after an install from the DVD.

This is about countries being not available after an install from the Live CD. There is some relation, but IMHO they are different bugs.
Comment 3 Ahmad Samir 2011-04-29 23:34:48 CEST
Read bug 460 summary again (after blino modified it 1-2 days ago).

Burmese showing when locales-en is installed is bug 1036. 

(Off-topic, in bugzilla you can use 'bug $BUGNUMBER' and bugzilla will translate it automatically to a url to the bug report in question).
Comment 4 Dick Gevers 2011-04-29 23:45:25 CEST
Originally bug 460 said the same as 1036 did later. Nevermind. Current bug is stg different. But I already described it in the original report. Seems clear to me.
Comment 5 Dick Gevers 2011-04-30 21:05:57 CEST
Apparently I have to explain it in a better way - so here goes:

Scenario 1:
-----------
Install Mageia from full DVD. Choose language English, location Netherlands (or any other, all countries are listed and can be selected).

Afterwards localedrake gives the option to use Burmese (and English and Dutch). This is weird for the user. Fixed by Thierry in svn as Bug 460, later Bug 1036.

$ $ $

Scenario 2:
-----------
Install Mageia from Live CD (GNOME or KDE give same result). There are only a few languages to choose from (obviously: it's only one CD, not all fit on it). 

After rebooting and adding & updating all repositories, one fires up localedrake embedded in MCC.

Now I should want to change my location to The Netherlands (or Slovenia etcetera). But I cannot, the countries simply are not listed. This is a different problem than Bug 460 or Bug 1036.

If someone is new to Mageia (or Linux), how is the user supposed to know (s)he should install locales-nl etc. to achive this? The user should have a full list of countries to select from, and if needed localedrake should be able to install any needed packages.

After all the MCC icon does say: "Manage localization for your system", but at this point it can't. So this bug is not fixed yet.

Resolution: DUPLICATE => (none)
Summary: [ GNOME Live CD Beta2 ] Not all countries available in localedrake => [ Live CD Beta2 ] Not all countries available in localedrake
Status: RESOLVED => REOPENED

Comment 6 Ahmad Samir 2011-05-01 01:55:34 CEST
I won't close, for the third time, as a dupe of bug 460 because I am tired of this ping pong, open close, game.

Over & out.
Comment 7 Dick Gevers 2011-05-01 09:15:43 CEST
I'm sorry that you get tired, Ahmad: I don't know how to make it more clear but it is not a duplicate. Bug 460 is about language. This one is about location.
Comment 8 Olivier Blin 2011-05-05 22:15:52 CEST
Adding a dependency to bug 460, since countries will only appear if the locale if available

Depends on: (none) => 460
CC: (none) => mageia

Marja Van Waes 2011-10-11 22:27:33 CEST

CC: (none) => marja11
Source RPM: (none) => draklive-install

Marja Van Waes 2011-10-11 22:28:52 CEST

Source RPM: draklive-install => draklive-install drakxtools

Comment 9 Marja Van Waes 2011-11-10 12:46:55 CET
@ Olivier

Assigning to you, although I know bug 460 needs to be solved. I just don't want this to be forgotten now that Mga 2

Assignee: bugsquad => mageia

Manuel Hiebel 2011-11-10 14:46:31 CET

Summary: [ Live CD Beta2 ] Not all countries available in localedrake => Not all countries available in localedrake

Filip Komar 2012-01-03 08:00:48 CET

CC: (none) => filip.komar

Dimitrios Glentadakis 2012-04-19 12:16:50 CEST

CC: (none) => dglent

Comment 10 Marja Van Waes 2012-05-26 13:07:31 CEST
Hi,

This bug was filed against cauldron, but we do not have cauldron at the moment.

Please report whether this bug is still valid for Mageia 2.

Thanks :)

Cheers,
marja

Keywords: (none) => NEEDINFO

Comment 11 Shlomi Fish 2012-06-21 21:07:28 CEST
This bug is still valid for Mageia 2. The "full list of countries" after selecting the language "English" does not contain Israel for example.

Keywords: NEEDINFO => (none)
Whiteboard: (none) => MGA2TOO
CC: (none) => shlomif

Comment 12 Marja Van Waes 2012-07-06 15:04:11 CEST
Please look at the bottom of this mail to see whether you're the assignee of this  bug, if you don't already know whether you are.


If you're the assignee:

We'd like to know for sure whether this bug was assigned correctly. Please change status to ASSIGNED if it is, or put OK on the whiteboard instead.

If you don't have a clue and don't see a way to find out, then please put NEEDHELP on the whiteboard.

Please assign back to Bug Squad or to the correct person to solve this bug if we were wrong to assign it to you, and explain why.

Thanks :)

**************************** 

@ the reporter and persons in the cc of this bug:

If you have any new information that wasn't given before (like this bug being valid for another version of Mageia, too, or it being solved) please tell us.

@ the reporter of this bug

If you didn't reply yet to a request for more information, please do so within two weeks from now.

Thanks all :-D
Comment 13 Juan Luis Baptiste 2012-12-26 04:24:15 CET
This still happens with Mga 3 beta 1, I don't have Colombia nor any other South American country available after install.

CC: (none) => juan.baptiste

Comment 14 Dick Gevers 2013-05-11 13:31:47 CEST
Still valid

Hardware: i586 => All
Whiteboard: MGA2TOO => 3RC

Comment 15 Marja Van Waes 2013-05-11 13:51:17 CEST
(In reply to Dick Gevers from comment #14)
> Still valid

Thanks for checking :-D

re-adding MGA2TOO, because I don't understand why it was removed

Whiteboard: 3RC => 3RC MGA2TOO

Comment 16 Dick Gevers 2013-05-11 23:34:05 CEST
Valid also for prerelease isos of 3 final

Whiteboard: 3RC MGA2TOO => MGA2TOO 3final

Comment 17 Shlomi Fish 2013-05-13 19:56:58 CEST
Created attachment 3965 [details]
Tentative patch to fix the problem.

This is a tentative/temporary patch that fixes the problem. It is done against:

shlomif[rpms]:$mageia/TOOLS/drakx/trunk$ svn info
Path: .
Working Copy Root Path: /home/shlomif/Download/unpack/Mageia/TOOLS/drakx/trunk
URL: svn+ssh://svn.mageia.org/svn/soft/drakx/trunk
Repository Root: svn+ssh://svn.mageia.org/svn/soft
Repository UUID: 5b7c3c08-40e5-403b-9995-ace06908e4af
Revision: 8223
Node Kind: directory
Schedule: normal
Last Changed Author: francescpinyol
Last Changed Rev: 8215
Last Changed Date: 2013-05-12 22:47:37 +0300 (Sun, 12 May 2013)

shlomif[rpms]:$mageia/TOOLS/drakx/trunk$ 

This lists the whole countries including those not installed.
claire robinson 2013-05-15 13:34:08 CEST

CC: (none) => eeeemail

claire robinson 2013-05-15 13:34:24 CEST

CC: (none) => tmb

Comment 18 Shlomi Fish 2013-06-06 12:53:15 CEST
Hi all,

(In reply to Shlomi Fish from comment #17)
> Created attachment 3965 [details]
> Tentative patch to fix the problem.
> 
> This is a tentative/temporary patch that fixes the problem. It is done
> against:
> 
> shlomif[rpms]:$mageia/TOOLS/drakx/trunk$ svn info
> Path: .
> Working Copy Root Path:
> /home/shlomif/Download/unpack/Mageia/TOOLS/drakx/trunk
> URL: svn+ssh://svn.mageia.org/svn/soft/drakx/trunk
> Repository Root: svn+ssh://svn.mageia.org/svn/soft
> Repository UUID: 5b7c3c08-40e5-403b-9995-ace06908e4af
> Revision: 8223
> Node Kind: directory
> Schedule: normal
> Last Changed Author: francescpinyol
> Last Changed Rev: 8215
> Last Changed Date: 2013-05-12 22:47:37 +0300 (Sun, 12 May 2013)
> 
> shlomif[rpms]:$mageia/TOOLS/drakx/trunk$ 
> 
> This lists the whole countries including those not installed.

I submitted this patch many weeks ago - does anyone have any comments about it? Can it be applied?

Regards,

-- Shlomi Fish
Comment 19 Pablo Saratxaga 2013-07-03 21:56:48 CEST
I don't see any difference with that patch.

However, there are two issues here:

1. list of choosable languages is limited to installed ones (from locales-xx packages)
2. first list of countries is determined by choosen language

For 1, it would be nice if the "advanced" option would list the whole list
of all possible languages; and if choosing a new one, install the corresponding locales-xx

For 2; the full countries list is available on the advanced option of country choosing; it is simply that in some cases the "short" list is quite long and it misleads to thinking it is the whole list.
Two possible solutions:
a) change the wording of the "choose your country" to "choose your country (see below for other countries)"
b) after some threshold (maybe ~15-20 countries) just display the whole list.

CC: (none) => pablo

Comment 20 Shlomi Fish 2013-07-13 19:17:02 CEST
(In reply to Pablo Saratxaga from comment #19)
> I don't see any difference with that patch.
> 

OK, to demonstrate the difference, I have created a screen recording:

http://www.shlomifish.org/Files/files/video/localedrake-with-and-without-the-patch.ogv

The first invocation of localedrake is without the patch, the second is with it applied. As you can see, the second list includes many countries that are not in the first list (including Iran and some empty countries in the beginning).

Regards,

-- Shlomi Fish
Comment 21 Dick Gevers 2014-01-17 19:16:41 CET
Valid for Live disks 4RC round 9

Whiteboard: MGA2TOO 3final => MGA2TOO 3final 4RC
Blocks: (none) => 11704

Comment 22 Thomas Backlund 2014-01-17 20:27:53 CET
I was thinking of trying to add all locales-* to livecds too, to make them more useful (without adding language files for all other packages, as that would grow too big)

that would stop those uggly errors in conole if correct locales is available.

that would also fix this issue ...
Comment 23 Dick Gevers 2014-01-17 20:43:59 CET
@tmb re #c22: IMHO the system only needs to know they exist, so it can download them when asked. 

And the report is for post install, so live disk is not an available medium anymore at that stage, I believe, so for that reason and to avoid bloat of the disk, I am not sure it would solve the problem.
Comment 24 Florian Hubold 2014-09-04 02:23:20 CEST
(In reply to Thomas Backlund from comment #22)
> I was thinking of trying to add all locales-* to livecds too

Maybe you can try that with next rounds of mga5 images?

CC: (none) => doktor5000

claire robinson 2014-09-08 17:32:52 CEST

Blocks: (none) => 14069

Comment 25 Dick Gevers 2014-11-15 12:23:20 CET
Old installers wont be changed.

Valid for M5B1, as seen with LiveCD KDE (Gnome one not working for me as per errata).
Missing same countries as aforementioned.

Whiteboard: MGA2TOO 3final 4RC => 5beta1

Comment 26 Rémi Verschelde 2015-03-29 22:40:11 CEST
(In reply to Florian Hubold from comment #24)
> (In reply to Thomas Backlund from comment #22)
> > I was thinking of trying to add all locales-* to livecds too
> 
> Maybe you can try that with next rounds of mga5 images?

That would only be a fix for the live ISO, but hopefully all those locales would not be installed on the system, and the bug would remain on installed systems AFAIU.

It seems to me that to fix this bug the available countries should be split out of the locales-<lang> packages, and localedrake should require the installation of the needed locales-<lang> package depending on the chosen country.

I don't have much hope that this will get fixed for Mageia 5 though, and we're struggling with the other blockers, so I move this one to the Mageia 6 tracker. It can be fixed after the release via an update btw (at least the post-install configuration issue).

CC: (none) => remi
Blocks: 14069, 11704 => 15527

Samuel Verschelde 2015-06-02 10:02:55 CEST

Target Milestone: --- => Mageia 6
Whiteboard: 5beta1 => MGA5TOO FOR_ERRATA

Samuel Verschelde 2015-06-02 10:05:11 CEST

Component: Installer => RPM Packages

Comment 27 Marja Van Waes 2016-07-10 13:19:06 CEST
(In reply to Rémi Verschelde from comment #26)

> 
> I don't have much hope that this will get fixed for Mageia 5 though, and
> we're struggling with the other blockers, so I move this one to the Mageia 6
> tracker. It can be fixed after the release via an update btw (at least the
> post-install configuration issue).

I think this one should be removed from the Mga6 tracker (with many more old bugs)

What about moving them to a Mageia7 "Nice to finally get this fixed" tracker?
Comment 28 Rémi Verschelde 2016-07-11 10:34:26 CEST
(In reply to Marja van Waes from comment #27)
> I think this one should be removed from the Mga6 tracker (with many more old
> bugs)
> 
> What about moving them to a Mageia7 "Nice to finally get this fixed" tracker?

Sounds good to me :) Such a tracker could be used during the preparation of the proposed features for Mageia 7.
Marja Van Waes 2016-07-12 16:52:33 CEST

Blocks: 15527 => 18932

Comment 29 Samuel Verschelde 2016-10-10 22:08:26 CEST
(In reply to Rémi Verschelde from comment #28)
> Sounds good to me :) Such a tracker could be used during the preparation of
> the proposed features for Mageia 7.

As bugsquad co-leader, I'm currently advocating against such trackers and for the proper use of the Milestone field instead. Setting milestone to Mageia 7.

Assignee: mageia => mageiatools
Target Milestone: Mageia 6 => Mageia 7

Samuel Verschelde 2016-10-10 22:08:46 CEST

Whiteboard: MGA5TOO FOR_ERRATA => MGA5TOO FOR_ERRATA MGA6TOO FOR_ERRATA6

Samuel Verschelde 2016-10-18 13:02:04 CEST

Whiteboard: MGA5TOO FOR_ERRATA MGA6TOO FOR_ERRATA6 => MGA5TOO MGA6TOO
Keywords: (none) => FOR_ERRATA5, FOR_ERRATA6

Samuel Verschelde 2016-11-10 10:36:01 CET

Blocks: 18932 => (none)

Comment 30 Dick Gevers 2019-05-18 13:21:24 CEST
M7 RC: 

Live isos does not ask country during install and afterwards I see all countries that were missing earlier as available.

So IMHO no use to keep this bug open.
If anyone disagrees it can be reopened...

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.