Bug 10312 - Terminology can't start
Summary: Terminology can't start
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 3
Hardware: i586 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: mga3-32-ok mga3-64-ok
Keywords: Triaged, validated_update
Depends on:
Blocks:
 
Reported: 2013-05-27 11:07 CEST by Sandro Cazzaniga
Modified: 2013-08-17 10:37 CEST (History)
6 users (show)

See Also:
Source RPM: terminology-0.2.0-2.mga3
CVE:
Status comment:


Attachments

Description Sandro Cazzaniga 2013-05-27 11:07:25 CEST
Description of problem:
Terminology cannot start because of a theme problem, it seems.

Version-Release number of selected component (if applicable):
0.2.0

Steps to Reproduce:
1. install terminoology via urpmi or rpmdrake
2. try to launch terminology into a terminal to see the error message:

CRI<20719>:elementary elm_win.c:2366 elm_win_add() Software X11 engine creation failed. Trying default.
ERR<20719>:elementary elm_win.c:2551 elm_win_add() Cannot create window.
ERR<20719>: elm_conform.c:571 elm_conformant_add() safety check failed: parent == NULL
ERR<20719>: utils.c:13 theme_apply() safety check failed: edje == NULL
CRI<20719>:terminology main.c:673 elm_main() Couldn't find terminology theme! Forgot 'make install'?



Reproducible: 

Steps to Reproduce:
Comment 1 Hook 2013-08-14 13:30:20 CEST
It seems not all dependencies are listed in the package.

A workaround is to install full Enlightment.

CC: (none) => matija

Manuel Hiebel 2013-08-15 00:10:18 CEST

Keywords: (none) => Triaged

Comment 2 trem 2013-08-15 15:22:26 CEST
I've looked for missing dependancy, and I've found two packages:
- evas
- elementary

With both dependancies, I can run terminology without installing all e17.
Comment 3 trem 2013-08-15 15:34:14 CEST
I have uploaded a patched/updated package for Mageia 2.

You can test it with the folling command :
- urpme libeina1 (remove almost all e17 package)
- urpmi terminology (install only terminology)
- terminology (run it)
then terminology should start 

Updated packages in core/updates_testing:
========================
terminology-0.2.0-3.mga3
terminology-debuginfo-0.2.0-3.mga3

Source RPMs: 
terminology-0.2.0-3.mga3
trem 2013-08-15 15:34:50 CEST

Assignee: tremyfr => qa-bugs

Comment 4 claire robinson 2013-08-15 18:01:04 CEST
(In reply to trem from comment #3)
> I have uploaded a patched/updated package for Mageia 2.

Is 2 updated aswell trem or did you mean Mageia 3 here?
Comment 5 Dave Hodgins 2013-08-16 05:06:11 CEST
Advisory 10312.adv uploaded to svn, assuming it's for 3 only.

CC: (none) => davidwhodgins

Comment 6 bozonius 2013-08-16 05:16:21 CEST
Testing i586 and x86_64 on Mga3.

CC: (none) => bozonius

Comment 7 bozonius 2013-08-16 13:13:52 CEST
After applying the testing update, the program appears to start as expected, but it issues what look like might be error messages on every individual motion or keypress.  I attempted to look up the indicated number on their bug tracking system, but can not find a bug number that high.  There was a version control changeset with that number, though.  Claire has recommended a bug to clean up these entrails.

So far, I have applied the update to i586.
Comment 8 William Kenney 2013-08-16 17:10:59 CEST
MGA3-64-OK for me

in VirtualBox

default install terminology-0.2.0-2.mga3.x86_64 from core release
[root@localhost wilcal]# urpmi terminology
Package terminology-0.2.0-2.mga3.x86_64 is already installed

Recreated error messages referred to in Description

install terminology-0.2.0-3.mga3.x86_64 from core updates_testing
[root@localhost wilcal]# urpmi terminology
Package terminology-0.2.0-3.mga3.x86_64 is already installed
Relaunch terminology from Menu, launched ok
Launch terminology from a terminal and that's fine too.

Test platform:
Intel Core i7-2600K Sandy Bridge 3.4GHz
GIGABYTE GA-Z68X-UD3-B3 LGA 1155 MoBo
GIGABYTE GV-N440D3-1GI Nvidia GeForce GT 440 (Fermi) 1GB
RTL8111/8168B PCI Express 1Gbit Ethernet
DRAM 16GB (4 x 4GB)
VirtualBox 4.2.16-1.mga3.x86_64.rpm

CC: (none) => wilcal.int
Whiteboard: (none) => MGA3-64-OK

Comment 9 William Kenney 2013-08-16 17:28:53 CEST
MGA3-32 ok for me

in VirtualBox

default install terminology-0.2.0-2.mga3.i586 from core release
[root@localhost wilcal]# urpmi terminology
Package terminology-0.2.0-2.mga3.i586 is already installed

Recreated error messages referred to in Description

install terminology-0.2.0-3.mga3.i586 from core updates_testing
[root@localhost wilcal]# urpmi terminology
Package terminology-0.2.0-3.mga3.i586 is already installed
Relaunch terminology from Menu, launched ok
Launch terminology from a terminal and that's fine too.

Test platform:
Intel Core i7-2600K Sandy Bridge 3.4GHz
GIGABYTE GA-Z68X-UD3-B3 LGA 1155 MoBo
GIGABYTE GV-N440D3-1GI Nvidia GeForce GT 440 (Fermi) 1GB
RTL8111/8168B PCI Express 1Gbit Ethernet
DRAM 16GB (4 x 4GB)
VirtualBox 4.2.16-1.mga3.x86_64.rpm

Whiteboard: MGA3-64-OK => MGA3-32-OK MGA3-64-OK

Comment 10 William Kenney 2013-08-16 17:30:51 CEST
Validating the update.
Could someone from the sysadmin team push 10312.adv to updates.

ready for validation

Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Comment 11 bozonius 2013-08-16 19:48:22 CEST
While confirming the defect on x86_64, the errors listed while starting terminology on x86_64 seems to be different; the program does not launch as expected.  

After testing update is applied, the program works.  It also spits out a trace indicating a different (changeset?) number than the i586 version, but it appears to behave the same way, tracing each keyclick or mouse movement.  

Bug 11021 has been filed against this other issue.

Keywords: validated_update => (none)
Whiteboard: MGA3-32-OK MGA3-64-OK => (none)

Comment 12 bozonius 2013-08-16 20:10:44 CEST
Validated the update.

Since the bug has been requested for push already, I will not duplicate the effort.
claire robinson 2013-08-16 20:20:12 CEST

Keywords: (none) => validated_update
Whiteboard: (none) => mga3-32-ok mga3-64-ok

Comment 13 Thomas Backlund 2013-08-17 10:37:05 CEST
Update pushed:
http://advisories.mageia.org/MGAA-2013-0087.html

Status: NEW => RESOLVED
CC: (none) => tmb
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.